Every CVE Search/ Get API key

CVE-2005-4816

Buffer overflow in mod_radius in ProFTPD before 1.3.0rc2 allows remote attackers to cause a...

7.5 HighFix available

Buffer overflow in mod_radius in ProFTPD before 1.3.0rc2 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a long password.

Exploit likelihood

12.8%Up 8.5 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Buffer overflow in mod_radius in ProFTPD before 1.3.0rc2 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a long password.

Record
CVE-2005-4816
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Updated
2026-11-02
CVE List No score

Buffer overflow in mod_radius in ProFTPD before 1.3.0rc2 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a long password.

Record
CVE-2005-4816
Updated
2026-11-02
EUVDEUVD-2005-4809 No score

Buffer overflow in mod_radius in ProFTPD before 1.3.0rc2 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a long password.

Record
EUVD-2005-4809
Updated
2026-11-03
GitHub AdvisoriesGHSA-2q4g-fw9r-2xxm No score

Buffer overflow in mod_radius in ProFTPD before 1.3.0rc2 allows remote attackers to cause a...

Buffer overflow in mod_radius in ProFTPD before 1.3.0rc2 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a long password.

Record
GHSA-2q4g-fw9r-2xxm
Updated
2026-11-02
OSV No score

Buffer overflow in mod_radius in ProFTPD before 1.3.0rc2 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a long password.

Record
CVE-2005-4816
Updated
2026-11-02
OSVDEBIAN-CVE-2005-4816 No score

Buffer overflow in mod_radius in ProFTPD before 1.3.0rc2 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a long password.

Record
DEBIAN-CVE-2005-4816
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
proftpd-dfsg
Debian:12
before 1.2.10+1.3.0rc5-1
1.2.10+1.3.0rc5-1
proftpd-dfsg
Debian:13
before 1.2.10+1.3.0rc5-1
1.2.10+1.3.0rc5-1
proftpd-dfsg
Debian:14
before 1.2.10+1.3.0rc5-1
1.2.10+1.3.0rc5-1
proftpd
Debian:3.1
before 1.2.10-15sarge4, plus listed versions
1.2.10-151.2.10-15sarge11.2.10-15sarge1.0.11.2.10-15sarge21.2.10-15sarge3
1.2.10-15sarge4

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2005-4816 is a high vulnerability (CVSS 7.5) in Proftpd Project Proftpd, published December 31, 2005. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 12.8%, the 96th percentile. Fixed in proftpd-dfsg 1.2.10+1.3.0rc5-1.

References

MoveEnter Open