CVE-2005-4816
Buffer overflow in mod_radius in ProFTPD before 1.3.0rc2 allows remote attackers to cause a...
Buffer overflow in mod_radius in ProFTPD before 1.3.0rc2 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a long password.
Exploit likelihood
What each source reports
NVD Score used
7.5
Buffer overflow in mod_radius in ProFTPD before 1.3.0rc2 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a long password.
- Record
CVE-2005-4816- CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Updated
- 2026-11-02
CVE List No score
Buffer overflow in mod_radius in ProFTPD before 1.3.0rc2 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a long password.
- Record
CVE-2005-4816- Updated
- 2026-11-02
EUVDEUVD-2005-4809 No score
Buffer overflow in mod_radius in ProFTPD before 1.3.0rc2 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a long password.
- Record
EUVD-2005-4809- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-2q4g-fw9r-2xxm No score
Buffer overflow in mod_radius in ProFTPD before 1.3.0rc2 allows remote attackers to cause a...
Buffer overflow in mod_radius in ProFTPD before 1.3.0rc2 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a long password.
- Record
GHSA-2q4g-fw9r-2xxm- Updated
- 2026-11-02
OSV No score
Buffer overflow in mod_radius in ProFTPD before 1.3.0rc2 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a long password.
- Record
CVE-2005-4816- Updated
- 2026-11-02
OSVDEBIAN-CVE-2005-4816 No score
Buffer overflow in mod_radius in ProFTPD before 1.3.0rc2 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a long password.
- Record
DEBIAN-CVE-2005-4816- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
proftpd-dfsgDebian:12 |
before 1.2.10+1.3.0rc5-1 | 1.2.10+1.3.0rc5-1 |
proftpd-dfsgDebian:13 |
before 1.2.10+1.3.0rc5-1 | 1.2.10+1.3.0rc5-1 |
proftpd-dfsgDebian:14 |
before 1.2.10+1.3.0rc5-1 | 1.2.10+1.3.0rc5-1 |
proftpdDebian:3.1 |
before 1.2.10-15sarge4, plus listed versions 1.2.10-151.2.10-15sarge11.2.10-15sarge1.0.11.2.10-15sarge21.2.10-15sarge3 |
1.2.10-15sarge4 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2005-4816 is a high vulnerability (CVSS 7.5) in Proftpd Project Proftpd, published December 31, 2005. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 12.8%, the 96th percentile. Fixed in proftpd-dfsg 1.2.10+1.3.0rc5-1.