Every CVE Search/ Get API key

CVE-2017-1000480

Smarty PHP code injection

9.8 CriticalFix available

Smarty 3 before 3.1.32 is vulnerable to a PHP code injection when calling fetch() or display() functions on custom resources that does not sanitize template name.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

3.12%Up 2.1 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 9.8

Smarty 3 before 3.1.32 is vulnerable to a PHP code injection when calling fetch() or display() functions on custom resources that does not sanitize template name.

Record
CVE-2017-1000480
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-94
Updated
2026-11-02
CVE List No score

Smarty 3 before 3.1.32 is vulnerable to a PHP code injection when calling fetch() or display() functions on custom resources that does not sanitize template name.

Record
CVE-2017-1000480
Updated
2026-11-02
EUVDEUVD-2022-3409 No score

Smarty 3 before 3.1.32 is vulnerable to a PHP code injection when calling fetch() or display() functions on custom resources that does not sanitize template name.

Record
EUVD-2022-3409
Updated
2026-11-03
GitHub AdvisoriesGHSA-9m49-vhwv-422g 9.8

Smarty PHP code injection

Smarty 3 before 3.1.32 is vulnerable to a PHP code injection when calling fetch() or display() functions on custom resources that does not sanitize template name.

Record
GHSA-9m49-vhwv-422g
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-94
Updated
2026-11-02
OSV 9.8

Smarty 3 before 3.1.32 is vulnerable to a PHP code injection when calling fetch() or display() functions on custom resources that does not sanitize template name.

Record
CVE-2017-1000480
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2017-1000480 9.8

Smarty 3 before 3.1.32 is vulnerable to a PHP code injection when calling fetch() or display() functions on custom resources that does not sanitize template name.

Record
DEBIAN-CVE-2017-1000480
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVGHSA-9m49-vhwv-422g 9.8

Smarty PHP code injection

Smarty 3 before 3.1.32 is vulnerable to a PHP code injection when calling fetch() or display() functions on custom resources that does not sanitize template name.

Record
GHSA-9m49-vhwv-422g
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-94
Updated
2026-11-02
OSVUBUNTU-CVE-2017-1000480 9.8

Smarty 3 before 3.1.32 is vulnerable to a PHP code injection when calling fetch() or display() functions on custom resources that does not sanitize template name.

Record
UBUNTU-CVE-2017-1000480
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2018-0118 No score

Updated php-smarty packages fix security vulnerability

Smarty 3 before 3.1.32 is vulnerable to a PHP code injection when calling fetch() or display() functions on custom resources that does not sanitize template name(CVE-2017-1000480).

Record
MGASA-2018-0118
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
smarty/smarty
Packagist
3 up to 3.1.32
3.1.32
smarty3
Debian:12
before 3.1.31+20161214.1.c7d42e4+selfpack1-3
3.1.31+20161214.1.c7d42e4+selfpack1-3
smarty3
Debian:13
before 3.1.31+20161214.1.c7d42e4+selfpack1-3
3.1.31+20161214.1.c7d42e4+selfpack1-3
smarty3
Debian:14
before 3.1.31+20161214.1.c7d42e4+selfpack1-3
3.1.31+20161214.1.c7d42e4+selfpack1-3
smarty3
Debian:7
before 3.1.10-2+deb7u2, plus listed versions
3.1.10-23.1.10-2+deb7u1
3.1.10-2+deb7u2
smarty3
Debian:8
before 3.1.21-1+deb8u1, plus listed versions
3.1.21-1
3.1.21-1+deb8u1
smarty3
Debian:9
before 3.1.31+20161214.1.c7d42e4+selfpack1-2+deb9u1, plus listed versions
3.1.31+20161214.1.c7d42e4+selfpack1-2
3.1.31+20161214.1.c7d42e4+selfpack1-2+deb9u1
smarty/smarty
Packagist
3 up to 3.1.32, plus listed versions
v3.1.11v3.1.12v3.1.13v3.1.14v3.1.15
Show 15 moreShow less
v3.1.16v3.1.17v3.1.18v3.1.19v3.1.20v3.1.21v3.1.23v3.1.24v3.1.25v3.1.26v3.1.27v3.1.28v3.1.29v3.1.30v3.1.31
3.1.32
php-smarty
Mageia:5
before 3.1.21-1.1.mga5
3.1.21-1.1.mga5
php-smarty
Mageia:6
before 3.1.21-3.1.mga6
3.1.21-3.1.mga6
smarty3
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
3.1.21-13.1.21-1ubuntu13.1.21-1ubuntu1+esm13.1.21-1ubuntu1+esm2
None known
smarty3
Ubuntu:18.04:LTS
before 3.1.31+20161214.1.c7d42e4+selfpack1-3, plus listed versions
3.1.31+20161214.1.c7d42e4+selfpack1-2
3.1.31+20161214.1.c7d42e4+selfpack1-3

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-1000480 is a critical vulnerability (CVSS 9.8) in Smarty, published January 3, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.12%, the 87th percentile. Fixed in smarty/smarty 3.1.32.

References

Show 7 moreShow less
MoveEnter Open