Every CVE Search/ Get API key

CVE-2004-1177

mailman Cross-site scripting (XSS) vulnerability

4.3 MediumFix available

Cross-site scripting (XSS) vulnerability in the driver script in mailman before 2.1.5 allows remote attackers to inject arbitrary web script or HTML via a URL, which is not properly escaped in the resulting error page.

Exploit likelihood

1.80%Unchanged since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.3

Cross-site scripting (XSS) vulnerability in the driver script in mailman before 2.1.5 allows remote attackers to inject arbitrary web script or HTML via a URL, which is not properly escaped in the resulting error page.

Record
CVE-2004-1177
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Updated
2026-11-02
CVE List No score

Cross-site scripting (XSS) vulnerability in the driver script in mailman before 2.1.5 allows remote attackers to inject arbitrary web script or HTML via a URL, which is not properly escaped in the resulting error page.

Record
CVE-2004-1177
Updated
2026-11-02
EUVDEUVD-2022-1824 No score

Cross-site scripting (XSS) vulnerability in the driver script in mailman before 2.1.5 allows remote attackers to inject arbitrary web script or HTML via a URL, which is not properly escaped in the resulting error page.

Record
EUVD-2022-1824
Updated
2026-11-03
GitHub AdvisoriesGHSA-rh6c-jh4c-9fg3 No score

mailman Cross-site scripting (XSS) vulnerability

Cross-site scripting (XSS) vulnerability in the driver script in mailman before 2.1.5 allows remote attackers to inject arbitrary web script or HTML via a URL, which is not properly escaped in the resulting error page.

Record
GHSA-rh6c-jh4c-9fg3
Weakness
CWE-79
Updated
2026-11-02
OSVGHSA-rh6c-jh4c-9fg3 No score

mailman Cross-site scripting (XSS) vulnerability

Cross-site scripting (XSS) vulnerability in the driver script in mailman before 2.1.5 allows remote attackers to inject arbitrary web script or HTML via a URL, which is not properly escaped in the resulting error page.

Record
GHSA-rh6c-jh4c-9fg3
Weakness
CWE-79
Updated
2026-11-02
OSVPYSEC-2026-659 No score

mailman Cross-site scripting (XSS) vulnerability

Cross-site scripting (XSS) vulnerability in the driver script in mailman before 2.1.5 allows remote attackers to inject arbitrary web script or HTML via a URL, which is not properly escaped in the resulting error page.

Record
PYSEC-2026-659
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
mailman
PyPI
before 2.1.5
2.1.5
mailman
Debian:3.0
before 2.0.11-1woody11, plus listed versions
2.0.11-1woody8
2.0.11-1woody11
mailman
PyPI
before 2.1.5, plus listed versions
3.0.0b3-
2.1.5
mailman
Red Hat:enterprise_linux:3::as
before 3:2.1.5-25.rhel3
3:2.1.5-25.rhel3
mailman-debuginfo
Red Hat:enterprise_linux:3::as
before 3:2.1.5-25.rhel3
3:2.1.5-25.rhel3
mailman
Red Hat:enterprise_linux:3::desktop
before 3:2.1.5-25.rhel3
3:2.1.5-25.rhel3
mailman-debuginfo
Red Hat:enterprise_linux:3::desktop
before 3:2.1.5-25.rhel3
3:2.1.5-25.rhel3
mailman
Red Hat:enterprise_linux:3::es
before 3:2.1.5-25.rhel3
3:2.1.5-25.rhel3
mailman-debuginfo
Red Hat:enterprise_linux:3::es
before 3:2.1.5-25.rhel3
3:2.1.5-25.rhel3
mailman
Red Hat:enterprise_linux:3::ws
before 3:2.1.5-25.rhel3
3:2.1.5-25.rhel3
Show 9 moreShow less
Affected packages
PackageAffectedFixed
mailman-debuginfo
Red Hat:enterprise_linux:3::ws
before 3:2.1.5-25.rhel3
3:2.1.5-25.rhel3
mailman
Red Hat:enterprise_linux:4::as
before 3:2.1.5-33.rhel4
3:2.1.5-33.rhel4
mailman-debuginfo
Red Hat:enterprise_linux:4::as
before 3:2.1.5-33.rhel4
3:2.1.5-33.rhel4
mailman
Red Hat:enterprise_linux:4::desktop
before 3:2.1.5-33.rhel4
3:2.1.5-33.rhel4
mailman-debuginfo
Red Hat:enterprise_linux:4::desktop
before 3:2.1.5-33.rhel4
3:2.1.5-33.rhel4
mailman
Red Hat:enterprise_linux:4::es
before 3:2.1.5-33.rhel4
3:2.1.5-33.rhel4
mailman-debuginfo
Red Hat:enterprise_linux:4::es
before 3:2.1.5-33.rhel4
3:2.1.5-33.rhel4
mailman
Red Hat:enterprise_linux:4::ws
before 3:2.1.5-33.rhel4
3:2.1.5-33.rhel4
mailman-debuginfo
Red Hat:enterprise_linux:4::ws
before 3:2.1.5-33.rhel4
3:2.1.5-33.rhel4

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2004-1177 is a medium vulnerability (CVSS 4.3) in Gnu Mailman, published January 10, 2005. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.80%, the 78th percentile. Fixed in mailman 2.1.5.

References

Show 17 moreShow less
MoveEnter Open