CVE-2004-1177
mailman Cross-site scripting (XSS) vulnerability
Cross-site scripting (XSS) vulnerability in the driver script in mailman before 2.1.5 allows remote attackers to inject arbitrary web script or HTML via a URL, which is not properly escaped in the resulting error page.
Exploit likelihood
What each source reports
NVD Score used
4.3
Cross-site scripting (XSS) vulnerability in the driver script in mailman before 2.1.5 allows remote attackers to inject arbitrary web script or HTML via a URL, which is not properly escaped in the resulting error page.
- Record
CVE-2004-1177- CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Updated
- 2026-11-02
CVE List No score
Cross-site scripting (XSS) vulnerability in the driver script in mailman before 2.1.5 allows remote attackers to inject arbitrary web script or HTML via a URL, which is not properly escaped in the resulting error page.
- Record
CVE-2004-1177- Updated
- 2026-11-02
EUVDEUVD-2022-1824 No score
Cross-site scripting (XSS) vulnerability in the driver script in mailman before 2.1.5 allows remote attackers to inject arbitrary web script or HTML via a URL, which is not properly escaped in the resulting error page.
- Record
EUVD-2022-1824- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-rh6c-jh4c-9fg3 No score
mailman Cross-site scripting (XSS) vulnerability
Cross-site scripting (XSS) vulnerability in the driver script in mailman before 2.1.5 allows remote attackers to inject arbitrary web script or HTML via a URL, which is not properly escaped in the resulting error page.
- Record
GHSA-rh6c-jh4c-9fg3- Weakness
- CWE-79
- Updated
- 2026-11-02
OSVGHSA-rh6c-jh4c-9fg3 No score
mailman Cross-site scripting (XSS) vulnerability
Cross-site scripting (XSS) vulnerability in the driver script in mailman before 2.1.5 allows remote attackers to inject arbitrary web script or HTML via a URL, which is not properly escaped in the resulting error page.
- Record
GHSA-rh6c-jh4c-9fg3- Weakness
- CWE-79
- Updated
- 2026-11-02
OSVPYSEC-2026-659 No score
mailman Cross-site scripting (XSS) vulnerability
Cross-site scripting (XSS) vulnerability in the driver script in mailman before 2.1.5 allows remote attackers to inject arbitrary web script or HTML via a URL, which is not properly escaped in the resulting error page.
- Record
PYSEC-2026-659- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
mailmanPyPI |
before 2.1.5 | 2.1.5 |
mailmanDebian:3.0 |
before 2.0.11-1woody11, plus listed versions 2.0.11-1woody8 |
2.0.11-1woody11 |
mailmanPyPI |
before 2.1.5, plus listed versions 3.0.0b3- |
2.1.5 |
mailmanRed Hat:enterprise_linux:3::as |
before 3:2.1.5-25.rhel3 | 3:2.1.5-25.rhel3 |
mailman-debuginfoRed Hat:enterprise_linux:3::as |
before 3:2.1.5-25.rhel3 | 3:2.1.5-25.rhel3 |
mailmanRed Hat:enterprise_linux:3::desktop |
before 3:2.1.5-25.rhel3 | 3:2.1.5-25.rhel3 |
mailman-debuginfoRed Hat:enterprise_linux:3::desktop |
before 3:2.1.5-25.rhel3 | 3:2.1.5-25.rhel3 |
mailmanRed Hat:enterprise_linux:3::es |
before 3:2.1.5-25.rhel3 | 3:2.1.5-25.rhel3 |
mailman-debuginfoRed Hat:enterprise_linux:3::es |
before 3:2.1.5-25.rhel3 | 3:2.1.5-25.rhel3 |
mailmanRed Hat:enterprise_linux:3::ws |
before 3:2.1.5-25.rhel3 | 3:2.1.5-25.rhel3 |
Show 9 moreShow less
| Package | Affected | Fixed |
|---|---|---|
mailman-debuginfoRed Hat:enterprise_linux:3::ws |
before 3:2.1.5-25.rhel3 | 3:2.1.5-25.rhel3 |
mailmanRed Hat:enterprise_linux:4::as |
before 3:2.1.5-33.rhel4 | 3:2.1.5-33.rhel4 |
mailman-debuginfoRed Hat:enterprise_linux:4::as |
before 3:2.1.5-33.rhel4 | 3:2.1.5-33.rhel4 |
mailmanRed Hat:enterprise_linux:4::desktop |
before 3:2.1.5-33.rhel4 | 3:2.1.5-33.rhel4 |
mailman-debuginfoRed Hat:enterprise_linux:4::desktop |
before 3:2.1.5-33.rhel4 | 3:2.1.5-33.rhel4 |
mailmanRed Hat:enterprise_linux:4::es |
before 3:2.1.5-33.rhel4 | 3:2.1.5-33.rhel4 |
mailman-debuginfoRed Hat:enterprise_linux:4::es |
before 3:2.1.5-33.rhel4 | 3:2.1.5-33.rhel4 |
mailmanRed Hat:enterprise_linux:4::ws |
before 3:2.1.5-33.rhel4 | 3:2.1.5-33.rhel4 |
mailman-debuginfoRed Hat:enterprise_linux:4::ws |
before 3:2.1.5-33.rhel4 | 3:2.1.5-33.rhel4 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2004-1177 is a medium vulnerability (CVSS 4.3) in Gnu Mailman, published January 10, 2005. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.80%, the 78th percentile. Fixed in mailman 2.1.5.
References
marc.info?l=bugtraq&m=110549296126351&w=2
exchange.xforce.ibmcloud.com/vulnerabilities/18854
bugs.debian.org/cgi-bin/bugreport.cgi?bug=287555
secunia.com/advisories/13603
mandriva.com/security/advisories?name=MDKSA-2005:015
novell.com/linux/security/advisories/2005_07_mailman.html
Show 17 moreShow less
debian.org/security/2005/dsa-674
redhat.com/support/errata/RHSA-2005-235.html
oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A11113
nvd.nist.gov/vuln/detail/CVE-2004-1177
github.com/advisories/GHSA-rh6c-jh4c-9fg3
github.com/terencehonles/mailman
pypi.org/project/mailman
access.redhat.com/errata/RHSA-2005:235
access.redhat.com/security/updates/classification
bugzilla.redhat.com/show_bug.cgi?id=132750
bugzilla.redhat.com/show_bug.cgi?id=142605
bugzilla.redhat.com/show_bug.cgi?id=143008
bugzilla.redhat.com/show_bug.cgi?id=147833
security.access.redhat.com/data/csaf/v2/advisories/2005/rhsa-2005_235.json
access.redhat.com/security/cve/CVE-2004-1177
bugzilla.redhat.com/show_bug.cgi?id=1617389
cve.org/CVERecord?id=CVE-2004-1177