Every CVE Search/ Get API key

CVE-2005-1854

Unknown vulnerability in apt-cacher in Debian 3.1, related to "missing input sanitising," allows...

7.5 HighFix available

Unknown vulnerability in apt-cacher in Debian 3.1, related to "missing input sanitising," allows remote attackers to execute arbitrary commands on the caching server.

Exploit likelihood

2.13%Up 0.9 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Unknown vulnerability in apt-cacher in Debian 3.1, related to "missing input sanitising," allows remote attackers to execute arbitrary commands on the caching server.

Record
CVE-2005-1854
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Updated
2026-11-02
CVE List No score

Unknown vulnerability in apt-cacher in Debian 3.1, related to "missing input sanitising," allows remote attackers to execute arbitrary commands on the caching server.

Record
CVE-2005-1854
Updated
2026-11-02
EUVDEUVD-2005-1856 No score

Unknown vulnerability in apt-cacher in Debian 3.1, related to "missing input sanitising," allows remote attackers to execute arbitrary commands on the caching server.

Record
EUVD-2005-1856
Updated
2026-11-03
GitHub AdvisoriesGHSA-9wxh-35jp-39hr No score

Unknown vulnerability in apt-cacher in Debian 3.1, related to "missing input sanitising," allows...

Unknown vulnerability in apt-cacher in Debian 3.1, related to "missing input sanitising," allows remote attackers to execute arbitrary commands on the caching server.

Record
GHSA-9wxh-35jp-39hr
Updated
2026-11-02
OSV No score

Unknown vulnerability in apt-cacher in Debian 3.1, related to "missing input sanitising," allows remote attackers to execute arbitrary commands on the caching server.

Record
CVE-2005-1854
Updated
2026-11-02
OSVDEBIAN-CVE-2005-1854 No score

Unknown vulnerability in apt-cacher in Debian 3.1, related to "missing input sanitising," allows remote attackers to execute arbitrary commands on the caching server.

Record
DEBIAN-CVE-2005-1854
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
apt-cacher
Debian:12
before 0.9.10
0.9.10
apt-cacher
Debian:13
before 0.9.10
0.9.10
apt-cacher
Debian:14
before 0.9.10
0.9.10
apt-cacher
Debian:3.1
before 0.9.4sarge1, plus listed versions
0.9.4
0.9.4sarge1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2005-1854 is a high vulnerability (CVSS 7.5) in Debian Apt-cacher, published August 3, 2005. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.13%, the 82nd percentile. Fixed in apt-cacher 0.9.10.

References

MoveEnter Open