CVE-2005-1857
Format string vulnerability in simpleproxy before 3.4 allows remote malicious HTTP proxies to...
Format string vulnerability in simpleproxy before 3.4 allows remote malicious HTTP proxies to execute arbitrary code via format string specifiers in a reply.
Exploit likelihood
What each source reports
NVD Score used
7.5
Format string vulnerability in simpleproxy before 3.4 allows remote malicious HTTP proxies to execute arbitrary code via format string specifiers in a reply.
- Record
CVE-2005-1857- CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Updated
- 2026-11-02
CVE List No score
Format string vulnerability in simpleproxy before 3.4 allows remote malicious HTTP proxies to execute arbitrary code via format string specifiers in a reply.
- Record
CVE-2005-1857- Updated
- 2026-11-02
EUVDEUVD-2005-1859 No score
Format string vulnerability in simpleproxy before 3.4 allows remote malicious HTTP proxies to execute arbitrary code via format string specifiers in a reply.
- Record
EUVD-2005-1859- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-xp5q-vpr4-hc8h No score
Format string vulnerability in simpleproxy before 3.4 allows remote malicious HTTP proxies to...
Format string vulnerability in simpleproxy before 3.4 allows remote malicious HTTP proxies to execute arbitrary code via format string specifiers in a reply.
- Record
GHSA-xp5q-vpr4-hc8h- Updated
- 2026-11-02
OSV No score
Format string vulnerability in simpleproxy before 3.4 allows remote malicious HTTP proxies to execute arbitrary code via format string specifiers in a reply.
- Record
CVE-2005-1857- Updated
- 2026-11-02
OSVDEBIAN-CVE-2005-1857 No score
Format string vulnerability in simpleproxy before 3.4 allows remote malicious HTTP proxies to execute arbitrary code via format string specifiers in a reply.
- Record
DEBIAN-CVE-2005-1857- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
simpleproxyDebian:12 |
before 3.2-4 | 3.2-4 |
simpleproxyDebian:14 |
before 3.2-4, plus listed versions 3.2-33.2-3sarge1 |
3.2-4 |
simpleproxyDebian:3.1 |
before 3.2-3sarge1, plus listed versions 3.2-3 |
3.2-3sarge1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2005-1857 is a high vulnerability (CVSS 7.5) in Simpleproxy, published August 26, 2005. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.32%, the 91st percentile. Fixed in simpleproxy 3.2-4.
References
kb.cert.org/vuls/id/139421
secunia.com/advisories/16567
exchange.xforce.ibmcloud.com/vulnerabilities/22016
debian.org/security/2005/dsa-786
securityfocus.com/bid/14666
sourceforge.net/project/shownotes.php?group_id=604&release_id=351847
nvd.nist.gov/vuln/detail/CVE-2005-1857
github.com/advisories/GHSA-xp5q-vpr4-hc8h
security-tracker.debian.org/tracker/CVE-2005-1857