Every CVE Search/ Get API key

CVE-2005-2532

OpenVPN before 2.0.1 does not properly flush the OpenSSL error queue when a packet can not be...

5.0 MediumFix available

OpenVPN before 2.0.1 does not properly flush the OpenSSL error queue when a packet can not be decrypted by the server, which allows remote authenticated attackers to cause a denial of service (client disconnection) via a large number of packets that can not be decrypted.

Exploit likelihood

2.74%Up 1.4 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

OpenVPN before 2.0.1 does not properly flush the OpenSSL error queue when a packet can not be decrypted by the server, which allows remote authenticated attackers to cause a denial of service (client disconnection) via a large number of packets that can not be decrypted.

Record
CVE-2005-2532
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Updated
2026-11-02
CVE List No score

OpenVPN before 2.0.1 does not properly flush the OpenSSL error queue when a packet can not be decrypted by the server, which allows remote authenticated attackers to cause a denial of service (client disconnection) via a large number of packets that can not be decrypted.

Record
CVE-2005-2532
Updated
2026-11-02
EUVDEUVD-2005-2533 No score

OpenVPN before 2.0.1 does not properly flush the OpenSSL error queue when a packet can not be decrypted by the server, which allows remote authenticated attackers to cause a denial of service (client disconnection) via a large number of packets that can not be decrypted.

Record
EUVD-2005-2533
Updated
2026-11-03
GitHub AdvisoriesGHSA-86x4-whvc-8cfg No score

OpenVPN before 2.0.1 does not properly flush the OpenSSL error queue when a packet can not be...

OpenVPN before 2.0.1 does not properly flush the OpenSSL error queue when a packet can not be decrypted by the server, which allows remote authenticated attackers to cause a denial of service (client disconnection) via a large number of packets that can not be decrypted.

Record
GHSA-86x4-whvc-8cfg
Updated
2026-11-02
OSV No score

OpenVPN before 2.0.1 does not properly flush the OpenSSL error queue when a packet can not be decrypted by the server, which allows remote authenticated attackers to cause a denial of service (client disconnection) via a large number of packets that can not be decrypted.

Record
CVE-2005-2532
Updated
2026-11-02
OSVDEBIAN-CVE-2005-2532 No score

OpenVPN before 2.0.1 does not properly flush the OpenSSL error queue when a packet can not be decrypted by the server, which allows remote authenticated attackers to cause a denial of service (client disconnection) via a large number of packets that can not be decrypted.

Record
DEBIAN-CVE-2005-2532
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
openvpn
Debian:12
before 2.0.2-1
2.0.2-1
openvpn
Debian:13
before 2.0.2-1
2.0.2-1
openvpn
Debian:14
before 2.0.2-1
2.0.2-1
openvpn
Debian:3.1
before 2.0-1sarge1, plus listed versions
2.0-1
2.0-1sarge1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2005-2532 is a medium vulnerability (CVSS 5.0) in Openvpn, published August 24, 2005. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.74%, the 86th percentile. Fixed in openvpn 2.0.2-1.

References

MoveEnter Open