Every CVE Search/ Get API key

CVE-2005-2929

Lynx 2.8.5, and other versions before 2.8.6dev.15, allows remote attackers to execute arbitrary...

7.5 HighFix available

Lynx 2.8.5, and other versions before 2.8.6dev.15, allows remote attackers to execute arbitrary commands via (1) lynxcgi:, (2) lynxexec, and (3) lynxprog links, which are not properly restricted in the default configuration in some environments.

Exploit likelihood

4.92%Up 0.6 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Lynx 2.8.5, and other versions before 2.8.6dev.15, allows remote attackers to execute arbitrary commands via (1) lynxcgi:, (2) lynxexec, and (3) lynxprog links, which are not properly restricted in the default configuration in some environments.

Record
CVE-2005-2929
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-264
Updated
2026-11-02
CVE List No score

Lynx 2.8.5, and other versions before 2.8.6dev.15, allows remote attackers to execute arbitrary commands via (1) lynxcgi:, (2) lynxexec, and (3) lynxprog links, which are not properly restricted in the default configuration in some environments.

Record
CVE-2005-2929
Updated
2026-11-02
EUVDEUVD-2005-2929 No score

Lynx 2.8.5, and other versions before 2.8.6dev.15, allows remote attackers to execute arbitrary commands via (1) lynxcgi:, (2) lynxexec, and (3) lynxprog links, which are not properly restricted in the default configuration in some environments.

Record
EUVD-2005-2929
Updated
2026-11-03
GitHub AdvisoriesGHSA-f56f-988c-jq3p No score

Lynx 2.8.5, and other versions before 2.8.6dev.15, allows remote attackers to execute arbitrary...

Lynx 2.8.5, and other versions before 2.8.6dev.15, allows remote attackers to execute arbitrary commands via (1) lynxcgi:, (2) lynxexec, and (3) lynxprog links, which are not properly restricted in the default configuration in some environments.

Record
GHSA-f56f-988c-jq3p
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
lynx
Red Hat:enterprise_linux:3::as
before 0:2.8.5-11.2
0:2.8.5-11.2
lynx-debuginfo
Red Hat:enterprise_linux:3::as
before 0:2.8.5-11.2
0:2.8.5-11.2
lynx
Red Hat:enterprise_linux:3::desktop
before 0:2.8.5-11.2
0:2.8.5-11.2
lynx-debuginfo
Red Hat:enterprise_linux:3::desktop
before 0:2.8.5-11.2
0:2.8.5-11.2
lynx
Red Hat:enterprise_linux:3::es
before 0:2.8.5-11.2
0:2.8.5-11.2
lynx-debuginfo
Red Hat:enterprise_linux:3::es
before 0:2.8.5-11.2
0:2.8.5-11.2
lynx
Red Hat:enterprise_linux:3::ws
before 0:2.8.5-11.2
0:2.8.5-11.2
lynx-debuginfo
Red Hat:enterprise_linux:3::ws
before 0:2.8.5-11.2
0:2.8.5-11.2
lynx
Red Hat:enterprise_linux:4::as
before 0:2.8.5-18.2
0:2.8.5-18.2
lynx-debuginfo
Red Hat:enterprise_linux:4::as
before 0:2.8.5-18.2
0:2.8.5-18.2
Show 6 moreShow less
Affected packages
PackageAffectedFixed
lynx
Red Hat:enterprise_linux:4::desktop
before 0:2.8.5-18.2
0:2.8.5-18.2
lynx-debuginfo
Red Hat:enterprise_linux:4::desktop
before 0:2.8.5-18.2
0:2.8.5-18.2
lynx
Red Hat:enterprise_linux:4::es
before 0:2.8.5-18.2
0:2.8.5-18.2
lynx-debuginfo
Red Hat:enterprise_linux:4::es
before 0:2.8.5-18.2
0:2.8.5-18.2
lynx
Red Hat:enterprise_linux:4::ws
before 0:2.8.5-18.2
0:2.8.5-18.2
lynx-debuginfo
Red Hat:enterprise_linux:4::ws
before 0:2.8.5-18.2
0:2.8.5-18.2

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2005-2929 is a high vulnerability (CVSS 7.5) in University Of Kansas Lynx, published November 18, 2005. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.92%, the 92nd percentile. Fixed in lynx 0:2.8.5-11.2.

References

Show 25 moreShow less
MoveEnter Open