Every CVE Search/ Get API key

CVE-2009-1358

apt-get in apt before 0.7.21 does not check for the correct error code from gpgv, which causes...

10.0 HighFix available

apt-get in apt before 0.7.21 does not check for the correct error code from gpgv, which causes apt to treat a repository as valid even when it has been signed with a key that has been revoked or expired, which might allow remote attackers to trick apt into installing malicious repositories.

Exploit likelihood

4.48%Up 2.5 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 10.0

apt-get in apt before 0.7.21 does not check for the correct error code from gpgv, which causes apt to treat a repository as valid even when it has been signed with a key that has been revoked or expired, which might allow remote attackers to trick apt into installing malicious repositories.

Record
CVE-2009-1358
CVSS 2.0
10.0 HighAV:N/AC:L/Au:N/C:C/I:C/A:C
Updated
2026-11-02
CVE List No score

apt-get in apt before 0.7.21 does not check for the correct error code from gpgv, which causes apt to treat a repository as valid even when it has been signed with a key that has been revoked or expired, which might allow remote attackers to trick apt into installing malicious repositories.

Record
CVE-2009-1358
Updated
2026-11-02
EUVDEUVD-2009-1356 No score

apt-get in apt before 0.7.21 does not check for the correct error code from gpgv, which causes apt to treat a repository as valid even when it has been signed with a key that has been revoked or expired, which might allow remote attackers to trick apt into installing malicious repositories.

Record
EUVD-2009-1356
Updated
2026-11-03
GitHub AdvisoriesGHSA-ggxf-mg5q-59fp No score

apt-get in apt before 0.7.21 does not check for the correct error code from gpgv, which causes...

apt-get in apt before 0.7.21 does not check for the correct error code from gpgv, which causes apt to treat a repository as valid even when it has been signed with a key that has been revoked or expired, which might allow remote attackers to trick apt into installing malicious repositories.

Record
GHSA-ggxf-mg5q-59fp
Updated
2026-11-02
OSV No score

apt-get in apt before 0.7.21 does not check for the correct error code from gpgv, which causes apt to treat a repository as valid even when it has been signed with a key that has been revoked or expired, which might allow remote attackers to trick apt into installing malicious repositories.

Record
CVE-2009-1358
Updated
2026-11-02
OSVDEBIAN-CVE-2009-1358 No score

apt-get in apt before 0.7.21 does not check for the correct error code from gpgv, which causes apt to treat a repository as valid even when it has been signed with a key that has been revoked or expired, which might allow remote attackers to trick apt into installing malicious repositories.

Record
DEBIAN-CVE-2009-1358
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
apt
Debian:12
before 0.7.21
0.7.21
apt
Debian:13
before 0.7.21
0.7.21
apt
Debian:14
before 0.7.21
0.7.21
apt
Debian:4.0
before 0.6.46.4-0.1+etch1, plus listed versions
0.6.46.4-0.1
0.6.46.4-0.1+etch1
apt
Debian:5.0
before 0.7.20.2+lenny1, plus listed versions
0.7.20.10.7.20.2
0.7.20.2+lenny1
apt
Debian:6.0
before 0.7.20.2+squeeze1
0.7.20.2+squeeze1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2009-1358 is a high vulnerability (CVSS 10.0) in Debian Apt, published April 6, 2009. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.48%, the 91st percentile. Fixed in apt 0.7.21.

References

Show 6 moreShow less
MoveEnter Open