Every CVE Search/ Get API key

CVE-2009-1722

Heap-based buffer overflow in the compression implementation in OpenEXR 1.2.2 allows context...

6.8 MediumFix available

Heap-based buffer overflow in the compression implementation in OpenEXR 1.2.2 allows context-dependent attackers to cause a denial of service (application crash) or possibly execute arbitrary code via unspecified vectors.

Exploit likelihood

4.54%Up 1.9 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.8

Heap-based buffer overflow in the compression implementation in OpenEXR 1.2.2 allows context-dependent attackers to cause a denial of service (application crash) or possibly execute arbitrary code via unspecified vectors.

Record
CVE-2009-1722
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

Heap-based buffer overflow in the compression implementation in OpenEXR 1.2.2 allows context-dependent attackers to cause a denial of service (application crash) or possibly execute arbitrary code via unspecified vectors.

Record
CVE-2009-1722
Updated
2026-11-02
EUVDEUVD-2009-1717 No score

Heap-based buffer overflow in the compression implementation in OpenEXR 1.2.2 allows context-dependent attackers to cause a denial of service (application crash) or possibly execute arbitrary code via unspecified vectors.

Record
EUVD-2009-1717
Updated
2026-11-03
GitHub AdvisoriesGHSA-g7x3-mh62-h5hm No score

Heap-based buffer overflow in the compression implementation in OpenEXR 1.2.2 allows context...

Heap-based buffer overflow in the compression implementation in OpenEXR 1.2.2 allows context-dependent attackers to cause a denial of service (application crash) or possibly execute arbitrary code via unspecified vectors.

Record
GHSA-g7x3-mh62-h5hm
Weakness
CWE-119
Updated
2026-11-02
OSV No score

Heap-based buffer overflow in the compression implementation in OpenEXR 1.2.2 allows context-dependent attackers to cause a denial of service (application crash) or possibly execute arbitrary code via unspecified vectors.

Record
CVE-2009-1722
Updated
2026-11-02
OSVDEBIAN-CVE-2009-1722 No score

Heap-based buffer overflow in the compression implementation in OpenEXR 1.2.2 allows context-dependent attackers to cause a denial of service (application crash) or possibly execute arbitrary code via unspecified vectors.

Record
DEBIAN-CVE-2009-1722
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
openexr
Debian:12
before 1.6.1-1
1.6.1-1
openexr
Debian:13
before 1.6.1-1
1.6.1-1
openexr
Debian:14
before 1.6.1-1
1.6.1-1
openexr
Debian:4.0
From an advisory covering 3 CVEs
before 1.2.2-4.3+etch2, plus listed versions
1.2.2-4.3
1.2.2-4.3+etch2
openexr
Debian:5.0
From an advisory covering 3 CVEs
before 1.6.1-3+lenny3, plus listed versions
1.6.1-3
1.6.1-3+lenny3

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2009-1722 is a medium vulnerability (CVSS 6.8) in Openexr, published July 28, 2009. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.54%, the 91st percentile. Fixed in openexr 1.6.1-1.

References

Show 12 moreShow less
MoveEnter Open