Every CVE Search/ Get API key

CVE-2011-1829

APT before 0.8.15.2 does not properly validate inline GPG signatures, which allows man-in-the...

4.3 MediumFix available

APT before 0.8.15.2 does not properly validate inline GPG signatures, which allows man-in-the-middle attackers to install modified packages via vectors involving lack of an initial clearsigned message.

Exploit likelihood

1.69%Up 0.6 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.3

APT before 0.8.15.2 does not properly validate inline GPG signatures, which allows man-in-the-middle attackers to install modified packages via vectors involving lack of an initial clearsigned message.

Record
CVE-2011-1829
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-20
Updated
2026-11-02
CVE List No score

APT before 0.8.15.2 does not properly validate inline GPG signatures, which allows man-in-the-middle attackers to install modified packages via vectors involving lack of an initial clearsigned message.

Record
CVE-2011-1829
Updated
2026-11-02
EUVDEUVD-2011-1827 No score

APT before 0.8.15.2 does not properly validate inline GPG signatures, which allows man-in-the-middle attackers to install modified packages via vectors involving lack of an initial clearsigned message.

Record
EUVD-2011-1827
Updated
2026-11-03
GitHub AdvisoriesGHSA-qq54-xq37-2h5v No score

APT before 0.8.15.2 does not properly validate inline GPG signatures, which allows man-in-the...

APT before 0.8.15.2 does not properly validate inline GPG signatures, which allows man-in-the-middle attackers to install modified packages via vectors involving lack of an initial clearsigned message.

Record
GHSA-qq54-xq37-2h5v
Weakness
CWE-20
Updated
2026-11-02
OSV No score

APT before 0.8.15.2 does not properly validate inline GPG signatures, which allows man-in-the-middle attackers to install modified packages via vectors involving lack of an initial clearsigned message.

Record
CVE-2011-1829
Updated
2026-11-02
OSVDEBIAN-CVE-2011-1829 No score

APT before 0.8.15.2 does not properly validate inline GPG signatures, which allows man-in-the-middle attackers to install modified packages via vectors involving lack of an initial clearsigned message.

Record
DEBIAN-CVE-2011-1829
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
apt
Debian:12
before 0.8.15.2
0.8.15.2
apt
Debian:13
before 0.8.15.2
0.8.15.2
apt
Debian:14
before 0.8.15.2
0.8.15.2

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2011-1829 is a medium vulnerability (CVSS 4.3) in Canonical Ubuntu Linux, published July 27, 2011. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.69%, the 77th percentile. Fixed in apt 0.8.15.2.

References

Show 4 moreShow less
MoveEnter Open