Every CVE Search/ Get API key

CVE-2012-2401

Plupload before 1.5.4, as used in wp-includes/js/plupload/ in WordPress before 3.3.2 and other...

5.0 MediumFix available

Plupload before 1.5.4, as used in wp-includes/js/plupload/ in WordPress before 3.3.2 and other products, enables scripting regardless of the domain from which the SWF content was loaded, which allows remote attackers to bypass the Same Origin Policy via crafted content.

Exploit likelihood

3.50%Up 1.3 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

Plupload before 1.5.4, as used in wp-includes/js/plupload/ in WordPress before 3.3.2 and other products, enables scripting regardless of the domain from which the SWF content was loaded, which allows remote attackers to bypass the Same Origin Policy via crafted content.

Record
CVE-2012-2401
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:P/A:N
Weakness
CWE-264
Updated
2026-11-02
CVE List No score

Plupload before 1.5.4, as used in wp-includes/js/plupload/ in WordPress before 3.3.2 and other products, enables scripting regardless of the domain from which the SWF content was loaded, which allows remote attackers to bypass the Same Origin Policy via crafted content.

Record
CVE-2012-2401
Updated
2026-11-02
EUVDEUVD-2012-2388 No score

Plupload before 1.5.4, as used in wp-includes/js/plupload/ in WordPress before 3.3.2 and other products, enables scripting regardless of the domain from which the SWF content was loaded, which allows remote attackers to bypass the Same Origin Policy via crafted content.

Record
EUVD-2012-2388
Updated
2026-11-03
GitHub AdvisoriesGHSA-ch8h-4j2v-gwvg No score

Plupload before 1.5.4, as used in wp-includes/js/plupload/ in WordPress before 3.3.2 and other...

Plupload before 1.5.4, as used in wp-includes/js/plupload/ in WordPress before 3.3.2 and other products, enables scripting regardless of the domain from which the SWF content was loaded, which allows remote attackers to bypass the Same Origin Policy via crafted content.

Record
GHSA-ch8h-4j2v-gwvg
Updated
2026-11-02
OSV No score

Plupload before 1.5.4, as used in wp-includes/js/plupload/ in WordPress before 3.3.2 and other products, enables scripting regardless of the domain from which the SWF content was loaded, which allows remote attackers to bypass the Same Origin Policy via crafted content.

Record
CVE-2012-2401
Updated
2026-11-02
OSVDEBIAN-CVE-2012-2401 No score

Plupload before 1.5.4, as used in wp-includes/js/plupload/ in WordPress before 3.3.2 and other products, enables scripting regardless of the domain from which the SWF content was loaded, which allows remote attackers to bypass the Same Origin Policy via crafted content.

Record
DEBIAN-CVE-2012-2401
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
wordpress
Debian:12
before 3.3.2+dfsg-1
3.3.2+dfsg-1
wordpress
Debian:13
before 3.3.2+dfsg-1
3.3.2+dfsg-1
wordpress
Debian:14
before 3.3.2+dfsg-1
3.3.2+dfsg-1
wordpress
Debian:6.0
From an advisory covering 15 CVEs
before 3.3.2+dfsg-1~squeeze1, plus listed versions
3.0.4+dfsg-13.0.5+dfsg-0+squeeze13.0.5+dfsg-13.2.1+dfsg-13.2.1+dfsg-23.2.1+dfsg-33.3+dfsg-13.3.1+dfsg-1
3.3.2+dfsg-1~squeeze1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2012-2401 is a medium vulnerability (CVSS 5.0) in Moxiecode Plupload, published April 21, 2012. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.50%, the 89th percentile. Fixed in wordpress 3.3.2+dfsg-1.

References

Show 7 moreShow less
MoveEnter Open