Every CVE Search/ Get API key

CVE-2013-1654

Puppet 2.7.x before 2.7.21 and 3.1.x before 3.1.1, and Puppet Enterprise 2.7.x before 2.7.2, does...

5.0 MediumFix available

Puppet 2.7.x before 2.7.21 and 3.1.x before 3.1.1, and Puppet Enterprise 2.7.x before 2.7.2, does not properly negotiate the SSL protocol between client and master, which allows remote attackers to conduct SSLv2 downgrade attacks against SSLv3 sessions via unspecified vectors.

Exploit likelihood

2.95%Up 1.5 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

Puppet 2.7.x before 2.7.21 and 3.1.x before 3.1.1, and Puppet Enterprise 2.7.x before 2.7.2, does not properly negotiate the SSL protocol between client and master, which allows remote attackers to conduct SSLv2 downgrade attacks against SSLv3 sessions via unspecified vectors.

Record
CVE-2013-1654
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:P/A:N
Updated
2026-11-02
CVE List No score

Puppet 2.7.x before 2.7.21 and 3.1.x before 3.1.1, and Puppet Enterprise 2.7.x before 2.7.2, does not properly negotiate the SSL protocol between client and master, which allows remote attackers to conduct SSLv2 downgrade attacks against SSLv3 sessions via unspecified vectors.

Record
CVE-2013-1654
Updated
2026-11-02
EUVDEUVD-2013-1685 No score

Puppet 2.7.x before 2.7.21 and 3.1.x before 3.1.1, and Puppet Enterprise 2.7.x before 2.7.2, does not properly negotiate the SSL protocol between client and master, which allows remote attackers to conduct SSLv2 downgrade attacks against SSLv3 sessions via unspecified vectors.

Record
EUVD-2013-1685
Updated
2026-11-03
GitHub AdvisoriesGHSA-53gg-mm53-pphh No score

Puppet 2.7.x before 2.7.21 and 3.1.x before 3.1.1, and Puppet Enterprise 2.7.x before 2.7.2, does...

Puppet 2.7.x before 2.7.21 and 3.1.x before 3.1.1, and Puppet Enterprise 2.7.x before 2.7.2, does not properly negotiate the SSL protocol between client and master, which allows remote attackers to conduct SSLv2 downgrade attacks against SSLv3 sessions via unspecified vectors.

Record
GHSA-53gg-mm53-pphh
Updated
2026-11-02
OSV No score

Puppet 2.7.x before 2.7.21 and 3.1.x before 3.1.1, and Puppet Enterprise 2.7.x before 2.7.2, does not properly negotiate the SSL protocol between client and master, which allows remote attackers to conduct SSLv2 downgrade attacks against SSLv3 sessions via unspecified vectors.

Record
CVE-2013-1654
Updated
2026-11-02
OSVDEBIAN-CVE-2013-1654 No score

Puppet 2.7.x before 2.7.21 and 3.1.x before 3.1.1, and Puppet Enterprise 2.7.x before 2.7.2, does not properly negotiate the SSL protocol between client and master, which allows remote attackers to conduct SSLv2 downgrade attacks against SSLv3 sessions via unspecified vectors.

Record
DEBIAN-CVE-2013-1654
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
puppet
Debian:11
before 2.7.18-3
2.7.18-3
puppet
Debian:6.0
before 2.6.2-5+squeeze7, plus listed versions
2.6.2-42.6.2-52.6.2-5+squeeze12.6.2-5+squeeze32.6.2-5+squeeze42.6.2-5+squeeze52.6.2-5+squeeze6
2.6.2-5+squeeze7
puppet
Red Hat:openstack:2::el6
before 0:2.6.18-1.el6ost
0:2.6.18-1.el6ost
puppet-server
Red Hat:openstack:2::el6
before 0:2.6.18-1.el6ost
0:2.6.18-1.el6ost

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2013-1654 is a medium vulnerability (CVSS 5.0) in Puppet, published March 12, 2013. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.95%, the 87th percentile. Fixed in puppet 2.7.18-3.

References

Show 32 moreShow less
MoveEnter Open