Every CVE Search/ Get API key

CVE-2014-8166

The browsing feature in the server in CUPS does not filter ANSI escape sequences from shared...

8.8 HighFix available

The browsing feature in the server in CUPS does not filter ANSI escape sequences from shared printer names, which might allow remote attackers to execute arbitrary code via a crafted printer name.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

3.70%Down 1.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 8.8

The browsing feature in the server in CUPS does not filter ANSI escape sequences from shared printer names, which might allow remote attackers to execute arbitrary code via a crafted printer name.

Record
CVE-2014-8166
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 2.0
5.1 MediumAV:N/AC:H/Au:N/C:P/I:P/A:P
Weakness
CWE-20
Updated
2026-11-02
CVE List No score

The browsing feature in the server in CUPS does not filter ANSI escape sequences from shared printer names, which might allow remote attackers to execute arbitrary code via a crafted printer name.

Record
CVE-2014-8166
Updated
2026-11-02
EUVDEUVD-2014-8007 No score

The browsing feature in the server in CUPS does not filter ANSI escape sequences from shared printer names, which might allow remote attackers to execute arbitrary code via a crafted printer name.

Record
EUVD-2014-8007
Updated
2026-11-03
GitHub AdvisoriesGHSA-fw6x-vp3m-9q59 8.8

The browsing feature in the server in CUPS does not filter ANSI escape sequences from shared...

The browsing feature in the server in CUPS does not filter ANSI escape sequences from shared printer names, which might allow remote attackers to execute arbitrary code via a crafted printer name.

Record
GHSA-fw6x-vp3m-9q59
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-20
Updated
2026-11-02
OSV 8.8

The browsing feature in the server in CUPS does not filter ANSI escape sequences from shared printer names, which might allow remote attackers to execute arbitrary code via a crafted printer name.

Record
CVE-2014-8166
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2014-8166 8.8

The browsing feature in the server in CUPS does not filter ANSI escape sequences from shared printer names, which might allow remote attackers to execute arbitrary code via a crafted printer name.

Record
DEBIAN-CVE-2014-8166
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVROOT-OS-DEBIAN-12-CVE-2014-8166 No score

CVE-2014-8166 in libcups2 - Patched by Root

Root has patched CVE-2014-8166 in the libcups2 package for Root:Debian:12. Multiple fixed versions available.

Record
ROOT-OS-DEBIAN-12-CVE-2014-8166
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
cups
Debian:12
All versions, plus listed versions
2.4.10-12.4.10-22.4.10-32.4.10-42.4.14-1
Show 23 moreShow less
2.4.15-12.4.16-12.4.17-12.4.18-12.4.2-32.4.2-3+deb12u12.4.2-3+deb12u22.4.2-3+deb12u32.4.2-3+deb12u42.4.2-3+deb12u52.4.2-3+deb12u62.4.2-3+deb12u72.4.2-3+deb12u82.4.2-3+deb12u92.4.2-42.4.2-52.4.2-62.4.20-12.4.7-12.4.7-1.12.4.7-1.22.4.7-22.4.7-3
None known
cups
Debian:13
All versions, plus listed versions
2.4.10-32.4.10-3+deb13u12.4.10-3+deb13u22.4.10-42.4.14-1
Show 5 moreShow less
2.4.15-12.4.16-12.4.17-12.4.18-12.4.20-1
None known
cups
Debian:14
All versions, plus listed versions
2.4.10-32.4.10-42.4.14-12.4.15-12.4.16-12.4.17-12.4.18-12.4.20-1
None known
libcups2
Root:Debian:12
before 2.4.2-3+deb12u8.root.io.1
2.4.2-3+deb12u8.root.io.12.4.2-3+deb12u8.root.io.22.4.2-3+deb12u8.root.io.32.4.2-3+deb12u9.aikido.4
rootio-libcups2
Root:Debian:12
before 2.4.2-3+deb12u8.root.io.1
2.4.2-3+deb12u8.root.io.12.4.2-3+deb12u8.root.io.22.4.2-3+deb12u8.root.io.32.4.2-3+deb12u9.aikido.4

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2014-8166 is a high vulnerability (CVSS 8.8) in Cups, published January 12, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.70%, the 89th percentile. Fixed in libcups2 2.4.2-3+deb12u8.root.io.1.

References

MoveEnter Open