Every CVE Search/ Get API key

CVE-2015-1196

GNU patch 2.7.1 allows remote attackers to write to arbitrary files via a symlink attack in a...

4.3 MediumFix available

GNU patch 2.7.1 allows remote attackers to write to arbitrary files via a symlink attack in a patch file.

Exploit likelihood

6.15%Up 4.7 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.3

GNU patch 2.7.1 allows remote attackers to write to arbitrary files via a symlink attack in a patch file.

Record
CVE-2015-1196
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-59
Updated
2026-11-02
CVE List No score

GNU patch 2.7.1 allows remote attackers to write to arbitrary files via a symlink attack in a patch file.

Record
CVE-2015-1196
Updated
2026-11-02
EUVDEUVD-2015-1337 No score

GNU patch 2.7.1 allows remote attackers to write to arbitrary files via a symlink attack in a patch file.

Record
EUVD-2015-1337
Updated
2026-11-03
GitHub AdvisoriesGHSA-pgg8-q7hj-8mg8 No score

GNU patch 2.7.1 allows remote attackers to write to arbitrary files via a symlink attack in a...

GNU patch 2.7.1 allows remote attackers to write to arbitrary files via a symlink attack in a patch file.

Record
GHSA-pgg8-q7hj-8mg8
Weakness
CWE-59
Updated
2026-11-02
OSV No score

GNU patch 2.7.1 allows remote attackers to write to arbitrary files via a symlink attack in a patch file.

Record
CVE-2015-1196
Updated
2026-11-02
OSVDEBIAN-CVE-2015-1196 No score

GNU patch 2.7.1 allows remote attackers to write to arbitrary files via a symlink attack in a patch file.

Record
DEBIAN-CVE-2015-1196
Updated
2026-11-02
Show 5 moreShow less
OSVMGASA-2015-0068 No score

Updated patch packages fix security vulnerabilities

Updated patch package fixes security vulnerabilities:

It was reported that a crafted diff file can make patch eat memory and later segfault (CVE-2014-9637).

It was reported that the versions of the patch utility that support Git-style patches are vulnerable to a directory traversal flaw. This could allow an attacker to overwrite arbitrary files by applying a specially crafted patch, with the privileges of the user running patch (CVE-2015-1395).

GNU patch before 2.7.4 allows remote attackers to write to arbitrary files via a symlink attack in a patch file (CVE-2015-1196).

Record
MGASA-2015-0068
Updated
2026-11-02
OSVopenSUSE-SU-2024:10379-1 No score

patch-2.7.5-1.112 on GA media

These are all security issues fixed in the patch-2.7.5-1.112 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10379-1
Updated
2026-11-02
OSVSUSE-SU-2015:1019-1 No score

Security update for patch

The GNU patch utility was updated to 2.7.5 to fix three security issues and one non-security bug.

The following vulnerabilities were fixed:

  • CVE-2015-1196: directory traversal flaw when handling git-style patches. This could allow an attacker to overwrite arbitrary files by tricking the user into applying a specially crafted patch. (bsc#913678)
  • CVE-2015-1395: directory traversal flaw when handling patches which rename files. This could allow an attacker to overwrite arbitrary files by tricking the user into applying a specially crafted patch. (bsc#915328)
  • CVE-2015-1396: directory traversal flaw via symbolic links. This could allow an attacker to overwrite arbitrary files by tricking the user into applying a by applying a specially crafted patch. (bsc#915329)

The following bug was fixed:

  • bsc#904519: Function names in hunks (from diff -p) are now preserved in reject files.
Record
SUSE-SU-2015:1019-1
Updated
2026-11-02
OSVUBUNTU-CVE-2015-1196 No score

GNU patch 2.7.1 allows remote attackers to write to arbitrary files via a symlink attack in a patch file.

Record
UBUNTU-CVE-2015-1196
Updated
2026-11-02
OSVUSN-2651-1 No score

patch vulnerabilities

Jakub Wilk discovered that GNU patch did not correctly handle file paths in patch files. An attacker could specially craft a patch file that could overwrite arbitrary files with the privileges of the user invoking the program. This issue only affected Ubuntu 12.04 LTS. (CVE-2010-4651)

László Böszörményi discovered that GNU patch did not correctly handle some patch files. An attacker could specially craft a patch file that could cause a denial of service. (CVE-2014-9637)

Jakub Wilk discovered that GNU patch did not correctly handle symbolic links in git style patch files. An attacker could specially craft a patch file that could overwrite arbitrary files with the privileges of the user invoking the program. This issue only affected Ubuntu 14.04 LTS and Ubuntu 14.10. (CVE-2015-1196)

Jakub Wilk discovered that GNU patch did not correctly handle file renames in git style patch files. An attacker could specially craft a patch file that could overwrite arbitrary files with the privileges of the user invoking the program. This issue only affected Ubuntu 14.04 LTS and Ubuntu 14.10. (CVE-2015-1395)

Jakub Wilk discovered the fix for CVE-2015-1196 was incomplete for GNU patch. An attacker could specially craft a patch file that could overwrite arbitrary files with the privileges of the user invoking the program. This issue only affected Ubuntu 14.04 LTS and Ubuntu 14.10. (CVE-2015-1396)

Record
USN-2651-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
patch
Debian:12
before 2.7.1-7
2.7.1-7
patch
Debian:13
before 2.7.1-7
2.7.1-7
patch
Debian:14
before 2.7.1-7
2.7.1-7
patch
Mageia:4
From an advisory covering 3 CVEs
before 2.7.4-1.mga4
2.7.4-1.mga4
patch
SUSE:Linux Enterprise Desktop 12
From an advisory covering 3 CVEs
before 2.7.5-7.1
2.7.5-7.1
patch
SUSE:Linux Enterprise Server 12
From an advisory covering 3 CVEs
before 2.7.5-7.1
2.7.5-7.1
patch
SUSE:Linux Enterprise Server for SAP Applications 12
From an advisory covering 3 CVEs
before 2.7.5-7.1
2.7.5-7.1
patch
Ubuntu:14.04:LTS
before 2.7.1-4ubuntu2.3, plus listed versions
2.7.1-32.7.1-42.7.1-4ubuntu12.7.1-4ubuntu2
2.7.1-4ubuntu2.3
patch
Ubuntu:14.04:LTS
From an advisory covering 5 CVEs
before 2.7.1-4ubuntu2.3, plus listed versions
2.7.1-32.7.1-42.7.1-4ubuntu12.7.1-4ubuntu2
2.7.1-4ubuntu2.3
patch
openSUSE:Tumbleweed
From an advisory covering 2 CVEs
before 2.7.5-1.112
2.7.5-1.112

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2015-1196 is a medium vulnerability (CVSS 4.3) in Gnu Patch, published January 21, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 6.15%, the 93rd percentile. Fixed in patch 2.7.1-7.

References

Show 25 moreShow less
MoveEnter Open