CVE-2015-2091
The authentication hook (mgs_hook_authz) in mod-gnutls 0.5.10 and earlier does not validate...
The authentication hook (mgs_hook_authz) in mod-gnutls 0.5.10 and earlier does not validate client certificates when "GnuTLSClientVerify require" is set, which allows remote attackers to spoof clients via a crafted certificate.
Exploit likelihood
What each source reports
NVD Score used
5.0
The authentication hook (mgs_hook_authz) in mod-gnutls 0.5.10 and earlier does not validate client certificates when "GnuTLSClientVerify require" is set, which allows remote attackers to spoof clients via a crafted certificate.
- Record
CVE-2015-2091- CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:P/A:N - Weakness
- CWE-310
- Updated
- 2026-11-02
CVE List No score
The authentication hook (mgs_hook_authz) in mod-gnutls 0.5.10 and earlier does not validate client certificates when "GnuTLSClientVerify require" is set, which allows remote attackers to spoof clients via a crafted certificate.
- Record
CVE-2015-2091- Updated
- 2026-11-02
EUVDEUVD-2015-2201 No score
The authentication hook (mgs_hook_authz) in mod-gnutls 0.5.10 and earlier does not validate client certificates when "GnuTLSClientVerify require" is set, which allows remote attackers to spoof clients via a crafted certificate.
- Record
EUVD-2015-2201- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-pgq5-v38c-mjg3 No score
The authentication hook (mgs_hook_authz) in mod-gnutls 0.5.10 and earlier does not validate...
The authentication hook (mgs_hook_authz) in mod-gnutls 0.5.10 and earlier does not validate client certificates when "GnuTLSClientVerify require" is set, which allows remote attackers to spoof clients via a crafted certificate.
- Record
GHSA-pgq5-v38c-mjg3- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
mod-gnutlsDebian:6.0 |
before 0.5.6-1+squeeze2, plus listed versions 0.5.6-10.5.6-1+squeeze1 |
0.5.6-1+squeeze2 |
mod-gnutlsDebian:7 |
before 0.5.10-1.1+deb7u1, plus listed versions 0.5.10-1.1 |
0.5.10-1.1+deb7u1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2015-2091 is a medium vulnerability (CVSS 5.0) in Apache Mod-gnutls, published March 10, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.25%, the 88th percentile. Fixed in mod-gnutls 0.5.6-1+squeeze2.