CVE-2015-5705
Argument injection vulnerability in devscripts before 2.15.7 allows remote attackers to write to...
Argument injection vulnerability in devscripts before 2.15.7 allows remote attackers to write to arbitrary files via a crafted symlink and crafted filename.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- High
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
7.5
Argument injection vulnerability in devscripts before 2.15.7 allows remote attackers to write to arbitrary files via a crafted symlink and crafted filename.
- Record
CVE-2015-5705- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:P/A:N - Weakness
- CWE-59
- Updated
- 2026-11-02
CVE List No score
Argument injection vulnerability in devscripts before 2.15.7 allows remote attackers to write to arbitrary files via a crafted symlink and crafted filename.
- Record
CVE-2015-5705- Updated
- 2026-11-02
EUVDEUVD-2015-5652 No score
Argument injection vulnerability in devscripts before 2.15.7 allows remote attackers to write to arbitrary files via a crafted symlink and crafted filename.
- Record
EUVD-2015-5652- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-qhpv-f2h3-4mh8
7.5
Argument injection vulnerability in devscripts before 2.15.7 allows remote attackers to write to...
Argument injection vulnerability in devscripts before 2.15.7 allows remote attackers to write to arbitrary files via a crafted symlink and crafted filename.
- Record
GHSA-qhpv-f2h3-4mh8- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N - Weakness
- CWE-59
- Updated
- 2026-11-02
OSV
7.5
Argument injection vulnerability in devscripts before 2.15.7 allows remote attackers to write to arbitrary files via a crafted symlink and crafted filename.
- Record
CVE-2015-5705- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N - Updated
- 2026-11-02
OSVDEBIAN-CVE-2015-5705
7.5
Argument injection vulnerability in devscripts before 2.15.7 allows remote attackers to write to arbitrary files via a crafted symlink and crafted filename.
- Record
DEBIAN-CVE-2015-5705- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
devscriptsDebian:12 |
before 2.15.8 | 2.15.8 |
devscriptsDebian:13 |
before 2.15.8 | 2.15.8 |
devscriptsDebian:14 |
before 2.15.8 | 2.15.8 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2015-5705 is a high vulnerability (CVSS 7.5) in Devscripts Devel Team Devscripts, published September 6, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.12%, the 87th percentile. Fixed in devscripts 2.15.8.
References
anonscm.debian.org/cgit/collab-maint/devscripts.git/commit?id=d8f8fa1d8e4151fa62997cb74403f97ab0d7e1a2
bugzilla.redhat.com/show_bug.cgi?id=1249645
lists.fedoraproject.org/pipermail/package-announce/2015-August/163710.html
bugs.debian.org/cgi-bin/bugreport.cgi?bug=794260
lists.fedoraproject.org/pipermail/package-announce/2015-August/163705.html
openwall.com/lists/oss-security/2015/08/01/7
nvd.nist.gov/vuln/detail/CVE-2015-5705
github.com/advisories/GHSA-qhpv-f2h3-4mh8
security-tracker.debian.org/tracker/CVE-2015-5705