CVE-2016-9431
An issue was discovered in the Tatsuya Kinoshita w3m fork before 0.5.3-31. Infinite recursion...
An issue was discovered in the Tatsuya Kinoshita w3m fork before 0.5.3-31. Infinite recursion vulnerability in w3m allows remote attackers to cause a denial of service via a crafted HTML page.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
6.5
An issue was discovered in the Tatsuya Kinoshita w3m fork before 0.5.3-31. Infinite recursion vulnerability in w3m allows remote attackers to cause a denial of service via a crafted HTML page.
- Record
CVE-2016-9431- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:N/A:P - Weakness
- CWE-119
- Updated
- 2026-11-02
CVE List No score
An issue was discovered in the Tatsuya Kinoshita w3m fork before 0.5.3-31. Infinite recursion vulnerability in w3m allows remote attackers to cause a denial of service via a crafted HTML page.
- Record
CVE-2016-9431- Updated
- 2026-11-02
EUVDEUVD-2016-10241 No score
An issue was discovered in the Tatsuya Kinoshita w3m fork before 0.5.3-31. Infinite recursion vulnerability in w3m allows remote attackers to cause a denial of service via a crafted HTML page.
- Record
EUVD-2016-10241- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-27vx-r33r-rh7x
6.5
An issue was discovered in the Tatsuya Kinoshita w3m fork before 0.5.3-31. Infinite recursion...
An issue was discovered in the Tatsuya Kinoshita w3m fork before 0.5.3-31. Infinite recursion vulnerability in w3m allows remote attackers to cause a denial of service via a crafted HTML page.
- Record
GHSA-27vx-r33r-rh7x- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Weakness
- CWE-119
- Updated
- 2026-11-02
OSV
6.5
An issue was discovered in the Tatsuya Kinoshita w3m fork before 0.5.3-31. Infinite recursion vulnerability in w3m allows remote attackers to cause a denial of service via a crafted HTML page.
- Record
CVE-2016-9431- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2016-9431
6.5
An issue was discovered in the Tatsuya Kinoshita w3m fork before 0.5.3-31. Infinite recursion vulnerability in w3m allows remote attackers to cause a denial of service via a crafted HTML page.
- Record
DEBIAN-CVE-2016-9431- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2016-9431
6.5
An issue was discovered in the Tatsuya Kinoshita w3m fork before 0.5.3-31. Infinite recursion vulnerability in w3m allows remote attackers to cause a denial of service via a crafted HTML page.
- Record
UBUNTU-CVE-2016-9431- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVMGASA-2018-0024 No score
Updated w3m packages fix security vulnerability
The w3m package has been updated to a newer git snapshot to fix several security issues.
- Record
MGASA-2018-0024- Updated
- 2026-11-02
OSVUSN-3214-1 No score
w3m vulnerabilities
A large number of security issues were discovered in the w3m browser. If a user were tricked into viewing a malicious website, a remote attacker could exploit a variety of issues related to web browser security, including cross-site scripting attacks, denial of service attacks, and arbitrary code execution.
- Record
USN-3214-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
w3mDebian:12 |
before 0.5.3-30 | 0.5.3-30 |
w3mDebian:13 |
before 0.5.3-30 | 0.5.3-30 |
w3mDebian:14 |
before 0.5.3-30 | 0.5.3-30 |
w3mMageia:5 From an advisory covering 34 CVEs |
before 0.5.3-8.2.mga5 | 0.5.3-8.2.mga5 |
w3mUbuntu:14.04:LTS |
before 0.5.3-15ubuntu0.1, plus listed versions 0.5.3-110.5.3-120.5.3-130.5.3-15 |
0.5.3-15ubuntu0.1 |
w3mUbuntu:16.04:LTS |
before 0.5.3-26ubuntu0.1, plus listed versions 0.5.3-240.5.3-250.5.3-260.5.3-26build1 |
0.5.3-26ubuntu0.1 |
w3mUbuntu:14.04:LTS From an advisory covering 33 CVEs |
before 0.5.3-15ubuntu0.1, plus listed versions 0.5.3-110.5.3-120.5.3-130.5.3-15 |
0.5.3-15ubuntu0.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2016-9431 is a medium vulnerability (CVSS 6.5) in Tats W3m, published December 11, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.41%, the 84th percentile. Fixed in w3m 0.5.3-30.
References
security.gentoo.org/glsa/201701-08
github.com/tats/w3m/blob/master/ChangeLog
github.com/tats/w3m/issues/10
securityfocus.com/bid/94407
openwall.com/lists/oss-security/2016/11/18/3
nvd.nist.gov/vuln/detail/CVE-2016-9431
Show 43 moreShow less
github.com/advisories/GHSA-27vx-r33r-rh7x
security-tracker.debian.org/tracker/CVE-2016-9431
advisories.mageia.org/MGASA-2018-0024.html
bugs.mageia.org/show_bug.cgi?id=19811
openwall.com/lists/oss-security/2016/11/03/3
openwall.com/lists/oss-security/2016/11/24/1
openwall.com/lists/oss-security/2016/11/25/5
lists.opensuse.org/opensuse-updates/2016-12/msg00084.html
ubuntu.com/security/CVE-2016-9431
ubuntu.com/security/notices/USN-3214-1
cve.org/CVERecord?id=CVE-2016-9431
ubuntu.com/security/CVE-2016-9422
ubuntu.com/security/CVE-2016-9423
ubuntu.com/security/CVE-2016-9424
ubuntu.com/security/CVE-2016-9425
ubuntu.com/security/CVE-2016-9426
ubuntu.com/security/CVE-2016-9428
ubuntu.com/security/CVE-2016-9429
ubuntu.com/security/CVE-2016-9430
ubuntu.com/security/CVE-2016-9432
ubuntu.com/security/CVE-2016-9433
ubuntu.com/security/CVE-2016-9434
ubuntu.com/security/CVE-2016-9435
ubuntu.com/security/CVE-2016-9436
ubuntu.com/security/CVE-2016-9437
ubuntu.com/security/CVE-2016-9438
ubuntu.com/security/CVE-2016-9439
ubuntu.com/security/CVE-2016-9440
ubuntu.com/security/CVE-2016-9441
ubuntu.com/security/CVE-2016-9442
ubuntu.com/security/CVE-2016-9443
ubuntu.com/security/CVE-2016-9622
ubuntu.com/security/CVE-2016-9623
ubuntu.com/security/CVE-2016-9624
ubuntu.com/security/CVE-2016-9625
ubuntu.com/security/CVE-2016-9626
ubuntu.com/security/CVE-2016-9627
ubuntu.com/security/CVE-2016-9628
ubuntu.com/security/CVE-2016-9629
ubuntu.com/security/CVE-2016-9630
ubuntu.com/security/CVE-2016-9631
ubuntu.com/security/CVE-2016-9632
ubuntu.com/security/CVE-2016-9633