Every CVE Search/ Get API key

CVE-2016-9433

An issue was discovered in the Tatsuya Kinoshita w3m fork before 0.5.3-31. w3m allows remote...

6.5 MediumFix available

An issue was discovered in the Tatsuya Kinoshita w3m fork before 0.5.3-31. w3m allows remote attackers to cause a denial of service (out-of-bounds array access) via a crafted HTML page.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

2.41%Up 1.2 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.5

An issue was discovered in the Tatsuya Kinoshita w3m fork before 0.5.3-31. w3m allows remote attackers to cause a denial of service (out-of-bounds array access) via a crafted HTML page.

Record
CVE-2016-9433
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:N/A:P
Weakness
CWE-125
Updated
2026-11-02
CVE List No score

An issue was discovered in the Tatsuya Kinoshita w3m fork before 0.5.3-31. w3m allows remote attackers to cause a denial of service (out-of-bounds array access) via a crafted HTML page.

Record
CVE-2016-9433
Updated
2026-11-02
EUVDEUVD-2016-10243 No score

An issue was discovered in the Tatsuya Kinoshita w3m fork before 0.5.3-31. w3m allows remote attackers to cause a denial of service (out-of-bounds array access) via a crafted HTML page.

Record
EUVD-2016-10243
Updated
2026-11-03
GitHub AdvisoriesGHSA-3gvf-cvjx-4qhp 6.5

An issue was discovered in the Tatsuya Kinoshita w3m fork before 0.5.3-31. w3m allows remote...

An issue was discovered in the Tatsuya Kinoshita w3m fork before 0.5.3-31. w3m allows remote attackers to cause a denial of service (out-of-bounds array access) via a crafted HTML page.

Record
GHSA-3gvf-cvjx-4qhp
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Weakness
CWE-125
Updated
2026-11-02
OSV 6.5

An issue was discovered in the Tatsuya Kinoshita w3m fork before 0.5.3-31. w3m allows remote attackers to cause a denial of service (out-of-bounds array access) via a crafted HTML page.

Record
CVE-2016-9433
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2016-9433 6.5

An issue was discovered in the Tatsuya Kinoshita w3m fork before 0.5.3-31. w3m allows remote attackers to cause a denial of service (out-of-bounds array access) via a crafted HTML page.

Record
DEBIAN-CVE-2016-9433
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2016-9433 6.5

An issue was discovered in the Tatsuya Kinoshita w3m fork before 0.5.3-31. w3m allows remote attackers to cause a denial of service (out-of-bounds array access) via a crafted HTML page.

Record
UBUNTU-CVE-2016-9433
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVMGASA-2018-0024 No score

Updated w3m packages fix security vulnerability

The w3m package has been updated to a newer git snapshot to fix several security issues.

Record
MGASA-2018-0024
Updated
2026-11-02
OSVUSN-3214-1 No score

w3m vulnerabilities

A large number of security issues were discovered in the w3m browser. If a user were tricked into viewing a malicious website, a remote attacker could exploit a variety of issues related to web browser security, including cross-site scripting attacks, denial of service attacks, and arbitrary code execution.

Record
USN-3214-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
w3m
Debian:12
before 0.5.3-30
0.5.3-30
w3m
Debian:13
before 0.5.3-30
0.5.3-30
w3m
Debian:14
before 0.5.3-30
0.5.3-30
w3m
Mageia:5
From an advisory covering 34 CVEs
before 0.5.3-8.2.mga5
0.5.3-8.2.mga5
w3m
Ubuntu:14.04:LTS
before 0.5.3-15ubuntu0.1, plus listed versions
0.5.3-110.5.3-120.5.3-130.5.3-15
0.5.3-15ubuntu0.1
w3m
Ubuntu:16.04:LTS
before 0.5.3-26ubuntu0.1, plus listed versions
0.5.3-240.5.3-250.5.3-260.5.3-26build1
0.5.3-26ubuntu0.1
w3m
Ubuntu:14.04:LTS
From an advisory covering 33 CVEs
before 0.5.3-15ubuntu0.1, plus listed versions
0.5.3-110.5.3-120.5.3-130.5.3-15
0.5.3-15ubuntu0.1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2016-9433 is a medium vulnerability (CVSS 6.5) in Tats W3m, published December 11, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.41%, the 84th percentile. Fixed in w3m 0.5.3-30.

References

Show 43 moreShow less
MoveEnter Open