CVE-2016-1983
The client_host function in parsers.c in Privoxy before 3.0.24 allows remote attackers to cause a...
The client_host function in parsers.c in Privoxy before 3.0.24 allows remote attackers to cause a denial of service (invalid read and crash) via an empty HTTP Host header.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.5
The client_host function in parsers.c in Privoxy before 3.0.24 allows remote attackers to cause a denial of service (invalid read and crash) via an empty HTTP Host header.
- Record
CVE-2016-1983- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:N/A:P - Weakness
- CWE-20
- Updated
- 2026-11-02
CVE List No score
The client_host function in parsers.c in Privoxy before 3.0.24 allows remote attackers to cause a denial of service (invalid read and crash) via an empty HTTP Host header.
- Record
CVE-2016-1983- Updated
- 2026-11-02
EUVDEUVD-2016-3072 No score
The client_host function in parsers.c in Privoxy before 3.0.24 allows remote attackers to cause a denial of service (invalid read and crash) via an empty HTTP Host header.
- Record
EUVD-2016-3072- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-6frp-gfc5-q2xj
7.5
The client_host function in parsers.c in Privoxy before 3.0.24 allows remote attackers to cause a...
The client_host function in parsers.c in Privoxy before 3.0.24 allows remote attackers to cause a denial of service (invalid read and crash) via an empty HTTP Host header.
- Record
GHSA-6frp-gfc5-q2xj- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-20
- Updated
- 2026-11-02
OSV
7.5
The client_host function in parsers.c in Privoxy before 3.0.24 allows remote attackers to cause a denial of service (invalid read and crash) via an empty HTTP Host header.
- Record
CVE-2016-1983- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2016-1983
7.5
The client_host function in parsers.c in Privoxy before 3.0.24 allows remote attackers to cause a denial of service (invalid read and crash) via an empty HTTP Host header.
- Record
DEBIAN-CVE-2016-1983- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2016-1983
7.5
The client_host function in parsers.c in Privoxy before 3.0.24 allows remote attackers to cause a denial of service (invalid read and crash) via an empty HTTP Host header.
- Record
UBUNTU-CVE-2016-1983- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVMGASA-2016-0055 No score
Updated privoxy packages fix security vulnerabilities
This update fixes two denial-of-service vulnerabilities that have been discovered in privoxy 3.0.23:
The remove_chunked_transfer_coding function in filters.c in Privoxy before 3.0.24 allows remote attackers to cause a denial of service (invalid read and crash) via crafted chunk-encoded content. (CVE-2016-1982)
The client_host function in parsers.c in Privoxy before 3.0.24 allows remote attackers to cause a denial of service (invalid read and crash) via an empty HTTP Host header. (CVE-2016-1983)
- Record
MGASA-2016-0055- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:10494-1 No score
privoxy-3.0.26-1.1 on GA media
These are all security issues fixed in the privoxy-3.0.26-1.1 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:10494-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
privoxyDebian:12 |
before 3.0.24-1 | 3.0.24-1 |
privoxyDebian:13 |
before 3.0.24-1 | 3.0.24-1 |
privoxyDebian:14 |
before 3.0.24-1 | 3.0.24-1 |
privoxyDebian:6.0 From an advisory covering 2 CVEs |
before 3.0.16-1+deb6u2, plus listed versions 3.0.16-1 |
3.0.16-1+deb6u2 |
privoxyDebian:7 From an advisory covering 2 CVEs |
before 3.0.19-2+deb7u3, plus listed versions 3.0.19-23.0.19-2+deb7u13.0.19-2+deb7u2 |
3.0.19-2+deb7u3 |
privoxyDebian:8 From an advisory covering 2 CVEs |
before 3.0.21-7+deb8u1, plus listed versions 3.0.21-7 |
3.0.21-7+deb8u1 |
privoxyMageia:5 From an advisory covering 2 CVEs |
before 3.0.23-1.1.mga5 | 3.0.23-1.1.mga5 |
privoxyopenSUSE:Tumbleweed From an advisory covering 8 CVEs |
before 3.0.26-1.1 | 3.0.26-1.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| affected | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2016-1983 is a high vulnerability (CVSS 7.5) in Privoxy, published January 23, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.87%, the 86th percentile. Fixed in privoxy 3.0.24-1.
References
debian.org/security/2016/dsa-3460
openwall.com/lists/oss-security/2016/01/22/3
openwall.com/lists/oss-security/2016/01/21/4
ijbswa.cvs.sourceforge.net/viewvc/ijbswa/current/parsers.c?r1=1.302&r2=1.303
lists.fedoraproject.org/pipermail/package-announce/2016-February/176492.html
lists.fedoraproject.org/pipermail/package-announce/2016-February/176475.html
Show 16 moreShow less
privoxy.org/announce.txt
nvd.nist.gov/vuln/detail/CVE-2016-1983
github.com/advisories/GHSA-6frp-gfc5-q2xj
security-tracker.debian.org/tracker/CVE-2016-1983
advisories.mageia.org/MGASA-2016-0055.html
bugs.mageia.org/show_bug.cgi?id=17566
ubuntu.com/security/CVE-2016-1983
cve.org/CVERecord?id=CVE-2016-1983
suse.com/security/cve/CVE-2015-1030
suse.com/security/cve/CVE-2015-1031
suse.com/security/cve/CVE-2015-1201
suse.com/security/cve/CVE-2015-1380
suse.com/security/cve/CVE-2015-1381
suse.com/security/cve/CVE-2015-1382
suse.com/security/cve/CVE-2016-1982
suse.com/security/cve/CVE-2016-1983