Every CVE Search/ Get API key

CVE-2013-1655

Puppet Improper Input Validation vulnerability

7.5 HighFix available

Puppet 2.7.x before 2.7.21 and 3.1.x before 3.1.1, when running Ruby 1.9.3 or later, allows remote attackers to execute arbitrary code via vectors related to "serialized attributes."

Exploit likelihood

4.56%Down 3.2 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Puppet 2.7.x before 2.7.21 and 3.1.x before 3.1.1, when running Ruby 1.9.3 or later, allows remote attackers to execute arbitrary code via vectors related to "serialized attributes."

Record
CVE-2013-1655
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-20
Updated
2026-11-02
CVE List No score

Puppet 2.7.x before 2.7.21 and 3.1.x before 3.1.1, when running Ruby 1.9.3 or later, allows remote attackers to execute arbitrary code via vectors related to "serialized attributes."

Record
CVE-2013-1655
Updated
2026-11-02
EUVDEUVD-2017-0168 No score

Puppet 2.7.x before 2.7.21 and 3.1.x before 3.1.1, when running Ruby 1.9.3 or later, allows remote attackers to execute arbitrary code via vectors related to "serialized attributes."

Record
EUVD-2017-0168
Updated
2026-11-03
GitHub AdvisoriesGHSA-574q-fxfj-wv6h No score

Puppet Improper Input Validation vulnerability

Puppet 2.7.x before 2.7.21 and 3.1.x before 3.1.1, when running Ruby 1.9.3 or later, allows remote attackers to execute arbitrary code via vectors related to "serialized attributes."

Record
GHSA-574q-fxfj-wv6h
Weakness
CWE-20
Updated
2026-11-02
OSV No score

Puppet 2.7.x before 2.7.21 and 3.1.x before 3.1.1, when running Ruby 1.9.3 or later, allows remote attackers to execute arbitrary code via vectors related to "serialized attributes."

Record
CVE-2013-1655
Updated
2026-11-02
OSVDEBIAN-CVE-2013-1655 No score

Puppet 2.7.x before 2.7.21 and 3.1.x before 3.1.1, when running Ruby 1.9.3 or later, allows remote attackers to execute arbitrary code via vectors related to "serialized attributes."

Record
DEBIAN-CVE-2013-1655
Updated
2026-11-02
OSVGHSA-574q-fxfj-wv6h No score

Puppet Improper Input Validation vulnerability

Puppet 2.7.x before 2.7.21 and 3.1.x before 3.1.1, when running Ruby 1.9.3 or later, allows remote attackers to execute arbitrary code via vectors related to "serialized attributes."

Record
GHSA-574q-fxfj-wv6h
Weakness
CWE-20
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
puppet
RubyGems
3.1.0 up to 3.1.1
3.1.1
puppet
RubyGems
2.7.0 up to 2.7.21
2.7.21
puppet
Debian:11
before 2.7.18-3
2.7.18-3
puppet
Debian:6.0
From an advisory covering 7 CVEs
before 2.6.2-5+squeeze7, plus listed versions
2.6.2-42.6.2-52.6.2-5+squeeze12.6.2-5+squeeze32.6.2-5+squeeze42.6.2-5+squeeze52.6.2-5+squeeze6
2.6.2-5+squeeze7
puppet
RubyGems
2.7.0 up to 2.7.21, plus listed versions
2.7.12.7.112.7.122.7.132.7.14
Show 12 moreShow less
2.7.162.7.172.7.182.7.192.7.202.7.20.rc12.7.32.7.42.7.52.7.62.7.82.7.9
2.7.21

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2013-1655 is a high vulnerability (CVSS 7.5) in Puppet, published March 12, 2013. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.56%, the 91st percentile. Fixed in puppet 3.1.1.

References

Show 8 moreShow less
MoveEnter Open