Every CVE Search/ Get API key

CVE-2017-2938

Adobe Flash Player versions 24.0.0.186 and earlier have a security bypass vulnerability related...

6.5 MediumFix available

Adobe Flash Player versions 24.0.0.186 and earlier have a security bypass vulnerability related to handling TCP connections.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
None
Availability
None

Exploit likelihood

5.08%Down 0.5 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 6.5

Adobe Flash Player versions 24.0.0.186 and earlier have a security bypass vulnerability related to handling TCP connections.

Record
CVE-2017-2938
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:P/I:N/A:N
Updated
2026-11-02
CVE List No score

Adobe Flash Player versions 24.0.0.186 and earlier have a security bypass vulnerability related to handling TCP connections.

Record
CVE-2017-2938
Updated
2026-11-02
EUVDEUVD-2017-12079 No score

Adobe Flash Player versions 24.0.0.186 and earlier have a security bypass vulnerability related to handling TCP connections.

Record
EUVD-2017-12079
Updated
2026-11-03
GitHub AdvisoriesGHSA-gx39-fvj4-xp9c 7.3

Adobe Flash Player versions 24.0.0.186 and earlier have a security bypass vulnerability related...

Adobe Flash Player versions 24.0.0.186 and earlier have a security bypass vulnerability related to handling TCP connections.

Record
GHSA-gx39-fvj4-xp9c
CVSS 3.0
7.3 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Updated
2026-11-02
OSVRHSA-2017:0057 8.8

Red Hat Security Advisory: flash-plugin security update

Record
RHSA-2017:0057
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2017-2938 6.5

Adobe Flash Player versions 24.0.0.186 and earlier have a security bypass vulnerability related to handling TCP connections.

Record
UBUNTU-CVE-2017-2938
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N
CVSS 3.0
7.3 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Updated
2026-11-02
OSVMGASA-2017-0014 No score

Updated flash-player-plugin packages fix security vulnerabilities

Adobe Flash Player 24.0.0.194 contains fixes to critical security vulnerabilities found in earlier versions that could potentially allow an attacker to take control of the affected system.

Adobe is aware of a report that an exploit for CVE-2016-7892 exists in the wild, and is being used in limited, targeted attacks against users running Internet Explorer (32-bit) on Windows.

This update resolves security bypass vulnerabilities (CVE-2016-7890, CVE-2017-2938).

This update resolves use-after-free vulnerabilities that could lead to code execution (CVE-2016-7872, CVE-2016-7877, CVE-2016-7878, CVE-2016-7879, CVE-2016-7880, CVE-2016-7881, CVE-2016-7892, CVE-2017-2932, CVE-2017-2936, CVE-2017-2937).

This update resolves buffer overflow vulnerabilities that could lead to code execution (CVE-2016-7867, CVE-2016-7868, CVE-2016-7869, CVE-2016-7870, CVE-2017-2927, CVE-2017-2933, CVE-2017-2934, CVE-2017-2935).

This update resolves memory corruption vulnerabilities that could lead to code execution (CVE-2016-7871, CVE-2016-7873, CVE-2016-7874, CVE-2016-7875, CVE-2016-7876, CVE-2017-2925, CVE-2017-2926, CVE-2017-2928, CVE-2017-2930, CVE-2017-2931).

Note that Adobe has dropped Adobe Access DRM support from all their Linux releases since their 11.2 release series (which no longer gets security updates), so any Flash content protected with Adobe Access will no longer work.

Record
MGASA-2017-0014
Updated
2026-11-02
OSVSUSE-SU-2017:0108-1 No score

Security update for flash-player

This update to Adobe Flash 24.0.0.194 fixes the following vulnerabilities advised under APSB17-02:

  • security bypass vulnerability that could lead to information disclosure (CVE-2017-2938)
  • use-after-free vulnerabilities that could lead to code execution (CVE-2017-2932, CVE-2017-2936, CVE-2017-2937)
  • heap buffer overflow vulnerabilities that could lead to code execution (CVE-2017-2927, CVE-2017-2933, CVE-2017-2934, CVE-2017-2935)
  • memory corruption vulnerabilities that could lead to code execution (CVE-2017-2925, CVE-2017-2926, CVE-2017-2928, CVE-2017-2930, CVE-2017-2931)
Record
SUSE-SU-2017:0108-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
flash-player-plugin
Mageia:5
From an advisory covering 30 CVEs
before 24.0.0.194-1.mga5.nonfree
24.0.0.194-1.mga5.nonfree
flash-plugin
Red Hat:rhel_extras:6
From an advisory covering 13 CVEs
before 0:24.0.0.194-1.el6_8
0:24.0.0.194-1.el6_8
flash-player
SUSE:Linux Enterprise Desktop 12 SP1
From an advisory covering 13 CVEs
before 24.0.0.194-155.1
24.0.0.194-155.1
flash-player
SUSE:Linux Enterprise Workstation Extension 12 SP1
From an advisory covering 13 CVEs
before 24.0.0.194-155.1
24.0.0.194-155.1
flashplugin-nonfree
Ubuntu:14.04:LTS
before 24.0.0.194ubuntu0.14.04.1, plus listed versions
11.2.202.310ubuntu111.2.202.327ubuntu0.13.10.111.2.202.332ubuntu111.2.202.335ubuntu111.2.202.336ubuntu1
Show 44 moreShow less
11.2.202.341ubuntu111.2.202.346ubuntu111.2.202.350ubuntu111.2.202.356ubuntu0.14.04.111.2.202.359ubuntu0.14.04.111.2.202.378ubuntu0.14.04.111.2.202.394ubuntu0.14.04.111.2.202.400ubuntu0.14.04.111.2.202.406ubuntu0.14.04.111.2.202.406ubuntu0.14.04.211.2.202.411ubuntu0.14.04.111.2.202.418ubuntu0.14.04.111.2.202.424ubuntu0.14.04.111.2.202.425ubuntu0.14.04.111.2.202.429ubuntu0.14.04.111.2.202.438ubuntu0.14.04.111.2.202.440ubuntu0.14.04.111.2.202.442ubuntu0.14.04.111.2.202.451ubuntu0.14.04.111.2.202.457ubuntu0.14.04.111.2.202.460ubuntu0.14.04.111.2.202.466ubuntu0.14.04.111.2.202.468ubuntu0.14.04.111.2.202.481ubuntu0.14.04.111.2.202.481ubuntu0.14.04.211.2.202.491ubuntu0.14.04.111.2.202.508ubuntu0.14.04.111.2.202.521ubuntu0.14.04.111.2.202.535ubuntu0.14.04.111.2.202.540ubuntu0.14.04.211.2.202.548ubuntu0.14.04.111.2.202.554ubuntu0.14.04.111.2.202.559ubuntu0.14.04.111.2.202.569ubuntu0.14.04.111.2.202.577ubuntu0.14.04.111.2.202.616ubuntu0.14.04.111.2.202.621ubuntu0.14.04.111.2.202.626ubuntu0.14.04.111.2.202.632ubuntu0.14.04.111.2.202.635ubuntu0.14.04.111.2.202.637ubuntu0.14.04.111.2.202.643ubuntu0.14.04.111.2.202.644ubuntu0.14.04.124.0.0.186ubuntu0.14.04.1
24.0.0.194ubuntu0.14.04.1
flashplugin-nonfree
Ubuntu:16.04:LTS
before 24.0.0.194ubuntu0.16.04.1, plus listed versions
11.2.202.540ubuntu211.2.202.548ubuntu111.2.202.554ubuntu111.2.202.559ubuntu111.2.202.569ubuntu1
Show 10 moreShow less
11.2.202.577ubuntu111.2.202.616ubuntu111.2.202.621ubuntu0.16.04.111.2.202.626ubuntu0.16.04.111.2.202.632ubuntu0.16.04.111.2.202.635ubuntu0.16.04.111.2.202.637ubuntu0.16.04.111.2.202.643ubuntu0.16.04.111.2.202.644ubuntu0.16.04.124.0.0.186ubuntu0.16.04.1
24.0.0.194ubuntu0.16.04.1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-2938 is a medium vulnerability (CVSS 6.5) in Adobe Flash Player, published January 11, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 5.08%, the 92nd percentile. Fixed in flashplugin-nonfree 24.0.0.194ubuntu0.14.04.1.

References

Show 62 moreShow less
MoveEnter Open