Every CVE Search/ Get API key

CVE-2017-9058

In libytnef in ytnef through 1.9.2, there is a heap-based buffer over-read due to incorrect...

9.8 CriticalFix available

In libytnef in ytnef through 1.9.2, there is a heap-based buffer over-read due to incorrect boundary checking in the SIZECHECK macro in lib/ytnef.c.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

1.54%Up 0.7 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 9.8

In libytnef in ytnef through 1.9.2, there is a heap-based buffer over-read due to incorrect boundary checking in the SIZECHECK macro in lib/ytnef.c.

Record
CVE-2017-9058
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-125
Updated
2026-11-02
CVE List No score

In libytnef in ytnef through 1.9.2, there is a heap-based buffer over-read due to incorrect boundary checking in the SIZECHECK macro in lib/ytnef.c.

Record
CVE-2017-9058
Updated
2026-11-02
EUVDEUVD-2017-17997 No score

In libytnef in ytnef through 1.9.2, there is a heap-based buffer over-read due to incorrect boundary checking in the SIZECHECK macro in lib/ytnef.c.

Record
EUVD-2017-17997
Updated
2026-11-03
GitHub AdvisoriesGHSA-4g85-cv2v-x664 9.8

In libytnef in ytnef through 1.9.2, there is a heap-based buffer over-read due to incorrect...

In libytnef in ytnef through 1.9.2, there is a heap-based buffer over-read due to incorrect boundary checking in the SIZECHECK macro in lib/ytnef.c.

Record
GHSA-4g85-cv2v-x664
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-125
Updated
2026-11-02
OSV 9.8

In libytnef in ytnef through 1.9.2, there is a heap-based buffer over-read due to incorrect boundary checking in the SIZECHECK macro in lib/ytnef.c.

Record
CVE-2017-9058
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2017-9058 9.8

In libytnef in ytnef through 1.9.2, there is a heap-based buffer over-read due to incorrect boundary checking in the SIZECHECK macro in lib/ytnef.c.

Record
DEBIAN-CVE-2017-9058
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2017-9058 9.8

In libytnef in ytnef through 1.9.2, there is a heap-based buffer over-read due to incorrect boundary checking in the SIZECHECK macro in lib/ytnef.c.

Record
UBUNTU-CVE-2017-9058
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2017-0174 No score

Updated libytnef packages fix security vulnerabilities

Several issues were discovered in libytnef, a library used to decode application/ms-tnef e-mail attachments. Multiple heap overflows, out-of-bound writes and reads, NULL pointer dereferences and infinite loops could be exploited by tricking a user into opening a maliciously crafted winmail.dat file (CVE-2017-6298, CVE-2017-6299, CVE-2017-6300, CVE-2017-6301, CVE-2017-6302, CVE-2017-6303, CVE-2017-6304, CVE-2017-6305, CVE-2017-6306, CVE-2017-6800, CVE-2017-6801, CVE-2017-6802).

A heap-buffer-overflow vulnerability in libytnef due to an incorrect boundary checking in SIZECHCK macro in lib/ytnef.c (CVE-2017-9058).

Record
MGASA-2017-0174
Updated
2026-11-02
OSVUSN-3667-1 No score

libytnef vulnerabilities

It was discovered that libytnef incorrectly handled certain files. An attacker could possibly use this to cause a denial of service. (CVE-2017-12141, CVE-2017-9146, CVE-2017-9471, CVE-2017-9473)

It was discovered that libytnef incorrectly handled certain files. An attacker could possibly use this to access sensitive information. (CVE-2017-9058)

Record
USN-3667-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libytnef
Debian:12
before 1.9.2-2
1.9.2-2
libytnef
Debian:13
before 1.9.2-2
1.9.2-2
libytnef
Debian:14
before 1.9.2-2
1.9.2-2
libytnef
Mageia:5
From an advisory covering 13 CVEs
before 1.5-10.2.mga5
1.5-10.2.mga5
libytnef
Ubuntu:14.04:LTS
before 1.5-6ubuntu0.2, plus listed versions
1.5-51.5-61.5-6ubuntu0.1
1.5-6ubuntu0.2
libytnef
Ubuntu:16.04:LTS
All versions, plus listed versions
1.5-61.5-91.5-9ubuntu0.1
None known
libytnef
Ubuntu:14.04:LTS
From an advisory covering 5 CVEs
before 1.5-6ubuntu0.2, plus listed versions
1.5-51.5-61.5-6ubuntu0.1
1.5-6ubuntu0.2

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-9058 is a critical vulnerability (CVSS 9.8) in Ytnef Project Ytnef, published May 18, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.54%, the 74th percentile. Fixed in libytnef 1.9.2-2.

References

Show 13 moreShow less
MoveEnter Open