Every CVE Search/ Get API key

CVE-2017-9471

In ytnef 1.9.2, the SwapWord function in lib/ytnef.c allows remote attackers to cause a denial of...

5.5 MediumFix available

In ytnef 1.9.2, the SwapWord function in lib/ytnef.c allows remote attackers to cause a denial of service (heap-based buffer over-read and application crash) via a crafted file.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

1.17%Down 0.1 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 5.5

In ytnef 1.9.2, the SwapWord function in lib/ytnef.c allows remote attackers to cause a denial of service (heap-based buffer over-read and application crash) via a crafted file.

Record
CVE-2017-9471
CVSS 3.0
5.5 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:N/A:P
Weakness
CWE-125
Updated
2026-11-02
CVE List No score

In ytnef 1.9.2, the SwapWord function in lib/ytnef.c allows remote attackers to cause a denial of service (heap-based buffer over-read and application crash) via a crafted file.

Record
CVE-2017-9471
Updated
2026-11-02
EUVDEUVD-2017-18403 No score

In ytnef 1.9.2, the SwapWord function in lib/ytnef.c allows remote attackers to cause a denial of service (heap-based buffer over-read and application crash) via a crafted file.

Record
EUVD-2017-18403
Updated
2026-11-03
GitHub AdvisoriesGHSA-mgvm-xh8j-rpqx 5.5

In ytnef 1.9.2, the SwapWord function in lib/ytnef.c allows remote attackers to cause a denial of...

In ytnef 1.9.2, the SwapWord function in lib/ytnef.c allows remote attackers to cause a denial of service (heap-based buffer over-read and application crash) via a crafted file.

Record
GHSA-mgvm-xh8j-rpqx
CVSS 3.0
5.5 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Weakness
CWE-125
Updated
2026-11-02
OSV 5.5

In ytnef 1.9.2, the SwapWord function in lib/ytnef.c allows remote attackers to cause a denial of service (heap-based buffer over-read and application crash) via a crafted file.

Record
CVE-2017-9471
CVSS 3.0
5.5 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2017-9471 5.5

In ytnef 1.9.2, the SwapWord function in lib/ytnef.c allows remote attackers to cause a denial of service (heap-based buffer over-read and application crash) via a crafted file.

Record
DEBIAN-CVE-2017-9471
CVSS 3.0
5.5 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2017-9471 5.5

In ytnef 1.9.2, the SwapWord function in lib/ytnef.c allows remote attackers to cause a denial of service (heap-based buffer over-read and application crash) via a crafted file.

Record
UBUNTU-CVE-2017-9471
CVSS 3.0
5.5 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUSN-3667-1 No score

libytnef vulnerabilities

It was discovered that libytnef incorrectly handled certain files. An attacker could possibly use this to cause a denial of service. (CVE-2017-12141, CVE-2017-9146, CVE-2017-9471, CVE-2017-9473)

It was discovered that libytnef incorrectly handled certain files. An attacker could possibly use this to access sensitive information. (CVE-2017-9058)

Record
USN-3667-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libytnef
Debian:12
before 1.9.3-1
1.9.3-1
libytnef
Debian:13
before 1.9.3-1
1.9.3-1
libytnef
Debian:14
before 1.9.3-1
1.9.3-1
libytnef
Ubuntu:14.04:LTS
before 1.5-6ubuntu0.2, plus listed versions
1.5-51.5-61.5-6ubuntu0.1
1.5-6ubuntu0.2
libytnef
Ubuntu:16.04:LTS
All versions, plus listed versions
1.5-61.5-91.5-9ubuntu0.1
None known
libytnef
Ubuntu:18.04:LTS
All versions, plus listed versions
1.9.2-2
None known
libytnef
Ubuntu:14.04:LTS
From an advisory covering 5 CVEs
before 1.5-6ubuntu0.2, plus listed versions
1.5-51.5-61.5-6ubuntu0.1
1.5-6ubuntu0.2

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-9471 is a medium vulnerability (CVSS 5.5) in Ytnef Project Ytnef, published June 7, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.17%, the 67th percentile. Fixed in libytnef 1.9.3-1.

References

Show 8 moreShow less
MoveEnter Open