CVE-2017-11329
GLPI before 9.1.5 allows SQL injection via an ajax/getDropdownValue.php request with an...
GLPI before 9.1.5 allows SQL injection via an ajax/getDropdownValue.php request with an entity_restrict parameter that is not a list of integers.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
GLPI before 9.1.5 allows SQL injection via an ajax/getDropdownValue.php request with an entity_restrict parameter that is not a list of integers.
- Record
CVE-2017-11329- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-89
- Updated
- 2026-11-02
CVE List No score
GLPI before 9.1.5 allows SQL injection via an ajax/getDropdownValue.php request with an entity_restrict parameter that is not a list of integers.
- Record
CVE-2017-11329- Updated
- 2026-11-02
EUVDEUVD-2017-2963 No score
GLPI before 9.1.5 allows SQL injection via an ajax/getDropdownValue.php request with an entity_restrict parameter that is not a list of integers.
- Record
EUVD-2017-2963- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-hq75-xjfc-hhp2
9.8
GLPI before 9.1.5 allows SQL injection via an ajax/getDropdownValue.php request with an...
GLPI before 9.1.5 allows SQL injection via an ajax/getDropdownValue.php request with an entity_restrict parameter that is not a list of integers.
- Record
GHSA-hq75-xjfc-hhp2- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-89
- Updated
- 2026-11-02
OSV
9.8
GLPI before 9.1.5 allows SQL injection via an ajax/getDropdownValue.php request with an entity_restrict parameter that is not a list of integers.
- Record
CVE-2017-11329- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2017-11329
9.8
GLPI before 9.1.5 allows SQL injection via an ajax/getDropdownValue.php request with an entity_restrict parameter that is not a list of integers.
- Record
UBUNTU-CVE-2017-11329- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVMGASA-2018-0135 No score
Updated glpi packages fix security vulnerability
The glpi package has been updated to version 9.1.6, which fixes several security issues and other bugs. See the upstream release announcements for details.
An issue in the php-zetacomponents-base package which prevented GLPI from working has also been fixed.
- Record
MGASA-2018-0135- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
glpiMageia:6 From an advisory covering 5 CVEs |
before 9.1.6-2.mga6 | 9.1.6-2.mga6 |
php-zetacomponents-baseMageia:6 From an advisory covering 5 CVEs |
before 1.9-1.1.mga6 | 1.9-1.1.mga6 |
glpiUbuntu:16.04:LTS |
All versions, plus listed versions 0.84.8+dfsg.1-10.84.8+dfsg.1-1ubuntu1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-11329 is a critical vulnerability (CVSS 9.8) in Glpi-project Glpi, published July 14, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.24%, the 69th percentile. No source names a fixed version.
References
github.com/glpi-project/glpi/issues/2456
github.com/glpi-project/glpi/releases/tag/9.1.5
nvd.nist.gov/vuln/detail/CVE-2017-11329
github.com/advisories/GHSA-hq75-xjfc-hhp2
advisories.mageia.org/MGASA-2018-0135.html
bugs.mageia.org/show_bug.cgi?id=21331
Show 7 moreShow less
glpi-project.org/spip.php?page=annonce&id_breve=370&lang=en
glpi-project.org/spip.php?page=annonce&id_breve=373&lang=en
glpi-project.org/spip.php?page=annonce&id_breve=376&lang=en
glpi-project.org/spip.php?page=annonce&id_breve=378&lang=en
glpi-project.org/spip.php?page=annonce&id_breve=379&lang=en
ubuntu.com/security/CVE-2017-11329
cve.org/CVERecord?id=CVE-2017-11329