CVE-2018-5747
In Long Range Zip (aka lrzip) 0.631, there is a use-after-free in the ucompthread function ...
In Long Range Zip (aka lrzip) 0.631, there is a use-after-free in the ucompthread function (stream.c). Remote attackers could leverage this vulnerability to cause a denial of service via a crafted lrz file.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
5.5
In Long Range Zip (aka lrzip) 0.631, there is a use-after-free in the ucompthread function (stream.c). Remote attackers could leverage this vulnerability to cause a denial of service via a crafted lrz file.
- Record
CVE-2018-5747- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:N/A:P - Weakness
- CWE-416
- Updated
- 2026-11-02
CVE List No score
In Long Range Zip (aka lrzip) 0.631, there is a use-after-free in the ucompthread function (stream.c). Remote attackers could leverage this vulnerability to cause a denial of service via a crafted lrz file.
- Record
CVE-2018-5747- Updated
- 2026-11-02
EUVDEUVD-2018-17516 No score
In Long Range Zip (aka lrzip) 0.631, there is a use-after-free in the ucompthread function (stream.c). Remote attackers could leverage this vulnerability to cause a denial of service via a crafted lrz file.
- Record
EUVD-2018-17516- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-w22r-wrx7-522x
5.5
In Long Range Zip (aka lrzip) 0.631, there is a use-after-free in the ucompthread function ...
In Long Range Zip (aka lrzip) 0.631, there is a use-after-free in the ucompthread function (stream.c). Remote attackers could leverage this vulnerability to cause a denial of service via a crafted lrz file.
- Record
GHSA-w22r-wrx7-522x- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Weakness
- CWE-416
- Updated
- 2026-11-02
OSV
5.5
In Long Range Zip (aka lrzip) 0.631, there is a use-after-free in the ucompthread function (stream.c). Remote attackers could leverage this vulnerability to cause a denial of service via a crafted lrz file.
- Record
CVE-2018-5747- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2018-5747
5.5
In Long Range Zip (aka lrzip) 0.631, there is a use-after-free in the ucompthread function (stream.c). Remote attackers could leverage this vulnerability to cause a denial of service via a crafted lrz file.
- Record
DEBIAN-CVE-2018-5747- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2018-5747
5.5
In Long Range Zip (aka lrzip) 0.631, there is a use-after-free in the ucompthread function (stream.c). Remote attackers could leverage this vulnerability to cause a denial of service via a crafted lrz file.
- Record
UBUNTU-CVE-2018-5747- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUSN-5171-1 No score
lrzip vulnerabilities
It was discovered that Long Range ZIP incorrectly handled certain specially crafted lrz files. A remote attacker could possibly use this issue to cause a denial of service (crash) or other unspecified impact.
- Record
USN-5171-1- Updated
- 2026-11-02
OSVUSN-5171-2 No score
lrzip vulnerabilities
USN-5171-1 fixed vulnerabilities in Long Range ZIP. This update provides the corresponding updates for Ubuntu 14.04 ESM and Ubuntu 16.04 ESM.
Original advisory details:
It was discovered that Long Range ZIP incorrectly handled certain specially crafted lrz files. A remote attacker could possibly use this issue to cause a denial of service (crash) or other unspecified impact.
- Record
USN-5171-2- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
lrzipDebian:12 |
before 0.631+git180517-1 | 0.631+git180517-1 |
lrzipDebian:13 |
before 0.631+git180517-1 | 0.631+git180517-1 |
lrzipDebian:14 |
before 0.631+git180517-1 | 0.631+git180517-1 |
lrzipDebian:9 |
before 0.631-1+deb9u1, plus listed versions 0.631-1 |
0.631-1+deb9u1 |
lrzipUbuntu:Pro:14.04:LTS |
before 0.616-1ubuntu0.1~esm1, plus listed versions 0.608-20.616-10.616-1ubuntu0.1~esm |
0.616-1ubuntu0.1~esm1 |
lrzipUbuntu:Pro:16.04:LTS |
before 0.621-1ubuntu0.1~esm1, plus listed versions 0.621-1 |
0.621-1ubuntu0.1~esm1 |
lrzipUbuntu:18.04:LTS |
before 0.631-1+deb9u1build0.18.04.1, plus listed versions 0.631-1 |
0.631-1+deb9u1build0.18.04.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2018-5747 is a medium vulnerability (CVSS 5.5) in Long Range Zip Project Range Zip, published January 17, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.23%, the 68th percentile. Fixed in lrzip 0.631+git180517-1.
References
github.com/ckolivas/lrzip/issues/90
lists.debian.org/debian-lts-announce/2021/08/msg00001.html
nvd.nist.gov/vuln/detail/CVE-2018-5747
github.com/advisories/GHSA-w22r-wrx7-522x
security-tracker.debian.org/tracker/CVE-2018-5747
ubuntu.com/security/CVE-2018-5747
Show 12 moreShow less
ubuntu.com/security/notices/USN-5171-1
cve.org/CVERecord?id=CVE-2018-5747
ubuntu.com/security/notices/USN-5171-2
ubuntu.com/security/CVE-2017-8844
ubuntu.com/security/CVE-2017-8846
ubuntu.com/security/CVE-2017-9928
ubuntu.com/security/CVE-2017-9929
ubuntu.com/security/CVE-2018-5650
ubuntu.com/security/CVE-2018-5786
ubuntu.com/security/CVE-2018-9058
ubuntu.com/security/CVE-2018-10685
ubuntu.com/security/CVE-2018-11496