CVE-2020-12135
bson before 0.8 incorrectly uses int rather than size_t for many variables, parameters, and...
bson before 0.8 incorrectly uses int rather than size_t for many variables, parameters, and return values. In particular, the bson_ensure_space() parameter bytesNeeded could have an integer overflow via properly constructed bson input.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
5.5
bson before 0.8 incorrectly uses int rather than size_t for many variables, parameters, and return values. In particular, the bson_ensure_space() parameter bytesNeeded could have an integer overflow via properly constructed bson input.
- Record
CVE-2020-12135- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:N/A:P - Weakness
- CWE-190
- Updated
- 2026-11-02
CVE List No score
bson before 0.8 incorrectly uses int rather than size_t for many variables, parameters, and return values. In particular, the bson_ensure_space() parameter bytesNeeded could have an integer overflow via properly constructed bson input.
- Record
CVE-2020-12135- Updated
- 2026-11-02
EUVDEUVD-2020-4450 No score
bson before 0.8 incorrectly uses int rather than size_t for many variables, parameters, and return values. In particular, the bson_ensure_space() parameter bytesNeeded could have an integer overflow via properly constructed bson input.
- Record
EUVD-2020-4450- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-f54q-h8mw-5h8w No score
bson before 0.8 incorrectly uses int rather than size_t for many variables, parameters, and...
bson before 0.8 incorrectly uses int rather than size_t for many variables, parameters, and return values. In particular, the bson_ensure_space() parameter bytesNeeded could have an integer overflow via properly constructed bson input.
- Record
GHSA-f54q-h8mw-5h8w- Updated
- 2026-11-02
OSV
5.5
bson before 0.8 incorrectly uses int rather than size_t for many variables, parameters, and return values. In particular, the bson_ensure_space() parameter bytesNeeded could have an integer overflow via properly constructed bson input.
- Record
CVE-2020-12135- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2020-12135
5.5
bson before 0.8 incorrectly uses int rather than size_t for many variables, parameters, and return values. In particular, the bson_ensure_space() parameter bytesNeeded could have an integer overflow via properly constructed bson input.
- Record
DEBIAN-CVE-2020-12135- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2020-12135
5.5
bson before 0.8 incorrectly uses int rather than size_t for many variables, parameters, and return values. In particular, the bson_ensure_space() parameter bytesNeeded could have an integer overflow via properly constructed bson input.
- Record
UBUNTU-CVE-2020-12135- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUSN-4450-1 No score
whoopsie vulnerabilities
Seong-Joong Kim discovered that Whoopsie incorrectly handled memory. A local attacker could use this issue to cause Whoopsie to consume memory, resulting in a denial of service. (CVE-2020-11937)
Seong-Joong Kim discovered that Whoopsie incorrectly handled parsing files. A local attacker could use this issue to cause Whoopsie to crash, resulting in a denial of service, or possibly execute arbitrary code. (CVE-2020-12135)
Seong-Joong Kim discovered that Whoopsie incorrectly handled memory. A local attacker could use this issue to cause Whoopsie to consume memory, resulting in a denial of service. (CVE-2020-15570)
- Record
USN-4450-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
duo-unixDebian:12 |
All versions, plus listed versions 1.11.3-11.11.3-1.11.11.3-1.1~exp11.11.3-1.2 |
None known |
duo-unixDebian:13 |
All versions, plus listed versions 1.11.3-1.2 |
None known |
whoopsieUbuntu:16.04:LTS |
before 0.2.52.5ubuntu0.5, plus listed versions 0.2.490.2.500.2.510.2.520.2.52.1 Show 8 moreShow less0.2.52.20.2.52.30.2.52.40.2.52.50.2.52.5ubuntu0.10.2.52.5ubuntu0.20.2.52.5ubuntu0.30.2.52.5ubuntu0.4 |
0.2.52.5ubuntu0.5 |
duo-unixUbuntu:16.04:LTS |
All versions, plus listed versions 1.9.11-1 |
None known |
whoopsieUbuntu:18.04:LTS |
before 0.2.62ubuntu0.5, plus listed versions 0.2.580.2.590.2.59build10.2.600.2.62 Show 4 moreShow less0.2.62ubuntu0.10.2.62ubuntu0.20.2.62ubuntu0.30.2.62ubuntu0.4 |
0.2.62ubuntu0.5 |
duo-unixUbuntu:18.04:LTS |
All versions, plus listed versions 1.9.21-11.9.21-1build1 |
None known |
whoopsieUbuntu:20.04:LTS |
before 0.2.69ubuntu0.1, plus listed versions 0.2.660.2.670.2.680.2.69 |
0.2.69ubuntu0.1 |
duo-unixUbuntu:20.04:LTS |
All versions, plus listed versions 1.9.21-1.11.11.3-1 |
None known |
duo-unixUbuntu:22.04:LTS |
All versions, plus listed versions 1.11.3-11.11.3-1build1 |
None known |
duo-unixUbuntu:24.04:LTS |
All versions, plus listed versions 1.11.3-1build11.11.3-1.11.11.3-1.1build11.11.3-1.1build2 |
None known |
Show 6 moreShow less
| Package | Affected | Fixed |
|---|---|---|
duo-unixUbuntu:25.10 |
All versions, plus listed versions 1.11.3-1.2 |
None known |
duo-unixUbuntu:26.10 |
All versions, plus listed versions 1.11.3-1.2build11.11.3-1.2ubuntu1 |
None known |
duo-unixUbuntu:26.04:LTS |
All versions, plus listed versions 1.11.3-1.21.11.3-1.2build1 |
None known |
whoopsieUbuntu:16.04:LTS From an advisory covering 3 CVEs |
before 0.2.52.5ubuntu0.5, plus listed versions 0.2.490.2.500.2.510.2.520.2.52.1 Show 8 moreShow less0.2.52.20.2.52.30.2.52.40.2.52.50.2.52.5ubuntu0.10.2.52.5ubuntu0.20.2.52.5ubuntu0.30.2.52.5ubuntu0.4 |
0.2.52.5ubuntu0.5 |
whoopsieUbuntu:18.04:LTS From an advisory covering 3 CVEs |
before 0.2.62ubuntu0.5, plus listed versions 0.2.580.2.590.2.59build10.2.600.2.62 Show 4 moreShow less0.2.62ubuntu0.10.2.62ubuntu0.20.2.62ubuntu0.30.2.62ubuntu0.4 |
0.2.62ubuntu0.5 |
whoopsieUbuntu:20.04:LTS From an advisory covering 3 CVEs |
before 0.2.69ubuntu0.1, plus listed versions 0.2.660.2.670.2.680.2.69 |
0.2.69ubuntu0.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2020-12135 is a medium vulnerability (CVSS 5.5) in Mongodb C Driver, published April 24, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.17%, the 67th percentile. Fixed in whoopsie 0.2.52.5ubuntu0.5.
References
bugs.launchpad.net/ubuntu/+source/whoopsie/+bug/1872560
launchpadlibrarian.net/474887364/bson-fix-overflow.patch
github.com/10gen-archive/mongo-c-driver-legacy/commit/1a1f5e26a4309480d88598913f9eebf9e9cba8ca
usn.ubuntu.com/4450-1
nvd.nist.gov/vuln/detail/CVE-2020-12135
github.com/advisories/GHSA-f54q-h8mw-5h8w