Every CVE Search/ Get API key

CVE-2017-1000450

Integer Overflow or Wraparound in OpenCV.

8.8 HighFix available

In opencv/modules/imgcodecs/src/utils.cpp, functions FillUniColor and FillUniGray do not check the input length, which can lead to integer overflow. If the image is from remote, may lead to remote code execution or denial of service. This affects Opencv 3.3 and earlier.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

3.26%Up 0.4 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 8.8

In opencv/modules/imgcodecs/src/utils.cpp, functions FillUniColor and FillUniGray do not check the input length, which can lead to integer overflow. If the image is from remote, may lead to remote code execution or denial of service. This affects Opencv 3.3 and earlier.

Record
CVE-2017-1000450
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-190
Updated
2026-11-02
CVE List No score

In opencv/modules/imgcodecs/src/utils.cpp, functions FillUniColor and FillUniGray do not check the input length, which can lead to integer overflow. If the image is from remote, may lead to remote code execution or denial of service. This affects Opencv 3.3 and earlier.

Record
CVE-2017-1000450
Updated
2026-11-02
EUVDEUVD-2021-2221 No score

In opencv/modules/imgcodecs/src/utils.cpp, functions FillUniColor and FillUniGray do not check the input length, which can lead to integer overflow. If the image is from remote, may lead to remote code execution or denial of service. This affects Opencv 3.3 and earlier.

Record
EUVD-2021-2221
Updated
2026-11-03
GitHub AdvisoriesGHSA-m43c-649m-pm48 8.8

Integer Overflow or Wraparound in OpenCV.

In opencv/modules/imgcodecs/src/utils.cpp, functions FillUniColor and FillUniGray do not check the input length, which can lead to integer overflow. If the image is from remote, may lead to remote code execution or denial of service. This affects Opencv 3.3 (corresponding with OpenCV-Python 3.3.0.9) and earlier.

Record
GHSA-m43c-649m-pm48
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-190
Updated
2026-11-02
OSV 8.8

In opencv/modules/imgcodecs/src/utils.cpp, functions FillUniColor and FillUniGray do not check the input length, which can lead to integer overflow. If the image is from remote, may lead to remote code execution or denial of service. This affects Opencv 3.3 and earlier.

Record
CVE-2017-1000450
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2017-1000450 8.8

In opencv/modules/imgcodecs/src/utils.cpp, functions FillUniColor and FillUniGray do not check the input length, which can lead to integer overflow. If the image is from remote, may lead to remote code execution or denial of service. This affects Opencv 3.3 and earlier.

Record
DEBIAN-CVE-2017-1000450
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
Show 4 moreShow less
OSVGHSA-m43c-649m-pm48 8.8

Integer Overflow or Wraparound in OpenCV.

In opencv/modules/imgcodecs/src/utils.cpp, functions FillUniColor and FillUniGray do not check the input length, which can lead to integer overflow. If the image is from remote, may lead to remote code execution or denial of service. This affects Opencv 3.3 (corresponding with OpenCV-Python 3.3.0.9) and earlier.

Record
GHSA-m43c-649m-pm48
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-190
Updated
2026-11-02
OSVPYSEC-2026-2825 8.8

Integer Overflow or Wraparound in OpenCV.

In opencv/modules/imgcodecs/src/utils.cpp, functions FillUniColor and FillUniGray do not check the input length, which can lead to integer overflow. If the image is from remote, may lead to remote code execution or denial of service. This affects Opencv 3.3 (corresponding with OpenCV-Python 3.3.0.9) and earlier.

Record
PYSEC-2026-2825
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVPYSEC-2026-712 8.8

Integer Overflow or Wraparound in OpenCV.

In opencv/modules/imgcodecs/src/utils.cpp, functions FillUniColor and FillUniGray do not check the input length, which can lead to integer overflow. If the image is from remote, may lead to remote code execution or denial of service. This affects Opencv 3.3 (corresponding with OpenCV-Python 3.3.0.9) and earlier.

Record
PYSEC-2026-712
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2017-1000450 8.8

In opencv/modules/imgcodecs/src/utils.cpp, functions FillUniColor and FillUniGray do not check the input length, which can lead to integer overflow. If the image is from remote, may lead to remote code execution or denial of service. This affects Opencv 3.3 and earlier.

Record
UBUNTU-CVE-2017-1000450
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
opencv-python
PyPI
through 3.3.0.9
3.3.1.11
opencv-contrib-python
PyPI
through 3.3.0.9
3.3.1.11
opencv
Debian:12
before 3.2.0+dfsg-6
3.2.0+dfsg-6
opencv
Debian:13
before 3.2.0+dfsg-6
3.2.0+dfsg-6
opencv
Debian:14
before 3.2.0+dfsg-6
3.2.0+dfsg-6
opencv
Debian:7
From an advisory covering 2 CVEs
before 2.3.1-11+deb7u3, plus listed versions
2.3.1-112.3.1-11+deb7u12.3.1-11+deb7u2
2.3.1-11+deb7u3
opencv
Debian:8
From an advisory covering 16 CVEs
before 2.4.9.1+dfsg-1+deb8u2, plus listed versions
2.4.9.1+dfsg-12.4.9.1+dfsg-1+deb8u1
2.4.9.1+dfsg-1+deb8u2
opencv
Debian:9
From an advisory covering 18 CVEs
before 2.4.9.1+dfsg1-2+deb9u1, plus listed versions
2.4.9.1+dfsg1-2
2.4.9.1+dfsg1-2+deb9u1
opencv-python
PyPI
before 3.3.1.11
3.3.1.11
opencv-contrib-python
PyPI
before 3.3.1.11
3.3.1.11
opencv
Ubuntu:16.04:LTS
before 2.4.9.1+dfsg-1.5ubuntu1.1, plus listed versions
2.4.9+dfsg-1ubuntu62.4.9.1+dfsg-1.2ubuntu12.4.9.1+dfsg-1.3ubuntu12.4.9.1+dfsg-1.5ubuntu1
2.4.9.1+dfsg-1.5ubuntu1.1
opencv
Ubuntu:18.04:LTS
before 3.2.0+dfsg-4ubuntu0.1, plus listed versions
3.1.0+dfsg1-1~exp1ubuntu33.2.0+dfsg-33.2.0+dfsg-43.2.0+dfsg-4build13.2.0+dfsg-4build2
3.2.0+dfsg-4ubuntu0.1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-1000450 is a high vulnerability (CVSS 8.8) in Opencv, published January 2, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.26%, the 88th percentile. Fixed in opencv-python 3.3.1.11.

References

Show 8 moreShow less
MoveEnter Open