Every CVE Search/ Get API key

CVE-2015-2171

Slim vulnerable to PHP object injection

7.5 HighFix available

Middleware/SessionCookie.php in Slim before 2.6.0 allows remote attackers to conduct PHP object injection attacks and execute arbitrary PHP code via crafted session data.

Exploit likelihood

2.50%Up 1.3 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Middleware/SessionCookie.php in Slim before 2.6.0 allows remote attackers to conduct PHP object injection attacks and execute arbitrary PHP code via crafted session data.

Record
CVE-2015-2171
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-94
Updated
2026-11-02
CVE List No score

Middleware/SessionCookie.php in Slim before 2.6.0 allows remote attackers to conduct PHP object injection attacks and execute arbitrary PHP code via crafted session data.

Record
CVE-2015-2171
Updated
2026-11-02
EUVDEUVD-2022-2914 No score

Middleware/SessionCookie.php in Slim before 2.6.0 allows remote attackers to conduct PHP object injection attacks and execute arbitrary PHP code via crafted session data.

Record
EUVD-2022-2914
Updated
2026-11-03
GitHub AdvisoriesGHSA-74mf-vjpg-9xh7 No score

Slim vulnerable to PHP object injection

Middleware/SessionCookie.php in Slim before 2.6.0 allows remote attackers to conduct PHP object injection attacks and execute arbitrary PHP code via crafted session data.

Record
GHSA-74mf-vjpg-9xh7
Weakness
CWE-94
Updated
2026-11-02
OSVGHSA-74mf-vjpg-9xh7 No score

Slim vulnerable to PHP object injection

Middleware/SessionCookie.php in Slim before 2.6.0 allows remote attackers to conduct PHP object injection attacks and execute arbitrary PHP code via crafted session data.

Record
GHSA-74mf-vjpg-9xh7
Weakness
CWE-94
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
slim/slim
Packagist
before 2.6.0
2.6.0
slim/slim
Packagist
before 2.6.0, plus listed versions
1.6.01.6.11.6.21.6.31.6.4
Show 17 moreShow less
1.6.51.6.61.6.72.0.02.1.02.2.02.3.02.3.12.3.22.3.32.3.42.3.52.4.02.4.12.4.22.4.32.5.0
2.6.0

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2015-2171 is a high vulnerability (CVSS 7.5) in Slimframework Slim, published March 30, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.50%, the 84th percentile. Fixed in slim/slim 2.6.0.

References

Show 4 moreShow less
MoveEnter Open