CVE-2017-1000499
phpMyAdmin CSRF Vulnerability
phpMyAdmin versions 4.7.x (prior to 4.7.6.1/4.7.7) are vulnerable to a CSRF weakness. By deceiving a user to click on a crafted URL, it is possible to perform harmful database operations such as deleting records, dropping/truncating tables etc.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
8.8
phpMyAdmin versions 4.7.x (prior to 4.7.6.1/4.7.7) are vulnerable to a CSRF weakness. By deceiving a user to click on a crafted URL, it is possible to perform harmful database operations such as deleting records, dropping/truncating tables etc.
- Record
CVE-2017-1000499- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - CVSS 2.0
- 6.8 Medium
AV:N/AC:M/Au:N/C:P/I:P/A:P - Weakness
- CWE-352
- Updated
- 2026-11-02
CVE List No score
phpMyAdmin versions 4.7.x (prior to 4.7.6.1/4.7.7) are vulnerable to a CSRF weakness. By deceiving a user to click on a crafted URL, it is possible to perform harmful database operations such as deleting records, dropping/truncating tables etc.
- Record
CVE-2017-1000499- Updated
- 2026-11-02
EUVDEUVD-2022-3737 No score
phpMyAdmin versions 4.7.x (prior to 4.7.6.1/4.7.7) are vulnerable to a CSRF weakness. By deceiving a user to click on a crafted URL, it is possible to perform harmful database operations such as deleting records, dropping/truncating tables etc.
- Record
EUVD-2022-3737- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-f9hx-5jq4-fgjm
8.8
phpMyAdmin CSRF Vulnerability
phpMyAdmin versions 4.7.x (prior to 4.7.6.1/4.7.7) are vulnerable to a CSRF weakness. By deceiving a user to click on a crafted URL, it is possible to perform harmful database operations such as deleting records, dropping/truncating tables etc.
- Record
GHSA-f9hx-5jq4-fgjm- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-352
- Updated
- 2026-11-02
OSV
8.8
phpMyAdmin versions 4.7.x (prior to 4.7.6.1/4.7.7) are vulnerable to a CSRF weakness. By deceiving a user to click on a crafted URL, it is possible to perform harmful database operations such as deleting records, dropping/truncating tables etc.
- Record
CVE-2017-1000499- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVGHSA-f9hx-5jq4-fgjm
8.8
phpMyAdmin CSRF Vulnerability
phpMyAdmin versions 4.7.x (prior to 4.7.6.1/4.7.7) are vulnerable to a CSRF weakness. By deceiving a user to click on a crafted URL, it is possible to perform harmful database operations such as deleting records, dropping/truncating tables etc.
- Record
GHSA-f9hx-5jq4-fgjm- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-352
- Updated
- 2026-11-02
OSVopenSUSE-SU-2018:0534-1 No score
Security update for phpMyAdmin
This update for phpMyAdmin 4.7.8 fixes the following issues:
- CVE-2018-7260: self-cross site scripting (XSS) vulnerability in the central columns feature (boo#1082188)
This version also fixes some minor functionality bugs. The previous update already fixed CVE-2017-1000499.
- Record
openSUSE-SU-2018:0534-1- Updated
- 2026-11-02
OSVopenSUSE-SU-2018:0536-1 No score
Security update for phpMyAdmin
This update for phpMyAdmin 4.7.8 fixes the following issues:
- CVE-2018-7260: self-cross site scripting (XSS) vulnerability in the central columns feature (boo#1082188)
This version also fixes some minor functionality bugs. The previous update already fixed CVE-2017-1000499.
- Record
openSUSE-SU-2018:0536-1- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:11171-1 No score
phpMyAdmin-5.1.1-1.2 on GA media
These are all security issues fixed in the phpMyAdmin-5.1.1-1.2 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:11171-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
phpmyadmin/phpmyadminPackagist |
4.7 up to 4.7.7 | 4.7.7 |
phpmyadmin/phpmyadminPackagist |
4.7 up to 4.7.7, plus listed versions 4.7.04.7.14.7.24.7.34.7.44.7.54.7.6 |
4.7.7 |
phpMyAdminSUSE:Package Hub 12 |
before 4.7.8-17.1 | 4.7.8-17.1 |
phpMyAdminopenSUSE:Tumbleweed |
before 5.1.1-1.2 | 5.1.1-1.2 |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| Exploit-DB | phpMyAdmin 4.7.x - Cross-Site Request Forgery | 2018-08-29 |
| PoC in GitHub | Villaquiranm/5MMISSI-CVE-2017-1000499 | 2019-01-05 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, Exploit-DB, GitHub Advisories, NVD, OSV, PoC in GitHub |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-1000499 is a high vulnerability (CVSS 8.8) in Phpmyadmin, published January 3, 2018. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 8.46%, the 95th percentile. Fixed in phpmyadmin/phpmyadmin 4.7.7.
References
securitytracker.com/id/1040163
cyberworldmirror.com/vulnerability-phpmyadmin-lets-attacker-perform-drop-table-single-click
exploit-db.com/exploits/45284
phpmyadmin.net/security/PMASA-2017-9
nvd.nist.gov/vuln/detail/CVE-2017-1000499
web.archive.org/web/20201208204518/http://www.securitytracker.com/id/1040163
Show 33 moreShow less
github.com/advisories/GHSA-f9hx-5jq4-fgjm
bugzilla.suse.com/1082188
suse.com/security/cve/CVE-2017-1000499
suse.com/security/cve/CVE-2018-7260
suse.com/security/cve/CVE-2005-2869
suse.com/security/cve/CVE-2006-1804
suse.com/security/cve/CVE-2006-2031
suse.com/security/cve/CVE-2015-8980
suse.com/security/cve/CVE-2017-1000013
suse.com/security/cve/CVE-2017-1000014
suse.com/security/cve/CVE-2017-1000015
suse.com/security/cve/CVE-2017-1000016
suse.com/security/cve/CVE-2017-1000017
suse.com/security/cve/CVE-2017-1000018
suse.com/security/cve/CVE-2018-10188
suse.com/security/cve/CVE-2018-12581
suse.com/security/cve/CVE-2018-12613
suse.com/security/cve/CVE-2018-15605
suse.com/security/cve/CVE-2018-19968
suse.com/security/cve/CVE-2018-19969
suse.com/security/cve/CVE-2018-19970
suse.com/security/cve/CVE-2019-11768
suse.com/security/cve/CVE-2019-12616
suse.com/security/cve/CVE-2019-12922
suse.com/security/cve/CVE-2019-18622
suse.com/security/cve/CVE-2019-6798
suse.com/security/cve/CVE-2019-6799
suse.com/security/cve/CVE-2020-10802
suse.com/security/cve/CVE-2020-10803
suse.com/security/cve/CVE-2020-10804
suse.com/security/cve/CVE-2020-26934
suse.com/security/cve/CVE-2020-26935
suse.com/security/cve/CVE-2020-5504