CVE-2017-1000442
Passbolt API is vulnerable to XSS in the url field on the password workspace grid and sidebar
Passbolt API version 1.6.4 and older are vulnerable to a XSS in the url field on the password workspace
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
5.4
Passbolt API version 1.6.4 and older are vulnerable to a XSS in the url field on the password workspace
- Record
CVE-2017-1000442- CVSS 3.0
- 5.4 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 3.5 Low
AV:N/AC:M/Au:S/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
Passbolt API version 1.6.4 and older are vulnerable to a XSS in the url field on the password workspace
- Record
CVE-2017-1000442- Updated
- 2026-11-02
EUVDEUVD-2022-4256 No score
Passbolt API version 1.6.4 and older are vulnerable to a XSS in the url field on the password workspace
- Record
EUVD-2022-4256- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-j2fp-9wp5-mg66
5.4
Passbolt API is vulnerable to XSS in the url field on the password workspace grid and sidebar
Passbolt API version 1.6.4 and older are vulnerable to a XSS in the url field on the password workspace
- Record
GHSA-j2fp-9wp5-mg66- CVSS 3.0
- 5.4 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
5.4
Passbolt API version 1.6.4 and older are vulnerable to a XSS in the url field on the password workspace
- Record
CVE-2017-1000442- CVSS 3.0
- 5.4 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVGHSA-j2fp-9wp5-mg66
5.4
Passbolt API is vulnerable to XSS in the url field on the password workspace grid and sidebar
Passbolt API version 1.6.4 and older are vulnerable to a XSS in the url field on the password workspace
- Record
GHSA-j2fp-9wp5-mg66- CVSS 3.0
- 5.4 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
passbolt/passbolt_apiPackagist |
before 1.6.5 | 1.6.5 |
passbolt/passbolt_apiPackagist |
before 1.6.5, plus listed versions v1.0.10v1.0.11v1.0.12v1.0.13v1.0.14 Show 18 moreShow lessv1.0.5v1.0.6v1.0.7v1.0.8v1.0.9v1.1.0v1.2.0v1.2.1v1.3.0v1.3.1v1.3.2v1.4.0v1.5.1v1.6.0v1.6.1v1.6.2v1.6.3v1.6.4 |
1.6.5 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-1000442 is a medium vulnerability (CVSS 5.4) in Passbolt Api, published January 2, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.52%, the 44th percentile. Fixed in passbolt/passbolt_api 1.6.5.
References
passbolt.com/incidents/20170914_xss_on_resource_urls
passbolt.com/release/notes
nvd.nist.gov/vuln/detail/CVE-2017-1000442
github.com/passbolt/passbolt_api/commit/f5eb93485a90195439e12aa8072f45ceb37b19c3
github.com/FriendsOfPHP/security-advisories/blob/master/passbolt/passbolt_api/CVE-2017-1000442.yaml
github.com/advisories/GHSA-j2fp-9wp5-mg66
github.com/passbolt/passbolt_api