Every CVE Search/ Get API key

CVE-2018-10856

Podman Elevated Container Privileges

5.3 MediumFix available

It has been discovered that podman before version 0.6.1 does not drop capabilities when executing a container as a non-root user. This results in unnecessary privileges being granted to the container.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
Low

Exploit likelihood

0.88%Unchanged since Apr 14, 2021
90%50%10%1%

What each source reports

CVE List Score used 5.3

It has been discovered that podman before version 0.6.1 does not drop capabilities when executing a container as a non-root user. This results in unnecessary privileges being granted to the container.

Record
CVE-2018-10856
CVSS 3.0
5.3 MediumCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
Weakness
CWE-250
Updated
2026-11-02
EUVDEUVD-2022-5613 5.3

It has been discovered that podman before version 0.6.1 does not drop capabilities when executing a container as a non-root user. This results in unnecessary privileges being granted to the container.

Record
EUVD-2022-5613
CVSS 3.0
5.3 MediumCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
Updated
2026-11-03
GitHub AdvisoriesGHSA-wp7w-vx86-vj9h 8.7

Podman Elevated Container Privileges

It has been discovered that podman before version 0.6.1 does not drop capabilities when executing a container as a non-root user. This results in unnecessary privileges being granted to the container.

Record
GHSA-wp7w-vx86-vj9h
CVSS 4.0
8.7 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-732
Updated
2026-11-02
NVD 5.3

It has been discovered that podman before version 0.6.1 does not drop capabilities when executing a container as a non-root user. This results in unnecessary privileges being granted to the container.

Record
CVE-2018-10856
CVSS 3.0
5.3 MediumCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
6.5 MediumAV:N/AC:L/Au:S/C:P/I:P/A:P
Weakness
CWE-250, CWE-732
Updated
2026-11-02
OSV 8.8

It has been discovered that podman before version 0.6.1 does not drop capabilities when executing a container as a non-root user. This results in unnecessary privileges being granted to the container.

Record
CVE-2018-10856
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVGHSA-wp7w-vx86-vj9h 8.7

Podman Elevated Container Privileges

It has been discovered that podman before version 0.6.1 does not drop capabilities when executing a container as a non-root user. This results in unnecessary privileges being granted to the container.

Record
GHSA-wp7w-vx86-vj9h
CVSS 4.0
8.7 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-732
Updated
2026-11-02
OSVRHSA-2018:2037 5.3

Red Hat Security Advisory: podman security update

Record
RHSA-2018:2037
CVSS 3.0
5.3 MediumCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
Updated
2026-11-02
OSVGO-2023-1962 No score

Podman Elevated Container Privileges in github.com/containers/podman

Podman Elevated Container Privileges in github.com/containers/podman

Record
GO-2023-1962
Updated
2026-11-02
OSVopenSUSE-SU-2024:11177-1 No score

podman-3.3.1-2.1 on GA media

These are all security issues fixed in the podman-3.3.1-2.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11177-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
github.com/containers/podman
Go
before 0.6.1
0.6.1
github.com/containers/podman/v2
Go
All versions None known
github.com/containers/podman/v3
Go
All versions None known
github.com/containers/podman/v4
Go
All versions None known
podman
Red Hat:rhel_extras_other:7
before 0:0.6.1-3.git3e0ff12.el7
0:0.6.1-3.git3e0ff12.el7
podman-debuginfo
Red Hat:rhel_extras_other:7
before 0:0.6.1-3.git3e0ff12.el7
0:0.6.1-3.git3e0ff12.el7
podman
openSUSE:Tumbleweed
From an advisory covering 6 CVEs
before 3.3.1-2.1
3.3.1-2.1

History

History
RecordedChangedSources
affected, facts
aliases, productsEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2018-10856 is a medium vulnerability (CVSS 5.3) in [unknown] Podman, published July 2, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.88%, the 59th percentile. Fixed in github.com/containers/podman 0.6.1.

References

Show 11 moreShow less
MoveEnter Open