CVE-2018-10856
Podman Elevated Container Privileges
It has been discovered that podman before version 0.6.1 does not drop capabilities when executing a container as a non-root user. This results in unnecessary privileges being granted to the container.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- Low
Exploit likelihood
What each source reports
CVE List Score used
5.3
It has been discovered that podman before version 0.6.1 does not drop capabilities when executing a container as a non-root user. This results in unnecessary privileges being granted to the container.
- Record
CVE-2018-10856- CVSS 3.0
- 5.3 Medium
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L - Weakness
- CWE-250
- Updated
- 2026-11-02
EUVDEUVD-2022-5613
5.3
It has been discovered that podman before version 0.6.1 does not drop capabilities when executing a container as a non-root user. This results in unnecessary privileges being granted to the container.
- Record
EUVD-2022-5613- CVSS 3.0
- 5.3 Medium
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-wp7w-vx86-vj9h
8.7
Podman Elevated Container Privileges
It has been discovered that podman before version 0.6.1 does not drop capabilities when executing a container as a non-root user. This results in unnecessary privileges being granted to the container.
- Record
GHSA-wp7w-vx86-vj9h- CVSS 4.0
- 8.7 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N - CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-732
- Updated
- 2026-11-02
NVD
5.3
It has been discovered that podman before version 0.6.1 does not drop capabilities when executing a container as a non-root user. This results in unnecessary privileges being granted to the container.
- Record
CVE-2018-10856- CVSS 3.0
- 5.3 Medium
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L - CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 6.5 Medium
AV:N/AC:L/Au:S/C:P/I:P/A:P - Weakness
- CWE-250, CWE-732
- Updated
- 2026-11-02
OSV
8.8
It has been discovered that podman before version 0.6.1 does not drop capabilities when executing a container as a non-root user. This results in unnecessary privileges being granted to the container.
- Record
CVE-2018-10856- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVGHSA-wp7w-vx86-vj9h
8.7
Podman Elevated Container Privileges
It has been discovered that podman before version 0.6.1 does not drop capabilities when executing a container as a non-root user. This results in unnecessary privileges being granted to the container.
- Record
GHSA-wp7w-vx86-vj9h- CVSS 4.0
- 8.7 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N - CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-732
- Updated
- 2026-11-02
OSVRHSA-2018:2037
5.3
Red Hat Security Advisory: podman security update
- Record
RHSA-2018:2037- CVSS 3.0
- 5.3 Medium
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L - Updated
- 2026-11-02
OSVGO-2023-1962 No score
Podman Elevated Container Privileges in github.com/containers/podman
Podman Elevated Container Privileges in github.com/containers/podman
- Record
GO-2023-1962- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:11177-1 No score
podman-3.3.1-2.1 on GA media
These are all security issues fixed in the podman-3.3.1-2.1 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:11177-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
github.com/containers/podmanGo |
before 0.6.1 | 0.6.1 |
github.com/containers/podman/v2Go |
All versions | None known |
github.com/containers/podman/v3Go |
All versions | None known |
github.com/containers/podman/v4Go |
All versions | None known |
podmanRed Hat:rhel_extras_other:7 |
before 0:0.6.1-3.git3e0ff12.el7 | 0:0.6.1-3.git3e0ff12.el7 |
podman-debuginfoRed Hat:rhel_extras_other:7 |
before 0:0.6.1-3.git3e0ff12.el7 | 0:0.6.1-3.git3e0ff12.el7 |
podmanopenSUSE:Tumbleweed From an advisory covering 6 CVEs |
before 3.3.1-2.1 | 3.3.1-2.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases, products | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2018-10856 is a medium vulnerability (CVSS 5.3) in [unknown] Podman, published July 2, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.88%, the 59th percentile. Fixed in github.com/containers/podman 0.6.1.
References
bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-10856
github.com/projectatomic/libpod/commit/bae80a0b663925ec751ad2784ca32989403cdc24
access.redhat.com/errata/RHSA-2018:2037
nvd.nist.gov/vuln/detail/CVE-2018-10856
github.com/advisories/GHSA-wp7w-vx86-vj9h
github.com/containers/podman
Show 11 moreShow less
access.redhat.com/security/updates/classification
bugzilla.redhat.com/show_bug.cgi?id=1592166
security.access.redhat.com/data/csaf/v2/advisories/2018/rhsa-2018_2037.json
access.redhat.com/security/cve/CVE-2018-10856
cve.org/CVERecord?id=CVE-2018-10856
suse.com/security/cve/CVE-2018-10856
suse.com/security/cve/CVE-2019-10152
suse.com/security/cve/CVE-2019-10214
suse.com/security/cve/CVE-2020-14370
suse.com/security/cve/CVE-2020-1726
suse.com/security/cve/CVE-2021-20199