CVE-2023-29579
yasm 1.3.0.55.g101bc was discovered to contain a stack overflow via the component yasm/yasm...
yasm 1.3.0.55.g101bc was discovered to contain a stack overflow via the component yasm/yasm+0x43b466 in vsprintf. Note: This has been disputed by third parties who argue this is a bug and not a security issue because yasm is a standalone program not designed to run untrusted code.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
5.5
yasm 1.3.0.55.g101bc was discovered to contain a stack overflow via the component yasm/yasm+0x43b466 in vsprintf. Note: This has been disputed by third parties who argue this is a bug and not a security issue because yasm is a standalone program not designed to run untrusted code.
- Record
CVE-2023-29579- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Weakness
- CWE-787
- Updated
- 2026-11-02
CVE List No score
yasm 1.3.0.55.g101bc was discovered to contain a stack overflow via the component yasm/yasm+0x43b466 in vsprintf. Note: This has been disputed by third parties who argue this is a bug and not a security issue because yasm is a standalone program not designed to run untrusted code.
- Record
CVE-2023-29579- Updated
- 2026-11-02
EUVDEUVD-2023-33120 No score
yasm 1.3.0.55.g101bc was discovered to contain a stack overflow via the component yasm/yasm+0x43b466 in vsprintf. Note: This has been disputed by third parties who argue this is a bug and not a security issue because yasm is a standalone program not designed to run untrusted code.
- Record
EUVD-2023-33120- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-9rj4-9hjf-7pcg
7.8
yasm 1.3.0.55.g101bc was discovered to contain a stack overflow via the component yasm/yasm...
yasm 1.3.0.55.g101bc was discovered to contain a stack overflow via the component yasm/yasm+0x43b466 in vsprintf.
- Record
GHSA-9rj4-9hjf-7pcg- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-787
- Updated
- 2026-11-02
OSV
5.5
yasm 1.3.0.55.g101bc was discovered to contain a stack overflow via the component yasm/yasm+0x43b466 in vsprintf. Note: This has been disputed by third parties who argue this is a bug and not a security issue because yasm is a standalone program not designed to run untrusted code.
- Record
CVE-2023-29579- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2023-29579
5.5
yasm 1.3.0.55.g101bc was discovered to contain a stack overflow via the component yasm/yasm+0x43b466 in vsprintf. Note: This has been disputed by third parties who argue this is a bug and not a security issue because yasm is a standalone program not designed to run untrusted code.
- Record
DEBIAN-CVE-2023-29579- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVOESA-2025-1526
5.5
yasm security update
Yasm is a complete rewrite of the NASM assembler under the “new” BSD License.
Security Fix(es):
An issue was discovered in yasm version 1.3.0. There is a NULL pointer dereference in yasm_expr_get_intnum() in libyasm/expr.c.(CVE-2021-33454)
An issue was discovered in yasm version 1.3.0. There is a heap-buffer-overflow in inc_fopen() in modules/preprocs/nasm/nasm-pp.c.(CVE-2021-33464)
yasm 1.3.0.55.g101bc was discovered to contain a stack overflow via the component yasm/yasm+0x43b466 in vsprintf. Note: This has been disputed by third parties who argue this is a bug and not a security issue because yasm is a standalone program not designed to run untrusted code.(CVE-2023-29579)
- Record
OESA-2025-1526- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
yasmDebian:12 |
All versions, plus listed versions 1.3.0-41.3.0-51.3.0-61.3.0-71.3.0-8 |
None known |
yasmDebian:13 |
before 1.3.0-7 | 1.3.0-7 |
yasmDebian:14 |
before 1.3.0-7 | 1.3.0-7 |
yasmopenEuler:24.03-LTS-SP1 From an advisory covering 3 CVEs |
before 1.3.0-13.oe2403sp1 | 1.3.0-13.oe2403sp1 |
yasmopenEuler:20.03-LTS-SP4 From an advisory covering 3 CVEs |
before 1.3.0-13.oe2003sp4 | 1.3.0-13.oe2003sp4 |
yasmopenEuler:22.03-LTS-SP3 From an advisory covering 3 CVEs |
before 1.3.0-13.oe2203sp3 | 1.3.0-13.oe2203sp3 |
yasmopenEuler:22.03-LTS-SP4 From an advisory covering 3 CVEs |
before 1.3.0-13.oe2203sp4 | 1.3.0-13.oe2203sp4 |
yasmopenEuler:24.03-LTS From an advisory covering 3 CVEs |
before 1.3.0-13.oe2403 | 1.3.0-13.oe2403 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2023-29579 is a medium vulnerability (CVSS 5.5) in Yasm Project Yasm, published April 24, 2023. Its validity is disputed. EPSS puts the chance of exploitation in the next 30 days at 0.30%, the 23rd percentile. Fixed in yasm 1.3.0-7.
References
github.com/yasm/yasm/issues/214
github.com/z1r00/fuzz_vuln/blob/main/yasm/stack-buffer-overflow/yasm/readmd.md
nvd.nist.gov/vuln/detail/CVE-2023-29579
github.com/advisories/GHSA-9rj4-9hjf-7pcg
security-tracker.debian.org/tracker/CVE-2023-29579
openeuler.org/zh/security/security-bulletins/detail?id=openEuler-SA-2025-1526
nvd.nist.gov/vuln/detail/CVE-2021-33454
nvd.nist.gov/vuln/detail/CVE-2021-33464