Every CVE Search/ Get API key

CVE-2024-5158

Type Confusion in V8 in Google Chrome prior to 125.0.6422.76 allowed a remote attacker to...

8.1 HighFix available

Type Confusion in V8 in Google Chrome prior to 125.0.6422.76 allowed a remote attacker to potentially perform arbitrary read/write via a crafted HTML page. (Chromium security severity: High)

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
None

Exploit likelihood

0.61%Up 0.6 points since May 23, 2024
90%50%10%1%

What each source reports

NVD Score used 8.1

Type Confusion in V8 in Google Chrome prior to 125.0.6422.76 allowed a remote attacker to potentially perform arbitrary read/write via a crafted HTML page. (Chromium security severity: High)

Record
CVE-2024-5158
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-843
Updated
2026-11-02
CVE List 8.8

Type Confusion in V8 in Google Chrome prior to 125.0.6422.76 allowed a remote attacker to potentially perform arbitrary read/write via a crafted HTML page. (Chromium security severity: High)

Record
CVE-2024-5158
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-843
Updated
2026-11-02
EUVDEUVD-2024-46409 8.8

Type Confusion in V8 in Google Chrome prior to 125.0.6422.76 allowed a remote attacker to potentially perform arbitrary read/write via a crafted HTML page. (Chromium security severity: High)

Record
EUVD-2024-46409
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
GitHub AdvisoriesGHSA-4433-jwm9-48r5 8.8

Type Confusion in V8 in Google Chrome prior to 125.0.6422.76 allowed a remote attacker to...

Type Confusion in V8 in Google Chrome prior to 125.0.6422.76 allowed a remote attacker to potentially perform arbitrary read/write via a crafted HTML page. (Chromium security severity: High)

Record
GHSA-4433-jwm9-48r5
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-22, CWE-843
Updated
2026-11-02
OSVALPINE-CVE-2024-5158 8.1

Type Confusion in V8 in Google Chrome prior to 125.0.6422.76 allowed a remote attacker to potentially perform arbitrary read/write via a crafted HTML page. (Chromium security severity: High)

Record
ALPINE-CVE-2024-5158
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N
Updated
2026-11-03
OSV 8.1

Type Confusion in V8 in Google Chrome prior to 125.0.6422.76 allowed a remote attacker to potentially perform arbitrary read/write via a crafted HTML page. (Chromium security severity: High)

Record
CVE-2024-5158
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N
Updated
2026-11-02
Show 6 moreShow less
OSVDEBIAN-CVE-2024-5158 8.1

Type Confusion in V8 in Google Chrome prior to 125.0.6422.76 allowed a remote attacker to potentially perform arbitrary read/write via a crafted HTML page. (Chromium security severity: High)

Record
DEBIAN-CVE-2024-5158
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N
Updated
2026-11-02
OSVMGASA-2024-0194 No score

Updated chromium-browser-stable packages fix security vulnerabilities

The chromium-browser-stable package has been updated to the 125.0.6422.76 release. It includes 6 security fixes Please, do note, that since some versions ago, only x86_64 is supported. i586 support for linux was stopped some years ago and the community is not able to provide patches anymore for the latest Chromium code.. High CVE-2024-5157: Use after free in Scheduling. High CVE-2024-5158: Type Confusion in V8. High CVE-2024-5159: Heap buffer overflow in ANGLE. High CVE-2024-5160: Heap buffer overflow in Dawn.

Record
MGASA-2024-0194
Updated
2026-11-02
OSVopenSUSE-SU-2024:0137-1 No score

Security update for chromium

This update for chromium fixes the following issues:

  • Chromium 125.0.6422.76 (boo#1224818)
    • CVE-2024-5157: Use after free in Scheduling
    • CVE-2024-5158: Type Confusion in V8
    • CVE-2024-5159: Heap buffer overflow in ANGLE
    • CVE-2024-5160: Heap buffer overflow in Dawn
    • Various fixes from internal audits, fuzzing and other initiatives
Record
openSUSE-SU-2024:0137-1
Updated
2026-11-02
OSVopenSUSE-SU-2024:13988-1 No score

chromedriver-125.0.6422.76-1.1 on GA media

These are all security issues fixed in the chromedriver-125.0.6422.76-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:13988-1
Updated
2026-11-02
OSVopenSUSE-SU-2024:14084-1 No score

nodejs-electron-29.4.3-1.1 on GA media

These are all security issues fixed in the nodejs-electron-29.4.3-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:14084-1
Updated
2026-11-02
OSVopenSUSE-SU-2024:14548-1 No score

libQt5Pdf5-5.15.18-1.1 on GA media

These are all security issues fixed in the libQt5Pdf5-5.15.18-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:14548-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
qt5-qtwebengine
Alpine:v3.20
before 5.15.16-r12
5.15.16-r12
qt5-qtwebengine
Alpine:v3.21
before 5.15.17-r3
5.15.17-r3
qt5-qtwebengine
Alpine:v3.22
before 5.15.17-r3
5.15.17-r3
qt5-qtwebengine
Alpine:v3.23
before 5.15.17-r3
5.15.17-r3
qt6-qtwebengine
Alpine:v3.21
before 6.7.2-r5
6.7.2-r5
qt6-qtwebengine
Alpine:v3.22
before 6.7.2-r5
6.7.2-r5
qt6-qtwebengine
Alpine:v3.23
before 6.7.2-r5
6.7.2-r5
qt6-qtwebengine
Alpine:v3.24
before 6.7.2-r5
6.7.2-r5
chromium
Debian:12
before 125.0.6422.76-1~deb12u1, plus listed versions
113.0.5672.126-1114.0.5735.106-1114.0.5735.106-1~deb11u1114.0.5735.106-1~deb12u1114.0.5735.133-1
Show 45 moreShow less
114.0.5735.133-1~deb11u1114.0.5735.133-1~deb12u1114.0.5735.198-1114.0.5735.198-1~deb11u1114.0.5735.198-1~deb12u1114.0.5735.90-1114.0.5735.90-2114.0.5735.90-2~deb11u1114.0.5735.90-2~deb12u1115.0.5790.102-1115.0.5790.102-2115.0.5790.170-1115.0.5790.170-1~deb11u1115.0.5790.170-1~deb12u1115.0.5790.98-1115.0.5790.98-1~deb11u1115.0.5790.98-1~deb12u1115.0.5790.98-2116.0.5845.110-1116.0.5845.110-1~deb11u1116.0.5845.110-1~deb12u1116.0.5845.110-2116.0.5845.140-1116.0.5845.140-1~deb11u1116.0.5845.140-1~deb12u1116.0.5845.180-1116.0.5845.180-1~deb11u1116.0.5845.180-1~deb12u1116.0.5845.96-1116.0.5845.96-1~deb11u1116.0.5845.96-1~deb12u1116.0.5845.96-2117.0.5938.132-1117.0.5938.132-1~deb11u1117.0.5938.132-1~deb12u1117.0.5938.132-2117.0.5938.149-1117.0.5938.149-1~deb11u1117.0.5938.149-1~deb12u1117.0.5938.62-1117.0.5938.62-1~deb11u1117.0.5938.62-1~deb12u1117.0.5938.92-1118.0.5993.117-1118.0.5993.117-1~deb11u1
125.0.6422.76-1~deb12u1
chromium
Debian:13
before 125.0.6422.76-1
125.0.6422.76-1
Show 7 moreShow less
Affected packages
PackageAffectedFixed
chromium
Debian:14
before 125.0.6422.76-1
125.0.6422.76-1
chromium-browser-stable
Mageia:9
before 125.0.6422.76-1.mga9.tainted
125.0.6422.76-1.mga9.tainted
chromium
SUSE:Package Hub 15 SP5
before 125.0.6422.76-bp155.2.85.2
125.0.6422.76-bp155.2.85.2
chromium
openSUSE:Leap 15.5
before 125.0.6422.76-bp155.2.85.2
125.0.6422.76-bp155.2.85.2
chromium
openSUSE:Tumbleweed
before 125.0.6422.76-1.1
125.0.6422.76-1.1
nodejs-electron
openSUSE:Tumbleweed
before 29.4.3-1.1
29.4.3-1.1
libqt5-qtwebengine
openSUSE:Tumbleweed
before 5.15.18-1.1
5.15.18-1.1

History

History
RecordedChangedSources
affected, aliases, referencesOSV
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2024-5158 is a high vulnerability (CVSS 8.1) in Google Chrome, published May 22, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.61%, the 49th percentile. Fixed in qt5-qtwebengine 5.15.16-r12.

References

Show 36 moreShow less
This page doesn't list everything

Left out here: 73 versions. The JSON record has them.

MoveEnter Open