CVE-2014-6440
VideoLAN VLC media player before 2.1.5 allows remote attackers to execute arbitrary code or cause...
VideoLAN VLC media player before 2.1.5 allows remote attackers to execute arbitrary code or cause a denial of service.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
VideoLAN VLC media player before 2.1.5 allows remote attackers to execute arbitrary code or cause a denial of service.
- Record
CVE-2014-6440- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-119
- Updated
- 2026-11-02
CVE List No score
VideoLAN VLC media player before 2.1.5 allows remote attackers to execute arbitrary code or cause a denial of service.
- Record
CVE-2014-6440- Updated
- 2026-11-02
EUVDEUVD-2014-6319 No score
VideoLAN VLC media player before 2.1.5 allows remote attackers to execute arbitrary code or cause a denial of service.
- Record
EUVD-2014-6319- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-hgvf-qfh8-3x8f
9.8
VideoLAN VLC media player before 2.1.5 allows remote attackers to execute arbitrary code or cause...
VideoLAN VLC media player before 2.1.5 allows remote attackers to execute arbitrary code or cause a denial of service.
- Record
GHSA-hgvf-qfh8-3x8f- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-119
- Updated
- 2026-11-02
OSV
9.8
VideoLAN VLC media player before 2.1.5 allows remote attackers to execute arbitrary code or cause a denial of service.
- Record
CVE-2014-6440- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2014-6440
9.8
VideoLAN VLC media player before 2.1.5 allows remote attackers to execute arbitrary code or cause a denial of service.
- Record
DEBIAN-CVE-2014-6440- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2014-6440
9.8
VideoLAN VLC media player before 2.1.5 allows remote attackers to execute arbitrary code or cause a denial of service.
- Record
UBUNTU-CVE-2014-6440- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVMGASA-2015-0095 No score
Updated vlc package fixes security vulnerability
Updated vlc packages (2.1.6) are an upgrade with some fixes. Some of the problems fixed upstream were already fixed by a previous Mageia update to VLC (see the link to MGASA-2015-0053).
VLC versions before 2.1.5 contain a vulnerability in the transcode module that may allow a corrupted stream to overflow buffers on the heap. With a non-malicious input, this could lead to heap corruption and a crash. However, under the right circumstances, a malicious attacker could potentially use this vulnerability to hijack program execution, and on some platforms, execute arbitrary code (CVE-2014-6440)
- Record
MGASA-2015-0095- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
vlcDebian:12 |
before 2.1.5-1 | 2.1.5-1 |
vlcDebian:13 |
before 2.1.5-1 | 2.1.5-1 |
vlcDebian:14 |
before 2.1.5-1 | 2.1.5-1 |
vlcMageia:4 |
before 2.1.6-1.0.mga4 | 2.1.6-1.0.mga4 |
vlcMageia:4 |
before 2.1.6-1.0.mga4.tainted | 2.1.6-1.0.mga4.tainted |
vlcUbuntu:14.04:LTS |
before 2.1.6-0ubuntu14.04.1, plus listed versions 2.0.8-12.1.1-12.1.2-12.1.2-22.1.2-2build12.1.2-2build22.1.4-0ubuntu14.04.1 |
2.1.6-0ubuntu14.04.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2014-6440 is a critical vulnerability (CVSS 9.8) in Videolan Vlc, published March 5, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.98%, the 92nd percentile. Fixed in vlc 2.1.5-1.
References
videolan.org/developers/vlc-branch/NEWS
securityfocus.com/bid/72950
security.gentoo.org/glsa/201603-08
seclists.org/oss-sec/2015/q1/751
billblough.net/blog/2015/03/04/cve-2014-6440-heap-overflow-in-vlc-transcode-module
nvd.nist.gov/vuln/detail/CVE-2014-6440
Show 8 moreShow less
github.com/advisories/GHSA-hgvf-qfh8-3x8f
security-tracker.debian.org/tracker/CVE-2014-6440
advisories.mageia.org/MGASA-2015-0095.html
bugs.mageia.org/show_bug.cgi?id=15384
openwall.com/lists/oss-security/2015/03/05/2
ubuntu.com/security/CVE-2014-6440
marc.info?l=oss-security&m=142553869106649&w=2
cve.org/CVERecord?id=CVE-2014-6440