Every CVE Search/ Get API key

CVE-2015-2684

Shibboleth Service Provider (SP) before 2.5.4 allows remote authenticated users to cause a denial...

4.0 MediumFix available

Shibboleth Service Provider (SP) before 2.5.4 allows remote authenticated users to cause a denial of service (crash) via a crafted SAML message.

Exploit likelihood

1.94%Up 0.9 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.0

Shibboleth Service Provider (SP) before 2.5.4 allows remote authenticated users to cause a denial of service (crash) via a crafted SAML message.

Record
CVE-2015-2684
CVSS 2.0
4.0 MediumAV:N/AC:L/Au:S/C:N/I:N/A:P
Weakness
CWE-20
Updated
2026-11-02
CVE List No score

Shibboleth Service Provider (SP) before 2.5.4 allows remote authenticated users to cause a denial of service (crash) via a crafted SAML message.

Record
CVE-2015-2684
Updated
2026-11-02
EUVDEUVD-2015-2775 No score

Shibboleth Service Provider (SP) before 2.5.4 allows remote authenticated users to cause a denial of service (crash) via a crafted SAML message.

Record
EUVD-2015-2775
Updated
2026-11-03
GitHub AdvisoriesGHSA-44gq-2834-6749 No score

Shibboleth Service Provider (SP) before 2.5.4 allows remote authenticated users to cause a denial...

Shibboleth Service Provider (SP) before 2.5.4 allows remote authenticated users to cause a denial of service (crash) via a crafted SAML message.

Record
GHSA-44gq-2834-6749
Weakness
CWE-20
Updated
2026-11-02
OSVMGASA-2015-0148 No score

Updated shibboleth-sp packages fix CVE-2015-2684

Updated shibboleth-sp package fixes security vulnerability:

A denial of service vulnerability was found in the Shibboleth Service Provider. When processing certain malformed SAML message generated by an authenticated attacker, the daemon could crash (CVE-2015-2684).

Record
MGASA-2015-0148
Updated
2026-11-02
OSVUBUNTU-CVE-2015-2684 No score

Shibboleth Service Provider (SP) before 2.5.4 allows remote authenticated users to cause a denial of service (crash) via a crafted SAML message.

Record
UBUNTU-CVE-2015-2684
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
shibboleth-sp2
Debian:6.0
before 2.3.1+dfsg-5+deb6u1, plus listed versions
2.3.1+dfsg-5
2.3.1+dfsg-5+deb6u1
shibboleth-sp2
Debian:7
before 2.4.3+dfsg-5+deb7u1, plus listed versions
2.4.3+dfsg-5
2.4.3+dfsg-5+deb7u1
shibboleth-sp
Mageia:4
before 2.5.3-1.1.mga4
2.5.3-1.1.mga4

History

History
RecordedChangedSources
affected
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2015-2684 is a medium vulnerability (CVSS 4.0) in Shibboleth Service Provider, published March 28, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.94%, the 80th percentile. Fixed in shibboleth-sp2 2.3.1+dfsg-5+deb6u1.

References

MoveEnter Open