Every CVE Search/ Get API key

CVE-2018-6196

w3m through 0.5.3 is prone to an infinite recursion flaw in HTMLlineproc0 because the...

7.5 HighFix available

w3m through 0.5.3 is prone to an infinite recursion flaw in HTMLlineproc0 because the feed_table_block_tag function in table.c does not prevent a negative indent value.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

2.94%Up 1.5 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 7.5

w3m through 0.5.3 is prone to an infinite recursion flaw in HTMLlineproc0 because the feed_table_block_tag function in table.c does not prevent a negative indent value.

Record
CVE-2018-6196
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-835
Updated
2026-11-02
CVE List No score

w3m through 0.5.3 is prone to an infinite recursion flaw in HTMLlineproc0 because the feed_table_block_tag function in table.c does not prevent a negative indent value.

Record
CVE-2018-6196
Updated
2026-11-02
EUVDEUVD-2018-17957 No score

w3m through 0.5.3 is prone to an infinite recursion flaw in HTMLlineproc0 because the feed_table_block_tag function in table.c does not prevent a negative indent value.

Record
EUVD-2018-17957
Updated
2026-11-03
GitHub AdvisoriesGHSA-rhw8-jfw3-7w97 7.5

w3m through 0.5.3 is prone to an infinite recursion flaw in HTMLlineproc0 because the...

w3m through 0.5.3 is prone to an infinite recursion flaw in HTMLlineproc0 because the feed_table_block_tag function in table.c does not prevent a negative indent value.

Record
GHSA-rhw8-jfw3-7w97
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-835
Updated
2026-11-02
OSVALPINE-CVE-2018-6196 7.5

w3m through 0.5.3 is prone to an infinite recursion flaw in HTMLlineproc0 because the feed_table_block_tag function in table.c does not prevent a negative indent value.

Record
ALPINE-CVE-2018-6196
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSV 7.5

w3m through 0.5.3 is prone to an infinite recursion flaw in HTMLlineproc0 because the feed_table_block_tag function in table.c does not prevent a negative indent value.

Record
CVE-2018-6196
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
Show 6 moreShow less
OSVDEBIAN-CVE-2018-6196 7.5

w3m through 0.5.3 is prone to an infinite recursion flaw in HTMLlineproc0 because the feed_table_block_tag function in table.c does not prevent a negative indent value.

Record
DEBIAN-CVE-2018-6196
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2018-6196 7.5

w3m through 0.5.3 is prone to an infinite recursion flaw in HTMLlineproc0 because the feed_table_block_tag function in table.c does not prevent a negative indent value.

Record
UBUNTU-CVE-2018-6196
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVMGASA-2018-0312 No score

Updated w3m packages fix security vulnerability

It was discovered that w3m incorrectly handled certain inputs. An attacker could possibly use this to cause a denial of service (CVE-2018-6196, CVE-2018-6197).

It was discovered that w3m incorrectly handled temporary files. An attacker could possibly use this to overwrite arbitrary files (CVE-2018-6198).

Record
MGASA-2018-0312
Updated
2026-11-02
OSVopenSUSE-SU-2024:11504-1 No score

w3m-0.5.3+git20180125-1.14 on GA media

These are all security issues fixed in the w3m-0.5.3+git20180125-1.14 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11504-1
Updated
2026-11-02
OSVSUSE-SU-2019:0776-1 No score

Security update for w3m

This update for w3m fixes several issues.

These security issues were fixed:

  • CVE-2018-6196: Prevent infinite recursion in HTMLlineproc0 caused by the feed_table_block_tag function which did not prevent a negative indent value (bsc#1077559)
  • CVE-2018-6197: Prevent NULL pointer dereference in formUpdateBuffer (bsc#1077568)
  • CVE-2018-6198: w3m did not properly handle temporary files when the ~/.w3m directory is unwritable, which allowed a local attacker to craft a symlink attack to overwrite arbitrary files (bsc#1077572)
Record
SUSE-SU-2019:0776-1
Updated
2026-11-02
OSVUSN-3555-1 No score

w3m vulnerabilities

It was discovered that w3m incorrectly handled certain inputs. An attacker could possibly use this to cause a denial of service. (CVE-2018-6196, CVE-2018-6197)

It was discovered that w3m incorrectly handled temporary files. An attacker could possibly use this to overwrite arbitrary files. (CVE-2018-6198)

Record
USN-3555-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
w3m
Alpine:v3.23
before 0.5.3_git20241203-r0
0.5.3_git20241203-r0
w3m
Debian:12
before 0.5.3-36
0.5.3-36
w3m
Debian:13
before 0.5.3-36
0.5.3-36
w3m
Debian:14
before 0.5.3-36
0.5.3-36
w3m
Debian:8
From an advisory covering 2 CVEs
before 0.5.3-19+deb8u3, plus listed versions
0.5.3-190.5.3-19+deb8u10.5.3-19+deb8u2
0.5.3-19+deb8u3
w3m
Mageia:5
From an advisory covering 3 CVEs
before 0.5.3-13.git20180520.0.mga5
0.5.3-13.git20180520.0.mga5
w3m
Mageia:6
From an advisory covering 3 CVEs
before 0.5.3-13.git20180520.0.mga6
0.5.3-13.git20180520.0.mga6
w3m
SUSE:Linux Enterprise Desktop 12 SP3
From an advisory covering 3 CVEs
before 0.5.3.git20161120-161.3.4
0.5.3.git20161120-161.3.4
w3m
SUSE:Linux Enterprise Desktop 12 SP4
From an advisory covering 3 CVEs
before 0.5.3.git20161120-161.3.4
0.5.3.git20161120-161.3.4
w3m
SUSE:Linux Enterprise Server 12 SP3
From an advisory covering 3 CVEs
before 0.5.3.git20161120-161.3.4
0.5.3.git20161120-161.3.4
Show 8 moreShow less
Affected packages
PackageAffectedFixed
w3m
SUSE:Linux Enterprise Server for SAP Applications 12 SP3
From an advisory covering 3 CVEs
before 0.5.3.git20161120-161.3.4
0.5.3.git20161120-161.3.4
w3m
SUSE:Linux Enterprise Server 12 SP4
From an advisory covering 3 CVEs
before 0.5.3.git20161120-161.3.4
0.5.3.git20161120-161.3.4
w3m
SUSE:Linux Enterprise Server for SAP Applications 12 SP4
From an advisory covering 3 CVEs
before 0.5.3.git20161120-161.3.4
0.5.3.git20161120-161.3.4
w3m
Ubuntu:14.04:LTS
before 0.5.3-15ubuntu0.2, plus listed versions
0.5.3-110.5.3-120.5.3-130.5.3-150.5.3-15ubuntu0.1
0.5.3-15ubuntu0.2
w3m
Ubuntu:16.04:LTS
before 0.5.3-26ubuntu0.2, plus listed versions
0.5.3-240.5.3-250.5.3-260.5.3-26build10.5.3-26ubuntu0.1
0.5.3-26ubuntu0.2
w3m
Ubuntu:14.04:LTS
From an advisory covering 3 CVEs
before 0.5.3-15ubuntu0.2, plus listed versions
0.5.3-110.5.3-120.5.3-130.5.3-150.5.3-15ubuntu0.1
0.5.3-15ubuntu0.2
w3m
Ubuntu:16.04:LTS
From an advisory covering 3 CVEs
before 0.5.3-26ubuntu0.2, plus listed versions
0.5.3-240.5.3-250.5.3-260.5.3-26build10.5.3-26ubuntu0.1
0.5.3-26ubuntu0.2
w3m
openSUSE:Tumbleweed
From an advisory covering 4 CVEs
before 0.5.3+git20180125-1.14
0.5.3+git20180125-1.14

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2018-6196 is a high vulnerability (CVSS 7.5) in Tats W3m, published January 24, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.94%, the 87th percentile. Fixed in w3m 0.5.3_git20241203-r0.

References

Show 20 moreShow less
MoveEnter Open