CVE-2008-5499
Unspecified vulnerability in Adobe Flash Player for Linux 10.0.12.36, and 9.0.151.0 and earlier,...
Unspecified vulnerability in Adobe Flash Player for Linux 10.0.12.36, and 9.0.151.0 and earlier, allows remote attackers to execute arbitrary code via a crafted SWF file.
Exploit likelihood
What each source reports
NVD Score used
9.3
Unspecified vulnerability in Adobe Flash Player for Linux 10.0.12.36, and 9.0.151.0 and earlier, allows remote attackers to execute arbitrary code via a crafted SWF file.
- Record
CVE-2008-5499- CVSS 2.0
- 9.3 High
AV:N/AC:M/Au:N/C:C/I:C/A:C - Weakness
- CWE-94
- Updated
- 2026-11-02
CVE List No score
Unspecified vulnerability in Adobe Flash Player for Linux 10.0.12.36, and 9.0.151.0 and earlier, allows remote attackers to execute arbitrary code via a crafted SWF file.
- Record
CVE-2008-5499- Updated
- 2026-11-02
EUVDEUVD-2008-5476 No score
Unspecified vulnerability in Adobe Flash Player for Linux 10.0.12.36, and 9.0.151.0 and earlier, allows remote attackers to execute arbitrary code via a crafted SWF file.
- Record
EUVD-2008-5476- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-jmfj-rgc6-43mh No score
Unspecified vulnerability in Adobe Flash Player for Linux 10.0.12.36, and 9.0.151.0 and earlier,...
Unspecified vulnerability in Adobe Flash Player for Linux 10.0.12.36, and 9.0.151.0 and earlier, allows remote attackers to execute arbitrary code via a crafted SWF file.
- Record
GHSA-jmfj-rgc6-43mh- Weakness
- CWE-94
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
flash-pluginRed Hat:rhel_extras:3 |
before 0:9.0.152.0-1.el3.with.oss | 0:9.0.152.0-1.el3.with.oss |
flash-pluginRed Hat:rhel_extras:4 |
before 0:9.0.152.0-1.el4 | 0:9.0.152.0-1.el4 |
flash-pluginRed Hat:rhel_extras:5::client |
before 0:10.0.15.3-2.el5 | 0:10.0.15.3-2.el5 |
flash-pluginRed Hat:rhel_extras:5::server |
before 0:10.0.15.3-2.el5 | 0:10.0.15.3-2.el5 |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| Exploit-DB | Adobe Flash Player - ActionScript Launch Command Execution (Metasploit) | 2012-04-20 |
| Metasploit | Adobe Flash Player ActionScript Launch Command Execution Vulnerability | 2008-12-17 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, Exploit-DB, GitHub Advisories, Metasploit, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2008-5499 is a high vulnerability (CVSS 9.3) in Adobe Flash Player For Linux, published December 18, 2008. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 79.4%, the 99th percentile. Fixed in flash-plugin 0:9.0.152.0-1.el3.with.oss.
References
securitytracker.com/id?1021458
secunia.com/advisories/33221
vupen.com/english/advisories/2008/3449
redhat.com/support/errata/RHSA-2008-1047.html
secunia.com/advisories/34226
secunia.com/advisories/33294
Show 16 moreShow less
securityfocus.com/bid/32896
osvdb.org/50796
security.gentoo.org/glsa/glsa-200903-23.xml
adobe.com/support/security/bulletins/apsb08-24.html
exchange.xforce.ibmcloud.com/vulnerabilities/47445
lists.opensuse.org/opensuse-security-announce/2008-12/msg00006.html
secunia.com/advisories/33267
nvd.nist.gov/vuln/detail/CVE-2008-5499
github.com/advisories/GHSA-jmfj-rgc6-43mh
access.redhat.com/errata/RHSA-2008:1047
redhat.com/security/updates/classification
adobe.com/products/flashplayer
bugzilla.redhat.com/show_bug.cgi?id=476172
security.access.redhat.com/data/csaf/v2/advisories/2008/rhsa-2008_1047.json
access.redhat.com/security/cve/CVE-2008-5499
cve.org/CVERecord?id=CVE-2008-5499