Every CVE Search/ Get API key

CVE-2016-1504

dhcpcd before 6.10.0 allows remote attackers to cause a denial of service (invalid read and crash...

7.5 HighFix available

dhcpcd before 6.10.0 allows remote attackers to cause a denial of service (invalid read and crash) via vectors related to the option length.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

2.90%Up 1.6 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

dhcpcd before 6.10.0 allows remote attackers to cause a denial of service (invalid read and crash) via vectors related to the option length.

Record
CVE-2016-1504
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

dhcpcd before 6.10.0 allows remote attackers to cause a denial of service (invalid read and crash) via vectors related to the option length.

Record
CVE-2016-1504
Updated
2026-11-02
EUVDEUVD-2016-2602 No score

dhcpcd before 6.10.0 allows remote attackers to cause a denial of service (invalid read and crash) via vectors related to the option length.

Record
EUVD-2016-2602
Updated
2026-11-03
GitHub AdvisoriesGHSA-f982-2cvq-99qg 7.5

dhcpcd before 6.10.0 allows remote attackers to cause a denial of service (invalid read and crash...

dhcpcd before 6.10.0 allows remote attackers to cause a denial of service (invalid read and crash) via vectors related to the option length.

Record
GHSA-f982-2cvq-99qg
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-119
Updated
2026-11-02
OSV 7.5

dhcpcd before 6.10.0 allows remote attackers to cause a denial of service (invalid read and crash) via vectors related to the option length.

Record
CVE-2016-1504
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2016-1504 7.5

dhcpcd before 6.10.0 allows remote attackers to cause a denial of service (invalid read and crash) via vectors related to the option length.

Record
DEBIAN-CVE-2016-1504
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2016-1504 7.5

dhcpcd before 6.10.0 allows remote attackers to cause a denial of service (invalid read and crash) via vectors related to the option length.

Record
UBUNTU-CVE-2016-1504
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVMGASA-2016-0034 No score

Updated dhcpcd packages fix security vulnerability

Possible heap overflow in dhcpcd before 6.10.0 caused by malformed dhcp responses due to incorrect option length values (CVE-2016-1503).

Possible invalid read in dhcpcd before 6.10.0 caused by malformed dhcp responses can lead to a crash (CVE-2016-1504).

The dhcpcd package has been updated to version 6.10.0 which fixes these issues and has several other bug fixes and enhancements.

Record
MGASA-2016-0034
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
dhcpcd5
Debian:12
before 6.10.1-1
6.10.1-1
dhcpcd
Mageia:5
From an advisory covering 2 CVEs
before 6.10.0-1.mga5
6.10.0-1.mga5
dhcpcd5
Ubuntu:Pro:14.04:LTS
All versions, plus listed versions
5.5.6-16.0.5-1ubuntu16.0.5-1.16.0.5-2build0.14.04.16.0.5-2+deb8u1build0.14.04.1~esm1
None known

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2016-1504 is a high vulnerability (CVSS 7.5) in Dhcpcd Project Dhcpcd, published January 21, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.90%, the 87th percentile. Fixed in dhcpcd5 6.10.1-1.

References

Show 16 moreShow less
MoveEnter Open