Every CVE Search/ Get API key

CVE-2018-5345

A stack-based buffer overflow within GNOME gcab through 0.7.4 can be exploited by malicious...

7.8 HighFix available

A stack-based buffer overflow within GNOME gcab through 0.7.4 can be exploited by malicious attackers to cause a crash or, potentially, execute arbitrary code via a crafted .cab file.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

2.19%Up 0.4 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 7.8

A stack-based buffer overflow within GNOME gcab through 0.7.4 can be exploited by malicious attackers to cause a crash or, potentially, execute arbitrary code via a crafted .cab file.

Record
CVE-2018-5345
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-787
Updated
2026-11-02
CVE List No score

A stack-based buffer overflow within GNOME gcab through 0.7.4 can be exploited by malicious attackers to cause a crash or, potentially, execute arbitrary code via a crafted .cab file.

Record
CVE-2018-5345
Updated
2026-11-02
EUVDEUVD-2018-17124 No score

A stack-based buffer overflow within GNOME gcab through 0.7.4 can be exploited by malicious attackers to cause a crash or, potentially, execute arbitrary code via a crafted .cab file.

Record
EUVD-2018-17124
Updated
2026-11-03
GitHub AdvisoriesGHSA-28gw-xjhw-6cm5 7.8

A stack-based buffer overflow within GNOME gcab through 0.7.4 can be exploited by malicious...

A stack-based buffer overflow within GNOME gcab through 0.7.4 can be exploited by malicious attackers to cause a crash or, potentially, execute arbitrary code via a crafted .cab file.

Record
GHSA-28gw-xjhw-6cm5
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-787
Updated
2026-11-02
OSV 7.8

A stack-based buffer overflow within GNOME gcab through 0.7.4 can be exploited by malicious attackers to cause a crash or, potentially, execute arbitrary code via a crafted .cab file.

Record
CVE-2018-5345
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2018-5345 7.8

A stack-based buffer overflow within GNOME gcab through 0.7.4 can be exploited by malicious attackers to cause a crash or, potentially, execute arbitrary code via a crafted .cab file.

Record
DEBIAN-CVE-2018-5345
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
Show 5 moreShow less
OSVRHSA-2018:0350 5.3

Red Hat Security Advisory: gcab security update

Record
RHSA-2018:0350
CVSS 3.0
5.3 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L
Updated
2026-11-02
OSVUBUNTU-CVE-2018-5345 7.8

A stack-based buffer overflow within GNOME gcab through 0.7.4 can be exploited by malicious attackers to cause a crash or, potentially, execute arbitrary code via a crafted .cab file.

Record
UBUNTU-CVE-2018-5345
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2018-0111 No score

Updated gcab packages fix security vulnerability

It was discovered that gcab is prone to a stack-based buffer overflow vulnerability when extracting .cab files. An attacker can take advantage of this flaw to cause a denial-of-service or, potentially the execution of arbitrary code with the privileges of the user running gcab, if a specially crafted .cab file is processed (CVE-2018-5345).

Record
MGASA-2018-0111
Updated
2026-11-02
OSVopenSUSE-SU-2024:10776-1 No score

gcab-1.4-2.9 on GA media

These are all security issues fixed in the gcab-1.4-2.9 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10776-1
Updated
2026-11-02
OSVUSN-3546-1 No score

gcab vulnerability

Richard Hughes discovered that gcab incorrectly handled certain malformed cabinet files. If a user or automated system were tricked into opening a specially crafted cabinet file, a remote attacker could use this issue to cause gcab to crash, resulting in a denial of service, or possibly execute arbitrary code.

Record
USN-3546-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
gcab
Debian:12
before 0.7-7
0.7-7
gcab
Debian:13
before 0.7-7
0.7-7
gcab
Debian:14
before 0.7-7
0.7-7
gcab
Debian:9
before 0.7-2+deb9u1, plus listed versions
0.7-2
0.7-2+deb9u1
gcab
Mageia:5
before 0.4-6.1.mga5
0.4-6.1.mga5
gcab
Mageia:6
before 0.7-1.1.mga6
0.7-1.1.mga6
gcab
Red Hat:enterprise_linux:7::client
before 0:0.7-4.el7_4
0:0.7-4.el7_4
gcab-debuginfo
Red Hat:enterprise_linux:7::client
before 0:0.7-4.el7_4
0:0.7-4.el7_4
libgcab1
Red Hat:enterprise_linux:7::client
before 0:0.7-4.el7_4
0:0.7-4.el7_4
libgcab1-devel
Red Hat:enterprise_linux:7::client
before 0:0.7-4.el7_4
0:0.7-4.el7_4
Show 14 moreShow less
Affected packages
PackageAffectedFixed
gcab
Red Hat:enterprise_linux:7::computenode
before 0:0.7-4.el7_4
0:0.7-4.el7_4
gcab-debuginfo
Red Hat:enterprise_linux:7::computenode
before 0:0.7-4.el7_4
0:0.7-4.el7_4
libgcab1
Red Hat:enterprise_linux:7::computenode
before 0:0.7-4.el7_4
0:0.7-4.el7_4
libgcab1-devel
Red Hat:enterprise_linux:7::computenode
before 0:0.7-4.el7_4
0:0.7-4.el7_4
gcab
Red Hat:enterprise_linux:7::server
before 0:0.7-4.el7_4
0:0.7-4.el7_4
gcab-debuginfo
Red Hat:enterprise_linux:7::server
before 0:0.7-4.el7_4
0:0.7-4.el7_4
libgcab1
Red Hat:enterprise_linux:7::server
before 0:0.7-4.el7_4
0:0.7-4.el7_4
libgcab1-devel
Red Hat:enterprise_linux:7::server
before 0:0.7-4.el7_4
0:0.7-4.el7_4
gcab
Red Hat:enterprise_linux:7::workstation
before 0:0.7-4.el7_4
0:0.7-4.el7_4
gcab-debuginfo
Red Hat:enterprise_linux:7::workstation
before 0:0.7-4.el7_4
0:0.7-4.el7_4
libgcab1
Red Hat:enterprise_linux:7::workstation
before 0:0.7-4.el7_4
0:0.7-4.el7_4
libgcab1-devel
Red Hat:enterprise_linux:7::workstation
before 0:0.7-4.el7_4
0:0.7-4.el7_4
gcab
Ubuntu:16.04:LTS
before 0.7-1ubuntu0.1, plus listed versions
0.6-10.6-1ubuntu10.7-1
0.7-1ubuntu0.1
gcab
openSUSE:Tumbleweed
before 1.4-2.9
1.4-2.9

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2018-5345 is a high vulnerability (CVSS 7.8) in Gnome Gcab, published January 11, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.19%, the 82nd percentile. Fixed in gcab 0.7-7.

References

Show 11 moreShow less
MoveEnter Open