CVE-2014-6273
Buffer overflow in the HTTP transport code in apt-get in APT 1.0.1 and earlier allows man-in-the...
Buffer overflow in the HTTP transport code in apt-get in APT 1.0.1 and earlier allows man-in-the-middle attackers to cause a denial of service (crash) or possibly execute arbitrary code via a crafted URL.
Exploit likelihood
What each source reports
NVD Score used
6.8
Buffer overflow in the HTTP transport code in apt-get in APT 1.0.1 and earlier allows man-in-the-middle attackers to cause a denial of service (crash) or possibly execute arbitrary code via a crafted URL.
- Record
CVE-2014-6273- CVSS 2.0
- 6.8 Medium
AV:N/AC:M/Au:N/C:P/I:P/A:P - Weakness
- CWE-119
- Updated
- 2026-11-02
CVE List No score
Buffer overflow in the HTTP transport code in apt-get in APT 1.0.1 and earlier allows man-in-the-middle attackers to cause a denial of service (crash) or possibly execute arbitrary code via a crafted URL.
- Record
CVE-2014-6273- Updated
- 2026-11-02
EUVDEUVD-2014-6159 No score
Buffer overflow in the HTTP transport code in apt-get in APT 1.0.1 and earlier allows man-in-the-middle attackers to cause a denial of service (crash) or possibly execute arbitrary code via a crafted URL.
- Record
EUVD-2014-6159- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-qxxp-8f4q-wv5v No score
Buffer overflow in the HTTP transport code in apt-get in APT 1.0.1 and earlier allows man-in-the...
Buffer overflow in the HTTP transport code in apt-get in APT 1.0.1 and earlier allows man-in-the-middle attackers to cause a denial of service (crash) or possibly execute arbitrary code via a crafted URL.
- Record
GHSA-qxxp-8f4q-wv5v- Weakness
- CWE-119
- Updated
- 2026-11-02
OSV No score
Buffer overflow in the HTTP transport code in apt-get in APT 1.0.1 and earlier allows man-in-the-middle attackers to cause a denial of service (crash) or possibly execute arbitrary code via a crafted URL.
- Record
CVE-2014-6273- Updated
- 2026-11-02
OSVDEBIAN-CVE-2014-6273 No score
Buffer overflow in the HTTP transport code in apt-get in APT 1.0.1 and earlier allows man-in-the-middle attackers to cause a denial of service (crash) or possibly execute arbitrary code via a crafted URL.
- Record
DEBIAN-CVE-2014-6273- Updated
- 2026-11-02
OSVMGASA-2014-0442 No score
Updated apt packages fix security vulnerability
The Google Security Team discovered a buffer overflow vulnerability in the HTTP transport code in apt-get. An attacker able to man-in-the-middle a HTTP request to an apt repository can trigger the buffer overflow, leading to a crash of the "http" apt method binary, or potentially to arbitrary code execution (CVE-2014-6273).
Also fixed is parsing of Mageia package index "synthesis" files with lines longer than 64k characters. This is necessary for upgrading to the "cauldron" development distro that will become Mageia 5. Note however that upgrading from Mageia 3 to Mageia 5 will not be supported.
- Record
MGASA-2014-0442- Updated
- 2026-11-02
OSVUBUNTU-CVE-2014-6273 No score
Buffer overflow in the HTTP transport code in apt-get in APT 1.0.1 and earlier allows man-in-the-middle attackers to cause a denial of service (crash) or possibly execute arbitrary code via a crafted URL.
- Record
UBUNTU-CVE-2014-6273- Updated
- 2026-11-02
OSVUSN-2353-1 No score
apt vulnerability
It was discovered that APT incorrectly handled certain http URLs. If a remote attacker were able to perform a machine-in-the-middle attack, this flaw could be exploited to cause APT to crash, resulting in a denial of service, or possibly execute arbitrary code. The default compiler options for affected releases should reduce the vulnerability to a denial of service. (CVE-2014-6273)
In addition, this update fixes regressions introduced by the USN-2348-1 security update: APT incorrectly handled file:/// sources on a different partition, incorrectly handled Dir::state::lists set to a relative path, and incorrectly handled cdrom: sources.
- Record
USN-2353-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
aptDebian:12 |
before 1.0.3 | 1.0.3 |
aptDebian:13 |
before 1.0.3 | 1.0.3 |
aptDebian:14 |
before 1.0.3 | 1.0.3 |
aptDebian:6.0 |
before 0.8.10.3+squeeze5, plus listed versions 0.8.10.30.8.10.3+squeeze10.8.10.3+squeeze20.8.10.3+squeeze3 |
0.8.10.3+squeeze5 |
aptDebian:7 |
before 0.9.7.9+deb7u5, plus listed versions 0.9.7.80.9.7.90.9.7.9+deb7u10.9.7.9+deb7u20.9.7.9+deb7u3 Show 4 moreShow less0.9.7.9+deb7u40.9.7.9~exp10.9.7.9~exp20.9.7.9~exp3 |
0.9.7.9+deb7u5 |
aptMageia:3 |
before 0.5.15lorg3.94-9.2.mga3 | 0.5.15lorg3.94-9.2.mga3 |
aptMageia:4 |
before 0.5.15lorg3.94-11.2.mga4 | 0.5.15lorg3.94-11.2.mga4 |
aptUbuntu:14.04:LTS |
before 1.0.1ubuntu2.4.1, plus listed versions 0.9.9.1~ubuntu30.9.9.1~ubuntu40.9.9.1~ubuntu50.9.13~exp1ubuntu10.9.13~exp1ubuntu2 Show 13 moreShow less0.9.13~exp1ubuntu30.9.13.1~ubuntu10.9.14.1ubuntu10.9.14.1ubuntu20.9.15.1ubuntu10.9.15.4ubuntu10.9.15.4ubuntu20.9.15.4ubuntu30.9.15.4ubuntu40.9.15.4ubuntu51.0.1ubuntu21.0.1ubuntu2.11.0.1ubuntu2.3 |
1.0.1ubuntu2.4.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2014-6273 is a medium vulnerability (CVSS 6.8) in Debian Advanced Package Tool, published September 23, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.44%, the 84th percentile. Fixed in apt 1.0.3.
References
ubuntu.com/usn/USN-2353-1
securityfocus.com/bid/70075
secunia.com/advisories/61710
exchange.xforce.ibmcloud.com/vulnerabilities/96151
debian.org/security/2014/dsa-3031
secunia.com/advisories/61605
Show 9 moreShow less
nvd.nist.gov/vuln/detail/CVE-2014-6273
github.com/advisories/GHSA-qxxp-8f4q-wv5v
security-tracker.debian.org/tracker/CVE-2014-6273
advisories.mageia.org/MGASA-2014-0442.html
bugs.mageia.org/show_bug.cgi?id=14112
ubuntu.com/usn/usn-2353-1
ubuntu.com/security/CVE-2014-6273
ubuntu.com/security/notices/USN-2353-1
cve.org/CVERecord?id=CVE-2014-6273