Every CVE Search/ Get API key

CVE-2017-13194

A vulnerability in the Android media framework (libvpx) related to odd frame width. Product:...

7.5 HighFix available

A vulnerability in the Android media framework (libvpx) related to odd frame width. Product: Android. Versions: 7.0, 7.1.1, 7.1.2, 8.0, 8.1. Android ID: A-64710201.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

1.80%Up 1.2 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 7.5

A vulnerability in the Android media framework (libvpx) related to odd frame width. Product: Android. Versions: 7.0, 7.1.1, 7.1.2, 8.0, 8.1. Android ID: A-64710201.

Record
CVE-2017-13194
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0
7.8 HighAV:N/AC:L/Au:N/C:N/I:N/A:C
Weakness
CWE-20
Updated
2026-11-02
CVE List No score

A vulnerability in the Android media framework (libvpx) related to odd frame width. Product: Android. Versions: 7.0, 7.1.1, 7.1.2, 8.0, 8.1. Android ID: A-64710201.

Record
CVE-2017-13194
Updated
2026-11-02
EUVDEUVD-2017-4711 No score

A vulnerability in the Android media framework (libvpx) related to odd frame width. Product: Android. Versions: 7.0, 7.1.1, 7.1.2, 8.0, 8.1. Android ID: A-64710201.

Record
EUVD-2017-4711
Updated
2026-11-03
GitHub AdvisoriesGHSA-9g26-5wqj-4px2 7.5

A vulnerability in the Android media framework (libvpx) related to odd frame width. Product:...

A vulnerability in the Android media framework (libvpx) related to odd frame width. Product: Android. Versions: 7.0, 7.1.1, 7.1.2, 8.0, 8.1. Android ID: A-64710201.

Record
GHSA-9g26-5wqj-4px2
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-20
Updated
2026-11-02
OSV 7.5

A vulnerability in the Android media framework (libvpx) related to odd frame width. Product: Android. Versions: 7.0, 7.1.1, 7.1.2, 8.0, 8.1. Android ID: A-64710201.

Record
CVE-2017-13194
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2017-13194 7.5

A vulnerability in the Android media framework (libvpx) related to odd frame width. Product: Android. Versions: 7.0, 7.1.1, 7.1.2, 8.0, 8.1. Android ID: A-64710201.

Record
DEBIAN-CVE-2017-13194
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
Show 6 moreShow less
OSVUBUNTU-CVE-2017-13194 7.5

A vulnerability in the Android media framework (libvpx) related to odd frame width. Product: Android. Versions: 7.0, 7.1.1, 7.1.2, 8.0, 8.1. Android ID: A-64710201.

Record
UBUNTU-CVE-2017-13194
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVMGASA-2018-0112 No score

Updated libvpx packages fix security vulnerability

A flaw was found in libvpx related to odd frame width, which may lead to a denial of service (CVE-2017-13194).

Record
MGASA-2018-0112
Updated
2026-11-02
OSVopenSUSE-SU-2024:11010-1 No score

libvpx-devel-1.10.0-1.3 on GA media

These are all security issues fixed in the libvpx-devel-1.10.0-1.3 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11010-1
Updated
2026-11-02
OSVSUSE-SU-2018:0181-1 No score

Security update for libvpx

This update for libvpx fixes one issues.

This security issue was fixed:

  • CVE-2017-13194: Fixed incorrect memory allocation related to odd frame width (bsc#1075992).
Record
SUSE-SU-2018:0181-1
Updated
2026-11-02
OSVUSN-4199-1 No score

libvpx vulnerabilities

It was discovered that libvpx did not properly handle certain malformed WebM media files. If an application using libvpx opened a specially crafted WebM file, a remote attacker could cause a denial of service, or possibly execute arbitrary code.

Record
USN-4199-1
Updated
2026-11-02
OSVUSN-4199-2 No score

libvpx vulnerabilities

USN-4199-1 fixed several vulnerabilities in libvpx. This update provides the corresponding update for Ubuntu 14.04 ESM.

Original advisory details:

It was discovered that libvpx did not properly handle certain malformed WebM media files. If an application using libvpx opened a specially crafted WebM file, a remote attacker could cause a denial of service, or possibly execute arbitrary code.

Record
USN-4199-2
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libvpx
Debian:12
before 1.7.0-2
1.7.0-2
libvpx
Debian:13
before 1.7.0-2
1.7.0-2
libvpx
Debian:14
before 1.7.0-2
1.7.0-2
libvpx
Debian:7
before 1.1.0-1+deb7u1, plus listed versions
1.1.0-1
1.1.0-1+deb7u1
libvpx
Debian:8
before 1.3.0-3+deb8u1, plus listed versions
1.3.0-3
1.3.0-3+deb8u1
libvpx
Debian:9
before 1.6.1-3+deb9u1, plus listed versions
1.6.1-3
1.6.1-3+deb9u1
libvpx
Mageia:5
before 1.3.0-3.2.mga5
1.3.0-3.2.mga5
libvpx
Mageia:6
before 1.5.0-3.1.mga6
1.5.0-3.1.mga6
libvpx
SUSE:Linux Enterprise Desktop 12 SP2
before 1.3.0-3.3.1
1.3.0-3.3.1
libvpx
SUSE:Linux Enterprise Desktop 12 SP3
before 1.3.0-3.3.1
1.3.0-3.3.1
Show 15 moreShow less
Affected packages
PackageAffectedFixed
libvpx
SUSE:Linux Enterprise Server for Raspberry Pi 12 SP2
before 1.3.0-3.3.1
1.3.0-3.3.1
libvpx
SUSE:Linux Enterprise Software Development Kit 12 SP2
before 1.3.0-3.3.1
1.3.0-3.3.1
libvpx
SUSE:Linux Enterprise Software Development Kit 12 SP3
before 1.3.0-3.3.1
1.3.0-3.3.1
libvpx
SUSE:Linux Enterprise Server 12 SP2
before 1.3.0-3.3.1
1.3.0-3.3.1
libvpx
SUSE:Linux Enterprise Server for SAP Applications 12 SP2
before 1.3.0-3.3.1
1.3.0-3.3.1
libvpx
SUSE:Linux Enterprise Server 12 SP3
before 1.3.0-3.3.1
1.3.0-3.3.1
libvpx
SUSE:Linux Enterprise Server for SAP Applications 12 SP3
before 1.3.0-3.3.1
1.3.0-3.3.1
libvpx
SUSE:Linux Enterprise Workstation Extension 12 SP2
before 1.3.0-3.3.1
1.3.0-3.3.1
libvpx
SUSE:Linux Enterprise Workstation Extension 12 SP3
before 1.3.0-3.3.1
1.3.0-3.3.1
libvpx
Ubuntu:Pro:14.04:LTS
before 1.3.0-2ubuntu0.1~esm1, plus listed versions
1.2.0-21.3.0-11.3.0-2
1.3.0-2ubuntu0.1~esm1
libvpx
Ubuntu:16.04:LTS
before 1.5.0-2ubuntu1.1, plus listed versions
1.4.0-41.5.0-21.5.0-2ubuntu1
1.5.0-2ubuntu1.1
libvpx
Ubuntu:16.04:LTS
From an advisory covering 6 CVEs
before 1.5.0-2ubuntu1.1, plus listed versions
1.4.0-41.5.0-21.5.0-2ubuntu1
1.5.0-2ubuntu1.1
libvpx
Ubuntu:18.04:LTS
From an advisory covering 6 CVEs
before 1.7.0-3ubuntu0.18.04.1, plus listed versions
1.6.1-31.7.0-3
1.7.0-3ubuntu0.18.04.1
libvpx
Ubuntu:Pro:14.04:LTS
From an advisory covering 3 CVEs
before 1.3.0-2ubuntu0.1~esm1, plus listed versions
1.2.0-21.3.0-11.3.0-2
1.3.0-2ubuntu0.1~esm1
libvpx
openSUSE:Tumbleweed
From an advisory covering 7 CVEs
before 1.10.0-1.3
1.10.0-1.3

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-13194 is a high vulnerability (CVSS 7.5) in Google Android, published January 12, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.80%, the 78th percentile. Fixed in libvpx 1.7.0-2.

References

Show 24 moreShow less
MoveEnter Open