Every CVE Search/ Get API key

CVE-2015-2559

Drupal 6.x before 6.35 and 7.x before 7.35 allows remote authenticated users to reset the...

3.5 LowFix available

Drupal 6.x before 6.35 and 7.x before 7.35 allows remote authenticated users to reset the password of other accounts by leveraging an account with the same password hash as another account and a crafted password reset URL.

Exploit likelihood

1.64%Up 0.6 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 3.5

Drupal 6.x before 6.35 and 7.x before 7.35 allows remote authenticated users to reset the password of other accounts by leveraging an account with the same password hash as another account and a crafted password reset URL.

Record
CVE-2015-2559
CVSS 2.0
3.5 LowAV:N/AC:M/Au:S/C:N/I:P/A:N
Weakness
CWE-284
Updated
2026-11-02
CVE List No score

Drupal 6.x before 6.35 and 7.x before 7.35 allows remote authenticated users to reset the password of other accounts by leveraging an account with the same password hash as another account and a crafted password reset URL.

Record
CVE-2015-2559
Updated
2026-11-02
EUVDEUVD-2015-2652 No score

Drupal 6.x before 6.35 and 7.x before 7.35 allows remote authenticated users to reset the password of other accounts by leveraging an account with the same password hash as another account and a crafted password reset URL.

Record
EUVD-2015-2652
Updated
2026-11-03
GitHub AdvisoriesGHSA-hqq6-wqq7-jgjq No score

Drupal 6.x before 6.35 and 7.x before 7.35 allows remote authenticated users to reset the...

Drupal 6.x before 6.35 and 7.x before 7.35 allows remote authenticated users to reset the password of other accounts by leveraging an account with the same password hash as another account and a crafted password reset URL.

Record
GHSA-hqq6-wqq7-jgjq
Weakness
CWE-284
Updated
2026-11-02
OSVMGASA-2015-0121 No score

Updated drupal packages fix security vulnerabilities

Password reset URLs can be forged under certain circumstances, allowing an attacker to gain access to another user's account without knowing the account's password (CVE-2015-2559).

Under certain circumstances, malicious users can construct a URL that will trick users into being redirected to a 3rd party website, thereby exposing the users to potential social engineering attacks. In addition, several URL-related API functions in Drupal 6 and 7 can be tricked into passing through external URLs when not intending to, potentially leading to additional open redirect vulnerabilities (CVE-2015-2749, CVE-2015-2750).

Record
MGASA-2015-0121
Updated
2026-11-02
OSVUBUNTU-CVE-2015-2559 No score

Drupal 6.x before 6.35 and 7.x before 7.35 allows remote authenticated users to reset the password of other accounts by leveraging an account with the same password hash as another account and a crafted password reset URL.

Record
UBUNTU-CVE-2015-2559
Updated
2026-11-02
OSVUSN-4773-1 No score

drupal7 vulnerabilities

It was discovered that Drupal did not properly process certain input. An attacker could use this vulnerability to execute arbitrary code or completely compromise a Drupal site. (CVE-2018-7600, CVE-2018-7602)

It was discovered that password reset URLs in Drupal could be forged. An attacker could use this vulnerability to gain access to another user's account. This issue affected only Ubuntu 14.04 ESM. (CVE-2015-2559)

It was discovered that Drupal did not properly protect against open redirects. An attacker could use this vulnerability to send unsuspecting users to 3rd party sites and potentially carry out phishing attacks. This issue affected only Ubuntu 14.04 ESM. (CVE-2015-2749, CVE-2015-2750)

Record
USN-4773-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
drupal7
Debian:7
before 7.14-2+deb7u9, plus listed versions
7.14-27.14-2+deb7u17.14-2+deb7u1~bpo60+17.14-2+deb7u27.14-2+deb7u2~bpo60+1
Show 10 moreShow less
7.14-2+deb7u37.14-2+deb7u47.14-2+deb7u4~bpo60+17.14-2+deb7u57.14-2+deb7u67.14-2+deb7u6~bpo60+17.14-2+deb7u77.14-2+deb7u7~bpo60+17.14-2+deb7u87.14-2+deb7u9~bpo60+1
7.14-2+deb7u9
drupal
Mageia:4
before 7.35-1.mga4
7.35-1.mga4
drupal7
Ubuntu:Pro:14.04:LTS
before 7.26-1ubuntu0.1+esm1, plus listed versions
7.23-17.24-17.24-27.26-17.26-1ubuntu0.1
7.26-1ubuntu0.1+esm1
drupal7
Ubuntu:Pro:16.04:LTS
before 7.44-1ubuntu1~16.04.0+esm1, plus listed versions
7.38-17.41-17.44-1ubuntu1~16.04.0
7.44-1ubuntu1~16.04.0+esm1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2015-2559 is a low vulnerability (CVSS 3.5) in Drupal, published March 20, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.64%, the 76th percentile. Fixed in drupal7 7.14-2+deb7u9.

References

Show 13 moreShow less
MoveEnter Open