bind-export-devel vulnerabilities (AlmaLinux)
29 vulnerabilities.
-
bind-export-develAlmaLinux Concurrent GSS-TSIG messages corrupt memory 8.1 High -
bind-export-develAlmaLinux Amplified resource exhaustion in inbound message processing 7.5 High -
bind-export-develAlmaLinux Validating resolver can abort while caching a mismatched NOQNAME proof 7.5 High -
bind-export-develAlmaLinux Use-after-free in query_addnoqnameproof() via the DNS64 filter64 path 7.5 High -
bind-export-develAlmaLinux qpcache NOQNAME proof use-after-free crashes recursive resolver 5.9 Medium -
bind-export-develAlmaLinux Remote assertion failure via 16-bit length truncation in `dns_ncache_add()` 7.5 High -
bind-export-develAlmaLinux DNSSEC Validation Bypass via Out-of-Zone NSEC Next Field 8.6 High -
bind-export-develAlmaLinux Unexpected exit in certain situations with NSEC and NSEC3 both present 7.5 High -
bind-export-develAlmaLinux Cache poisoning possible with label count discrepancy, RRSIG, and wildcards 7.5 High -
bind-export-develAlmaLinux Potential memory usage beyond configured limits 7.5 High -
bind-export-develAlmaLinux Incorrect acceptance of NSEC3 records 6.8 Medium -
bind-export-develAlmaLinux Invalid handling of CLASS != IN 7.5 High -
bind-export-develAlmaLinux BIND 9 server memory exhaustion during GSS-API TKEY negotiation 7.5 High -
bind-export-develAlmaLinux Excessive NSEC3 iterations cause high CPU load during insecure delegation validation 7.5 High -
bind-export-develAlmaLinux Cache poisoning attacks with unsolicited RRs 8.6 High -
bind-export-develAlmaLinux Many records in the additional section cause CPU exhaustion 7.5 High -
bind-export-develAlmaLinux SIG(0) can be used to exhaust CPU resources 7.5 High -
bind-export-develAlmaLinux BIND's database will be slow if a very large number of RRs exist at the same name 7.5 High -
bind-export-develAlmaLinux The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is... 7.5 High -
bind-export-develAlmaLinux Certain DNSSEC aspects of the DNS protocol (in RFC 4035 and related RFCs) allow remote attackers... 7.5 High -
bind-export-develAlmaLinux Parsing large DNS messages may cause excessive CPU load 7.5 High -
bind-export-develAlmaLinux A stack exhaustion flaw in control channel code may cause named to terminate unexpectedly 7.5 High -
bind-export-develAlmaLinux named's configured cache size limit can be significantly exceeded 7.5 High -
bind-export-develAlmaLinux An UPDATE message flood may cause named to exhaust all available memory 7.5 High -
bind-export-develAlmaLinux Memory leaks in EdDSA DNSSEC verification code 7.5 High -
bind-export-develAlmaLinux Memory leak in ECDSA DNSSEC verification code 7.5 High -
bind-export-develAlmaLinux Processing large delegations may severely degrade resolver performance 5.3 Medium -
bind-export-develAlmaLinux DNS forwarders - cache poisoning vulnerability 6.8 Medium -
bind-export-develAlmaLinux Lame cache can be abused to severely degrade resolver performance 5.3 Medium