bind-libs-lite vulnerabilities (AlmaLinux)
30 vulnerabilities.
-
bind-libs-liteAlmaLinux Concurrent GSS-TSIG messages corrupt memory 8.1 High -
bind-libs-liteAlmaLinux Amplified resource exhaustion in inbound message processing 7.5 High -
bind-libs-liteAlmaLinux Validating resolver can abort while caching a mismatched NOQNAME proof 7.5 High -
bind-libs-liteAlmaLinux Use-after-free in query_addnoqnameproof() via the DNS64 filter64 path 7.5 High -
bind-libs-liteAlmaLinux qpcache NOQNAME proof use-after-free crashes recursive resolver 5.9 Medium -
bind-libs-liteAlmaLinux Remote assertion failure via 16-bit length truncation in `dns_ncache_add()` 7.5 High -
bind-libs-liteAlmaLinux DNSSEC Validation Bypass via Out-of-Zone NSEC Next Field 8.6 High -
bind-libs-liteAlmaLinux Unexpected exit in certain situations with NSEC and NSEC3 both present 7.5 High -
bind-libs-liteAlmaLinux Cache poisoning possible with label count discrepancy, RRSIG, and wildcards 7.5 High -
bind-libs-liteAlmaLinux Potential memory usage beyond configured limits 7.5 High -
bind-libs-liteAlmaLinux Incorrect acceptance of NSEC3 records 6.8 Medium -
bind-libs-liteAlmaLinux Invalid handling of CLASS != IN 7.5 High -
bind-libs-liteAlmaLinux BIND 9 server memory exhaustion during GSS-API TKEY negotiation 7.5 High -
bind-libs-liteAlmaLinux Excessive NSEC3 iterations cause high CPU load during insecure delegation validation 7.5 High -
bind-libs-liteAlmaLinux Cache poisoning attacks with unsolicited RRs 8.6 High -
bind-libs-liteAlmaLinux Many records in the additional section cause CPU exhaustion 7.5 High -
bind-libs-liteAlmaLinux SIG(0) can be used to exhaust CPU resources 7.5 High -
bind-libs-liteAlmaLinux BIND's database will be slow if a very large number of RRs exist at the same name 7.5 High -
bind-libs-liteAlmaLinux The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is... 7.5 High -
bind-libs-liteAlmaLinux Certain DNSSEC aspects of the DNS protocol (in RFC 4035 and related RFCs) allow remote attackers... 7.5 High -
bind-libs-liteAlmaLinux Parsing large DNS messages may cause excessive CPU load 7.5 High -
bind-libs-liteAlmaLinux A stack exhaustion flaw in control channel code may cause named to terminate unexpectedly 7.5 High -
bind-libs-liteAlmaLinux named's configured cache size limit can be significantly exceeded 7.5 High -
bind-libs-liteAlmaLinux An UPDATE message flood may cause named to exhaust all available memory 7.5 High -
bind-libs-liteAlmaLinux Memory leaks in EdDSA DNSSEC verification code 7.5 High -
bind-libs-liteAlmaLinux Memory leak in ECDSA DNSSEC verification code 7.5 High -
bind-libs-liteAlmaLinux Processing large delegations may severely degrade resolver performance 5.3 Medium -
bind-libs-liteAlmaLinux DNS forwarders - cache poisoning vulnerability 6.8 Medium -
bind-libs-liteAlmaLinux Lame cache can be abused to severely degrade resolver performance 5.3 Medium -
bind-libs-liteAlmaLinux A broken inbound incremental zone update (IXFR) can cause named to terminate unexpectedly 6.5 Medium