bind-pkcs11-libs vulnerabilities (AlmaLinux)
30 vulnerabilities.
-
bind-pkcs11-libsAlmaLinux Concurrent GSS-TSIG messages corrupt memory 8.1 High -
bind-pkcs11-libsAlmaLinux Amplified resource exhaustion in inbound message processing 7.5 High -
bind-pkcs11-libsAlmaLinux Validating resolver can abort while caching a mismatched NOQNAME proof 7.5 High -
bind-pkcs11-libsAlmaLinux Use-after-free in query_addnoqnameproof() via the DNS64 filter64 path 7.5 High -
bind-pkcs11-libsAlmaLinux qpcache NOQNAME proof use-after-free crashes recursive resolver 5.9 Medium -
bind-pkcs11-libsAlmaLinux Remote assertion failure via 16-bit length truncation in `dns_ncache_add()` 7.5 High -
bind-pkcs11-libsAlmaLinux DNSSEC Validation Bypass via Out-of-Zone NSEC Next Field 8.6 High -
bind-pkcs11-libsAlmaLinux Unexpected exit in certain situations with NSEC and NSEC3 both present 7.5 High -
bind-pkcs11-libsAlmaLinux Cache poisoning possible with label count discrepancy, RRSIG, and wildcards 7.5 High -
bind-pkcs11-libsAlmaLinux Potential memory usage beyond configured limits 7.5 High -
bind-pkcs11-libsAlmaLinux Incorrect acceptance of NSEC3 records 6.8 Medium -
bind-pkcs11-libsAlmaLinux Invalid handling of CLASS != IN 7.5 High -
bind-pkcs11-libsAlmaLinux BIND 9 server memory exhaustion during GSS-API TKEY negotiation 7.5 High -
bind-pkcs11-libsAlmaLinux Excessive NSEC3 iterations cause high CPU load during insecure delegation validation 7.5 High -
bind-pkcs11-libsAlmaLinux Cache poisoning attacks with unsolicited RRs 8.6 High -
bind-pkcs11-libsAlmaLinux Many records in the additional section cause CPU exhaustion 7.5 High -
bind-pkcs11-libsAlmaLinux SIG(0) can be used to exhaust CPU resources 7.5 High -
bind-pkcs11-libsAlmaLinux BIND's database will be slow if a very large number of RRs exist at the same name 7.5 High -
bind-pkcs11-libsAlmaLinux The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is... 7.5 High -
bind-pkcs11-libsAlmaLinux Certain DNSSEC aspects of the DNS protocol (in RFC 4035 and related RFCs) allow remote attackers... 7.5 High -
bind-pkcs11-libsAlmaLinux Parsing large DNS messages may cause excessive CPU load 7.5 High -
bind-pkcs11-libsAlmaLinux A stack exhaustion flaw in control channel code may cause named to terminate unexpectedly 7.5 High -
bind-pkcs11-libsAlmaLinux named's configured cache size limit can be significantly exceeded 7.5 High -
bind-pkcs11-libsAlmaLinux An UPDATE message flood may cause named to exhaust all available memory 7.5 High -
bind-pkcs11-libsAlmaLinux Memory leaks in EdDSA DNSSEC verification code 7.5 High -
bind-pkcs11-libsAlmaLinux Memory leak in ECDSA DNSSEC verification code 7.5 High -
bind-pkcs11-libsAlmaLinux Processing large delegations may severely degrade resolver performance 5.3 Medium -
bind-pkcs11-libsAlmaLinux DNS forwarders - cache poisoning vulnerability 6.8 Medium -
bind-pkcs11-libsAlmaLinux Lame cache can be abused to severely degrade resolver performance 5.3 Medium -
bind-pkcs11-libsAlmaLinux A broken inbound incremental zone update (IXFR) can cause named to terminate unexpectedly 6.5 Medium