bind-pkcs11-utils vulnerabilities (AlmaLinux)
30 vulnerabilities.
-
bind-pkcs11-utilsAlmaLinux Concurrent GSS-TSIG messages corrupt memory 8.1 High -
bind-pkcs11-utilsAlmaLinux Amplified resource exhaustion in inbound message processing 7.5 High -
bind-pkcs11-utilsAlmaLinux Validating resolver can abort while caching a mismatched NOQNAME proof 7.5 High -
bind-pkcs11-utilsAlmaLinux Use-after-free in query_addnoqnameproof() via the DNS64 filter64 path 7.5 High -
bind-pkcs11-utilsAlmaLinux qpcache NOQNAME proof use-after-free crashes recursive resolver 5.9 Medium -
bind-pkcs11-utilsAlmaLinux Remote assertion failure via 16-bit length truncation in `dns_ncache_add()` 7.5 High -
bind-pkcs11-utilsAlmaLinux DNSSEC Validation Bypass via Out-of-Zone NSEC Next Field 8.6 High -
bind-pkcs11-utilsAlmaLinux Unexpected exit in certain situations with NSEC and NSEC3 both present 7.5 High -
bind-pkcs11-utilsAlmaLinux Cache poisoning possible with label count discrepancy, RRSIG, and wildcards 7.5 High -
bind-pkcs11-utilsAlmaLinux Potential memory usage beyond configured limits 7.5 High -
bind-pkcs11-utilsAlmaLinux Incorrect acceptance of NSEC3 records 6.8 Medium -
bind-pkcs11-utilsAlmaLinux Invalid handling of CLASS != IN 7.5 High -
bind-pkcs11-utilsAlmaLinux BIND 9 server memory exhaustion during GSS-API TKEY negotiation 7.5 High -
bind-pkcs11-utilsAlmaLinux Excessive NSEC3 iterations cause high CPU load during insecure delegation validation 7.5 High -
bind-pkcs11-utilsAlmaLinux Cache poisoning attacks with unsolicited RRs 8.6 High -
bind-pkcs11-utilsAlmaLinux Many records in the additional section cause CPU exhaustion 7.5 High -
bind-pkcs11-utilsAlmaLinux SIG(0) can be used to exhaust CPU resources 7.5 High -
bind-pkcs11-utilsAlmaLinux BIND's database will be slow if a very large number of RRs exist at the same name 7.5 High -
bind-pkcs11-utilsAlmaLinux The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is... 7.5 High -
bind-pkcs11-utilsAlmaLinux Certain DNSSEC aspects of the DNS protocol (in RFC 4035 and related RFCs) allow remote attackers... 7.5 High -
bind-pkcs11-utilsAlmaLinux Parsing large DNS messages may cause excessive CPU load 7.5 High -
bind-pkcs11-utilsAlmaLinux A stack exhaustion flaw in control channel code may cause named to terminate unexpectedly 7.5 High -
bind-pkcs11-utilsAlmaLinux named's configured cache size limit can be significantly exceeded 7.5 High -
bind-pkcs11-utilsAlmaLinux An UPDATE message flood may cause named to exhaust all available memory 7.5 High -
bind-pkcs11-utilsAlmaLinux Memory leaks in EdDSA DNSSEC verification code 7.5 High -
bind-pkcs11-utilsAlmaLinux Memory leak in ECDSA DNSSEC verification code 7.5 High -
bind-pkcs11-utilsAlmaLinux Processing large delegations may severely degrade resolver performance 5.3 Medium -
bind-pkcs11-utilsAlmaLinux DNS forwarders - cache poisoning vulnerability 6.8 Medium -
bind-pkcs11-utilsAlmaLinux Lame cache can be abused to severely degrade resolver performance 5.3 Medium -
bind-pkcs11-utilsAlmaLinux A broken inbound incremental zone update (IXFR) can cause named to terminate unexpectedly 6.5 Medium