bind-license vulnerabilities (Red Hat)
77 vulnerabilities.
-
bind-licenseRed Hat Validating resolver can abort while caching a mismatched NOQNAME proof 7.5 High -
bind-licenseRed Hat Use-after-free in query_addnoqnameproof() via the DNS64 filter64 path 7.5 High -
bind-licenseRed Hat SVCB AliasMode additional-data error leaks qpcache references 7.5 High -
bind-licenseRed Hat Remote assertion failure via 16-bit length truncation in `dns_ncache_add()` 7.5 High -
bind-licenseRed Hat Remote CPU denial of service through cached SVCB/HTTPS AliasMode trees 7.5 High -
bind-licenseRed Hat DNSSEC Validation Bypass via Out-of-Zone NSEC Next Field 8.6 High -
bind-licenseRed Hat Unexpected exit in certain situations with NSEC and NSEC3 both present 7.5 High -
bind-licenseRed Hat Cache poisoning possible with label count discrepancy, RRSIG, and wildcards 7.5 High -
bind-licenseRed Hat Potential memory usage beyond configured limits 7.5 High -
bind-licenseRed Hat Potential wildcard CNAME RPZ policy bypass 7.5 High -
bind-licenseRed Hat Incorrect acceptance of NSEC3 records 6.8 Medium -
bind-licenseRed Hat Invalid handling of CLASS != IN 7.5 High -
bind-licenseRed Hat BIND 9 server memory exhaustion during GSS-API TKEY negotiation 7.5 High -
bind-licenseRed Hat Excessive NSEC3 iterations cause high CPU load during insecure delegation validation 7.5 High -
bind-licenseRed Hat Resource exhaustion via malformed DNSKEY handling 7.5 High -
bind-licenseRed Hat Cache poisoning due to weak PRNG 8.6 High -
bind-licenseRed Hat Cache poisoning attacks with unsolicited RRs 8.6 High -
bind-licenseRed Hat Many records in the additional section cause CPU exhaustion 7.5 High -
bind-licenseRed Hat Assertion failure when serving both stale cache data and authoritative zone content 7.5 High -
bind-licenseRed Hat SIG(0) can be used to exhaust CPU resources 7.5 High -
bind-licenseRed Hat BIND's database will be slow if a very large number of RRs exist at the same name 7.5 High -
bind-licenseRed Hat Specific recursive query patterns may lead to an out-of-memory condition 7.5 High -
bind-licenseRed Hat Enabling both DNS64 and serve-stale may cause an assertion failure during recursive resolution 7.5 High -
bind-licenseRed Hat Querying RFC 1918 reverse zones may cause an assertion failure when "nxdomain-redirect" is enabled 7.5 High -
bind-licenseRed Hat The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is... 7.5 High -
bind-licenseRed Hat Certain DNSSEC aspects of the DNS protocol (in RFC 4035 and related RFCs) allow remote attackers... 7.5 High -
bind-licenseRed Hat Parsing large DNS messages may cause excessive CPU load 7.5 High -
bind-licenseRed Hat A stack exhaustion flaw in control channel code may cause named to terminate unexpectedly 7.5 High -
bind-licenseRed Hat named's configured cache size limit can be significantly exceeded 7.5 High -
bind-licenseRed Hat named configured to answer from stale cache may terminate unexpectedly at recursive-clients soft quota 7.5 High -
bind-licenseRed Hat named configured to answer from stale cache may terminate unexpectedly while processing RRSIG queries 7.5 High -
bind-licenseRed Hat An UPDATE message flood may cause named to exhaust all available memory 7.5 High -
bind-licenseRed Hat Memory leaks in EdDSA DNSSEC verification code 7.5 High -
bind-licenseRed Hat Memory leak in ECDSA DNSSEC verification code 7.5 High -
bind-licenseRed Hat BIND 9 resolvers configured to answer from stale cache with zero stale-answer-client-timeout may terminate unexpectedly 7.5 High -
bind-licenseRed Hat Processing large delegations may severely degrade resolver performance 5.3 Medium -
bind-licenseRed Hat DoS from specifically crafted TCP packets 5.3 Medium -
bind-licenseRed Hat DNS forwarders - cache poisoning vulnerability 6.8 Medium -
bind-licenseRed Hat Lame cache can be abused to severely degrade resolver performance 5.3 Medium -
bind-licenseRed Hat An assertion check can fail while answering queries for DNAME records that require the DNAME to be processed to resolve itself 7.5 High -
bind-licenseRed Hat A broken inbound incremental zone update (IXFR) can cause named to terminate unexpectedly 6.5 Medium -
bind-licenseRed Hat A vulnerability in BIND's GSSAPI security policy negotiation can be targeted by a buffer overflow attack 8.1 High -
bind-licenseRed Hat update-policy rules of type "subdomain" are enforced incorrectly 4.3 Medium -
bind-licenseRed Hat A flaw in native PKCS#11 code can lead to a remotely triggerable assertion failure in pk11.c 7.5 High -
bind-licenseRed Hat A truncated TSIG response can lead to an assertion failure 6.5 Medium -
bind-licenseRed Hat A buffer boundary check assertion in rdataset.c can fail incorrectly during zone transfer 4.9 Medium -
bind-licenseRed Hat A logic error in code which checks TSIG validity can be used to trigger an assertion failure in tsig.c 7.5 High -
bind-licenseRed Hat BIND does not sufficiently limit the number of fetches performed when processing referrals 8.6 High -
bind-licenseRed Hat TCP-pipelined queries can bypass tcp-clients limit 7.5 High -
bind-licenseRed Hat An oversight while backporting a feature leads to an assertion failure in buffer.c:420 5.9 Medium - Show olderLoading…